core/linux-armv5 to 3.14.0-2

This commit is contained in:
Kevin Mihelich 2014-04-09 02:25:05 +00:00
parent 70e34aac01
commit 59fb8b99b7
2 changed files with 77 additions and 0 deletions

View file

@ -0,0 +1,74 @@
From 5d77ba2d26110c678b40fd723866a17d4036de12 Mon Sep 17 00:00:00 2001
From: Lucas De Marchi <lucas.demarchi@intel.com>
Date: Tue, 18 Feb 2014 02:19:26 -0300
Subject: [PATCH 1/6] Bluetooth: allocate static minor for vhci
Commit bfacbb9 (Bluetooth: Use devname:vhci module alias for virtual HCI
driver) added the module alias to hci_vhci module so it's possible to
create the /dev/vhci node. However creating an alias without
specifying the minor doesn't allow us to create the node ahead,
triggerring module auto-load when it's first accessed.
Starting with depmod from kmod 16 we started to warn if there's a
devname alias without specifying the major and minor.
Let's do the same done for uhid, kvm, fuse and others, specifying a
fixed minor. In systems with systemd as the init the following will
happen: on early boot systemd will call "kmod static-nodes" to read
/lib/modules/$(uname -r)/modules.devname and then create the nodes. When
first accessed these "dead" nodes will trigger the module loading.
Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
Acked-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
---
Documentation/devices.txt | 1 +
drivers/bluetooth/hci_vhci.c | 3 ++-
include/linux/miscdevice.h | 1 +
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/Documentation/devices.txt b/Documentation/devices.txt
index 10378cc..04356f5 100644
--- a/Documentation/devices.txt
+++ b/Documentation/devices.txt
@@ -353,6 +353,7 @@ Your cooperation is appreciated.
133 = /dev/exttrp External device trap
134 = /dev/apm_bios Advanced Power Management BIOS
135 = /dev/rtc Real Time Clock
+ 137 = /dev/vhci Bluetooth virtual HCI driver
139 = /dev/openprom SPARC OpenBoot PROM
140 = /dev/relay8 Berkshire Products Octal relay card
141 = /dev/relay16 Berkshire Products ISO-16 relay card
diff --git a/drivers/bluetooth/hci_vhci.c b/drivers/bluetooth/hci_vhci.c
index 1ef6990..add1c6a 100644
--- a/drivers/bluetooth/hci_vhci.c
+++ b/drivers/bluetooth/hci_vhci.c
@@ -359,7 +359,7 @@ static const struct file_operations vhci_fops = {
static struct miscdevice vhci_miscdev= {
.name = "vhci",
.fops = &vhci_fops,
- .minor = MISC_DYNAMIC_MINOR,
+ .minor = VHCI_MINOR,
};
static int __init vhci_init(void)
@@ -385,3 +385,4 @@ MODULE_DESCRIPTION("Bluetooth virtual HCI driver ver " VERSION);
MODULE_VERSION(VERSION);
MODULE_LICENSE("GPL");
MODULE_ALIAS("devname:vhci");
+MODULE_ALIAS_MISCDEV(VHCI_MINOR);
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 3737f72..7bb6148 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -23,6 +23,7 @@
#define TEMP_MINOR 131 /* Temperature Sensor */
#define RTC_MINOR 135
#define EFI_RTC_MINOR 136 /* EFI Time services */
+#define VHCI_MINOR 137
#define SUN_OPENPROM_MINOR 139
#define DMAPI_MINOR 140 /* DMAPI */
#define NVRAM_MINOR 144
--
1.9.1

View file

@ -21,6 +21,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0002-Revert-mmc-mxs-use-mmc_gpio_get_ro-for-detecting-rea.patch'
'0003-Revert-mmc-mxs-use-standard-flag-for-cd-inverted.patch'
'0004-Revert-mmc-mxs-use-standard-flag-for-broken-card-det.patch'
'0005-Bluetooth-allocate-static-minor-for-vhci.patch'
'imx23-olinuxino.patch'
'gpio-clamp.patch'
'config')
@ -30,6 +31,7 @@ md5sums=('b621207b3f6ecbb67db18b13258f8ea8'
'c819b56b5d6ebe32b9ef44a0ae8fc4c2'
'2233ffb1d01de896a74e5b08a7a19152'
'49a3db56af64668f9d0eddc5020cdc87'
'1b276abe16d14e133f3f28d9c9e6bd68'
'ef1497399f2d214eff4c40d36482120a'
'eb02814c2c46d5a8cf81361bbab9abbd'
'86f483af896a10938dc92b296d4b7f03')
@ -47,6 +49,7 @@ prepare() {
patch -Np1 -i ../0002-Revert-mmc-mxs-use-mmc_gpio_get_ro-for-detecting-rea.patch
patch -Np1 -i ../0003-Revert-mmc-mxs-use-standard-flag-for-cd-inverted.patch
patch -Np1 -i ../0004-Revert-mmc-mxs-use-standard-flag-for-broken-card-det.patch
patch -Np1 -i ../0005-Bluetooth-allocate-static-minor-for-vhci.patch
# AUFS patches
cp -ru "${srcdir}/aufs3-standalone/Documentation" .