core/linux-aarch64 to 4.10.0-1

This commit is contained in:
Kevin Mihelich 2017-02-20 02:25:25 +00:00
parent 31cb35fd80
commit 5a00d16807
3 changed files with 226 additions and 88 deletions

View file

@ -1,4 +1,4 @@
From e36d607d56dc5c0cbf2cb600e7686b559ea77b44 Mon Sep 17 00:00:00 2001
From 7e89ba6ecc97cfc35857e84004105d63808c5cd7 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,7 +8,7 @@ Subject: [PATCH] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index dc989a8..912be75 100644
index 831aa33d078a..03625547d794 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -60,6 +60,7 @@
@ -19,7 +19,7 @@ index dc989a8..912be75 100644
#define CARRIER_CHECK_DELAY (2 * HZ)
@@ -80,6 +81,10 @@ static bool turbo_mode = true;
@@ -82,6 +83,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -30,7 +30,7 @@ index dc989a8..912be75 100644
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm)
{
@@ -809,8 +814,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
@@ -910,8 +915,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
}
@ -91,5 +91,5 @@ index dc989a8..912be75 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.10.2
2.11.1

View file

@ -4,10 +4,10 @@
buildarch=8
pkgbase=linux-aarch64
_srcname=linux-4.9
_srcname=linux-4.10
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform"
pkgver=4.9.11
pkgver=4.10.0
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
@ -15,21 +15,20 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'config'
'linux.preset')
md5sums=('0a68ef3615c64bd5ee54a3320e46667d'
'738953d9d33739f3a333c7ef6ce33e3d'
'b68153e7f7e4700ca631ce5383bf2659'
'0efe3393b688589232b62af5d9beb194'
md5sums=('b5e7f6b9b2fe1b6cc7bc56a3a0bfc090'
'1d852d09fa6ec38017b3ebe631c02d32'
'44a337fea317d8a8143a8d6f998a1183'
'b5ef67d6086e20de7b82265f562f88b1')
prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# ALARM patches
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch

File diff suppressed because it is too large Load diff