extra/libreoffice-fresh to 6.1.3-3

This commit is contained in:
Kevin Mihelich 2018-12-18 01:24:58 +00:00
parent 720c4de104
commit 5a33a57bb8
2 changed files with 25 additions and 1 deletions

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=6.1.3.2
pkgver=6.1.3
pkgrel=2
pkgrel=3
arch=('x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -65,6 +65,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
make-pyuno-work-with-system-wide-module-install.diff
poppler-0.70.patch
libreoffice-poppler-0.71.patch
libreoffice-poppler-0.72.patch
0001-Update-mdds-to-1.4.1.patch
0001-Update-orcus-to-0.14.0.patch
libreoffice-fresh.sh libreoffice-fresh.csh)
@ -108,6 +109,7 @@ sha256sums=('d46f38f6c48c6d2338fb97c6d0fae9b43802f9849b50817b3bcf9910f1708f44'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
'ffe1698d3db3320a9213a459e7619f4962c9792a8b256ea0fe2b7e0af1df430a'
'dc8b5b0d1a4a1fed4f5cab048cd7ecd78630725458311bcbfe0a660c82357b49'
'8e8460302a7febc9a29b32b98fb77c85910ccadc65c73e0e9997dc5aabaaeb2a'
'60560283a5e22acad7f341b16dff4a654559b36db5d49b1e59f3bb9ae9b2336c'
'28c97effbe55e43a1370ab141c676cec9daba9e3dc408bec78136dfefc892a8b'
@ -141,6 +143,8 @@ prepare() {
patch -Np1 -i ../poppler-0.70.patch
# fix build with poppler 0.71
patch -p1 -i ../libreoffice-poppler-0.71.patch
# fix build with poppler 0.72
patch -p1 -i ../libreoffice-poppler-0.72.patch
# fix build with new mdds 1.4.x, liborcus 0.14.x
# sed -i "s:mdds-1.2 >= 1.2.3:mdds-1.4 >= 1.4.2:" configure.ac

View file

@ -0,0 +1,20 @@
--- libreoffice-6.1.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig 2018-12-14 20:04:01.633697240 +0000
+++ libreoffice-6.1.3.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2018-12-14 20:04:18.020410653 +0000
@@ -555,7 +555,7 @@
LinkAction* pAction = link->getAction();
if (pAction && pAction->getKind() == actionURI)
{
- const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
std::vector<char> aEsc( lcl_escapeLineFeeds(pURI) );
@@ -757,7 +757,7 @@
aFont = it->second;
- std::vector<char> aEsc( lcl_escapeLineFeeds(aFont.familyName.getCString()) );
+ std::vector<char> aEsc( lcl_escapeLineFeeds(aFont.familyName.c_str()) );
printf( " %d %d %d %d %f %d %s",
aFont.isEmbedded,
aFont.isBold,