mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mplayer to 37224-1
This commit is contained in:
parent
e14b034388
commit
5a529ee2fb
3 changed files with 115 additions and 15 deletions
|
@ -1,5 +1,6 @@
|
|||
# $Id$
|
||||
# Maintainer : Ionut Biru <ibiru@archlinux.org>
|
||||
# Maintainer: Ionut Biru <ibiru@archlinux.org>
|
||||
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Hugo Doria <hugo@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -9,41 +10,50 @@
|
|||
|
||||
pkgbase=mplayer
|
||||
pkgname=('mplayer' 'mencoder')
|
||||
pkgver=37051
|
||||
pkgrel=2
|
||||
pkgver=37224
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=(
|
||||
'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
|
||||
'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'jack' 'libcaca'
|
||||
'x264' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
|
||||
'x264-dev' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
|
||||
'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'fribidi' 'unzip' 'mesa'
|
||||
'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
|
||||
'libcdio-paranoia' 'opus'
|
||||
'libcdio-paranoia' 'opus' 'subversion'
|
||||
)
|
||||
license=('GPL')
|
||||
url='http://www.mplayerhq.hu/'
|
||||
options=('!buildflags' '!emptydirs')
|
||||
source=(http://mirrors.kernel.org/archlinux/other/$pkgbase/$pkgbase-$pkgver.tar.xz{,.sig}
|
||||
http://ffmpeg.org/releases/ffmpeg-2.2.tar.bz2
|
||||
source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
|
||||
http://ffmpeg.org/releases/ffmpeg-2.2.3.tar.bz2
|
||||
mplayer.desktop
|
||||
cdio-includes.patch
|
||||
include-samba-4.0.patch)
|
||||
md5sums=('0407ab1f9613dcd6bce06a80ac0b028b'
|
||||
'SKIP'
|
||||
'744febca199548c9393b1f1ed05ccdd8'
|
||||
include-samba-4.0.patch
|
||||
giflib51.patch
|
||||
revert-icl-fixes.patch)
|
||||
md5sums=('SKIP'
|
||||
'dbb5b6b69bd010916f17df0ae596e0b1'
|
||||
'62f44a58f072b2b1a3c3d3e4976d64b3'
|
||||
'7b5be7191aafbea64218dc4916343bbc'
|
||||
'868a92bdef148df7f38bfa992b26ce9d')
|
||||
'868a92bdef148df7f38bfa992b26ce9d'
|
||||
'14461fb94b7aa5dda091ba4f737df2d9'
|
||||
'3579402002b7302fdf2d146639333efd')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgbase-$pkgver
|
||||
svnversion
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$pkgver
|
||||
mv ../ffmpeg-2.2 ./ffmpeg
|
||||
mv ../ffmpeg-2.2.3 ./ffmpeg
|
||||
|
||||
patch -p0 -i ../cdio-includes.patch
|
||||
patch -p1 -i ../include-samba-4.0.patch
|
||||
patch -Np0 -i ../giflib51.patch
|
||||
patch -Np0 -i ../revert-icl-fixes.patch
|
||||
|
||||
echo "#define VERSION \"SVN-r$pkgver\"" > version.h
|
||||
echo '#define MP_TITLE "%s "VERSION" (C) 2000-2014 MPlayer Team\n"' >> version.h
|
||||
./version.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
24
extra/mplayer/giflib51.patch
Normal file
24
extra/mplayer/giflib51.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- libvo/vo_gif89a.c.orig 2014-06-11 10:06:29.243216331 +0000
|
||||
+++ libvo/vo_gif89a.c 2014-06-11 10:08:37.346078847 +0000
|
||||
@@ -75,6 +75,9 @@
|
||||
#define MakeMapObject GifMakeMapObject
|
||||
#define FreeMapObject GifFreeMapObject
|
||||
#define QuantizeBuffer GifQuantizeBuffer
|
||||
+#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
|
||||
+#define EGifCloseFile(a) EGifCloseFile(a, NULL)
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
// how many frames per second we are aiming for during output.
|
||||
--- libmpdemux/demux_gif.c.orig 2014-06-11 10:46:48.120883788 +0000
|
||||
+++ libmpdemux/demux_gif.c 2014-06-11 10:47:28.290732272 +0000
|
||||
@@ -50,6 +50,9 @@
|
||||
#define DGifOpenFileHandle(a) DGifOpenFileHandle(a, NULL)
|
||||
#define GifError() (gif ? gif->Error : 0)
|
||||
#define GifErrorString() GifErrorString(gif->Error)
|
||||
+#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
|
||||
+#define DGifCloseFile(a) DGifCloseFile(a, NULL)
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
/* >= 4.2 prior GIFLIB did not have MAJOR/MINOR defines */
|
66
extra/mplayer/revert-icl-fixes.patch
Normal file
66
extra/mplayer/revert-icl-fixes.patch
Normal file
|
@ -0,0 +1,66 @@
|
|||
Index: libmpcodecs/vf_fspp.c
|
||||
===================================================================
|
||||
--- libmpcodecs/vf_fspp.c (revision 37183)
|
||||
+++ libmpcodecs/vf_fspp.c (revision 37181)
|
||||
@@ -1598,10 +1598,6 @@
|
||||
|
||||
: "+S"(data), "+D"(output), "+c"(cnt), "=o"(temps)
|
||||
: "d"(thr_adr)
|
||||
- NAMED_CONSTRAINTS_ADD(ff_MM_FIX_0_707106781,MM_2,MM_FIX_1_414213562_A,MM_FIX_1_414213562,MM_FIX_0_382683433,
|
||||
- ff_MM_FIX_0_541196100,MM_FIX_1_306562965,MM_FIX_0_847759065)
|
||||
- NAMED_CONSTRAINTS_ADD(MM_FIX_0_566454497,MM_FIX_0_198912367,MM_FIX_2_613125930,MM_FIX_1_847759065,
|
||||
- MM_FIX_1_082392200)
|
||||
: "%"REG_a
|
||||
);
|
||||
}
|
||||
@@ -1871,8 +1867,6 @@
|
||||
|
||||
: "+S"(workspace), "+D"(output_adr), "+c"(cnt), "=o"(temps)
|
||||
: "a"(output_stride*sizeof(short))
|
||||
- NAMED_CONSTRAINTS_ADD(MM_FIX_1_414213562_A,MM_FIX_2_613125930,MM_FIX_1_847759065,MM_FIX_1_082392200,
|
||||
- MM_FIX_1_414213562,MM_DESCALE_RND)
|
||||
: "%"REG_d
|
||||
);
|
||||
}
|
||||
@@ -1980,10 +1974,10 @@
|
||||
"movd (%%"REG_S",%%"REG_a",2), %%mm3 \n\t" //5
|
||||
"paddw %%mm4, %%mm1 \n\t"
|
||||
|
||||
- "movq %%mm5, %3 \n\t" //t7
|
||||
+ "movq %%mm5, 0*8+%3 \n\t" //t7
|
||||
"punpcklbw %%mm7, %%mm3 \n\t"
|
||||
|
||||
- "movq %%mm6, %4 \n\t" //t6
|
||||
+ "movq %%mm6, 1*8+%3 \n\t" //t6
|
||||
"movq %%mm2, %%mm4 \n\t"
|
||||
|
||||
"movd (%%"REG_S"), %%mm5 \n\t" //3
|
||||
@@ -2029,7 +2023,7 @@
|
||||
"psubw %%mm1, %%mm5 \n\t" //d1
|
||||
"movq %%mm0, %%mm6 \n\t"
|
||||
|
||||
- "movq %4, %%mm1 \n\t"
|
||||
+ "movq 1*8+%3, %%mm1 \n\t"
|
||||
"punpcklwd %%mm5, %%mm0 \n\t"
|
||||
|
||||
"punpckhwd %%mm5, %%mm6 \n\t"
|
||||
@@ -2053,7 +2047,7 @@
|
||||
"movq %%mm7, "DCTSIZE_S"*3*2(%%"REG_D") \n\t"
|
||||
"psllw $2, %%mm3 \n\t" //t10
|
||||
|
||||
- "movq %3, %%mm2 \n\t"
|
||||
+ "movq 0*8+%3, %%mm2 \n\t"
|
||||
"psllw $2, %%mm4 \n\t" //t11
|
||||
|
||||
"pmulhw "MANGLE(MM_FIX_0_707106781)", %%mm4 \n\t" //z3
|
||||
@@ -2116,9 +2110,8 @@
|
||||
"dec %%"REG_c" \n\t"
|
||||
"jnz 6b \n\t"
|
||||
|
||||
- : "+S"(pixels), "+D"(data), "+c"(cnt), "=o"(temps), "=o"(temps[1])
|
||||
+ : "+S"(pixels), "+D"(data), "+c"(cnt), "=o"(temps)
|
||||
: "a"(line_size)
|
||||
- NAMED_CONSTRAINTS_ADD(ff_MM_FIX_0_707106781,ff_MM_FIX_0_541196100,MM_FIX_0_382683433,MM_FIX_1_306562965)
|
||||
: "%"REG_d);
|
||||
}
|
||||
|
Loading…
Reference in a new issue