extra/netpbm to 10.69.02-1

This commit is contained in:
Kevin Mihelich 2015-01-09 01:17:24 +00:00
parent 71a563138e
commit 5a7932ec9f
2 changed files with 6 additions and 17 deletions

View file

@ -5,14 +5,14 @@
# - add armv7h for -fPIC flag
pkgname=netpbm
pkgver=10.67.00
pkgver=10.69.02
pkgrel=1
pkgdesc="A toolkit for manipulation of graphic images"
arch=('i686' 'x86_64')
license=('custom' 'BSD' 'GPL' 'LGPL')
url="http://netpbm.sourceforge.net/"
depends=('perl' 'libpng' 'libtiff' 'libxml2')
makedepends=('python2' 'jbigkit')
makedepends=('python2' 'jbigkit' 'subversion')
options=('!makeflags')
# Get docs with: wget --recursive --relative -nH http://netpbm.sourceforge.net/doc/
source=(svn://svn.code.sf.net/p/netpbm/code/advanced
@ -22,8 +22,9 @@ sha1sums=('SKIP'
'25a58975bd8cd383238b4ae31f4405c60914faac'
'SKIP'
'b79cf9d42488fea065ba16262ed97694c47af08d'
'4e9d91516d79d2099ba4bd47434e6bb12c52bcc4'
'313e040ea74eb73675aa420b6f54e1f4452c4769'
'c67a63c010353de3ecac3ad72ba76bbb85e4ed4c')
validpgpkeys=('5357F3B111688D88C1D88119FCF2CB179205AC90')
pkgver() {
cd advanced

View file

@ -768,9 +768,9 @@ diff -up netpbm-10.58.01/converter/ppm/ppmtopict.c.security-code netpbm-10.58.01
/* Finally, write out the data. */
+ overflow_add(cols/MAX_COUNT, 1);
+ overflow_add(cols, cols/MAX_COUNT+1);
packed = malloc((unsigned)(cols+cols/MAX_COUNT+1));
outBuf = malloc((unsigned)(cols+cols/MAX_COUNT+1));
for (row = 0, oc = 0; row < rows; row++)
oc += putRow(stdout, row, cols, pixels[row], packed);
unsigned int rowSize;
diff -up netpbm-10.58.01/converter/ppm/ppmtopj.c.security-code netpbm-10.58.01/converter/ppm/ppmtopj.c
--- netpbm-10.58.01/converter/ppm/ppmtopj.c.security-code 2012-04-09 15:31:44.000000000 +0200
+++ netpbm-10.58.01/converter/ppm/ppmtopj.c 2012-04-09 15:40:03.212619677 +0200
@ -1145,18 +1145,6 @@ diff -up netpbm-10.58.01/generator/pbmtext.c.security-code netpbm-10.58.01/gener
hmargin = 2 * fontP->maxwidth;
}
}
diff -up netpbm-10.58.01/generator/pgmcrater.c.security-code netpbm-10.58.01/generator/pgmcrater.c
--- netpbm-10.58.01/generator/pgmcrater.c.security-code 2012-04-09 15:31:34.000000000 +0200
+++ netpbm-10.58.01/generator/pgmcrater.c 2012-04-09 15:40:03.226619502 +0200
@@ -130,7 +130,7 @@ static void gencraters()
/* Acquire the elevation array and initialize it to mean
surface elevation. */
- MALLOCARRAY(aux, SCRX * SCRY);
+ aux = (unsigned short *) malloc3(SCRX, SCRY, sizeof(short));
if (aux == NULL)
pm_error("out of memory allocating elevation array");
diff -up netpbm-10.58.01/lib/libpam.c.security-code netpbm-10.58.01/lib/libpam.c
--- netpbm-10.58.01/lib/libpam.c.security-code 2012-04-09 15:31:38.000000000 +0200
+++ netpbm-10.58.01/lib/libpam.c 2012-04-09 15:40:03.227619490 +0200