mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/distcc: patch fix
This commit is contained in:
parent
fabc6e69c1
commit
5ab4f9a529
2 changed files with 11 additions and 3 deletions
|
@ -28,7 +28,7 @@ source=(http://distcc.googlecode.com/files/${pkgname}-${pkgver}.tar.bz2
|
||||||
md5sums=('18cd4f33f5cfc3e75675cafc568fb9cf'
|
md5sums=('18cd4f33f5cfc3e75675cafc568fb9cf'
|
||||||
'239aae53250e3e35288cba566bc0bbf1'
|
'239aae53250e3e35288cba566bc0bbf1'
|
||||||
'09f0688da9c1840e518d2593bd5c3830'
|
'09f0688da9c1840e518d2593bd5c3830'
|
||||||
'211e96f2c920d10cd5284e4fc075d559')
|
'6d6abde46f321355eb0eaafc03c2ad1d')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
|
|
|
@ -1,7 +1,15 @@
|
||||||
diff -urN a/src/io.c b/src/io.c
|
diff -urN a/src/io.c b/src/io.c
|
||||||
--- a/src/io.c 2011-04-05 12:58:58.000000000 -0600
|
--- a/src/io.c 2011-04-05 12:58:58.000000000 -0600
|
||||||
+++ b/src/io.c 2014-07-07 05:37:25.074543921 -0600
|
+++ b/src/io.c 2014-07-07 05:44:18.668161665 -0600
|
||||||
@@ -75,11 +75,10 @@
|
@@ -43,6 +43,7 @@
|
||||||
|
#include <string.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <errno.h>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
@@ -75,11 +76,10 @@
|
||||||
const char *user_timeout = getenv("DISTCC_IO_TIMEOUT");
|
const char *user_timeout = getenv("DISTCC_IO_TIMEOUT");
|
||||||
if (user_timeout) {
|
if (user_timeout) {
|
||||||
int parsed_user_timeout = atoi(user_timeout);
|
int parsed_user_timeout = atoi(user_timeout);
|
||||||
|
|
Loading…
Reference in a new issue