extra/boost to 1.56.0-2

This commit is contained in:
Kevin Mihelich 2014-10-12 22:32:02 +00:00
parent f51ba9758b
commit 5b029638bf
3 changed files with 33 additions and 16 deletions

View file

@ -1,13 +0,0 @@
Index: libs/log/src/dump_avx2.cpp
===================================================================
--- libs/log/src/dump_avx2.cpp (revision 86614)
+++ libs/log/src/dump_avx2.cpp (working copy)
@@ -205,7 +205,7 @@
__m256i mm_input = _mm256_load_si256(reinterpret_cast< const __m256i* >(p));
__m256i mm_output1, mm_output2, mm_output3;
dump_pack(mm_char_10_to_a, mm_input, mm_output1, mm_output2, mm_output3);
- store_characters_x3(mm_output1, mm_output2, mm_output3, buf);
+ store_characters_x3(mm_output1, mm_output2, mm_output3, b);
}
_mm256_zeroall(); // need to zero all ymm registers to avoid register spills/restores the compler generates around the function call

View file

@ -15,13 +15,20 @@ pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.56.0
_boostver=${pkgver//./_}
pkgrel=1
pkgrel=2
url='http://www.boost.org/'
arch=('i686' 'x86_64')
license=('custom')
makedepends=('icu>=53.1' 'python' 'python2' 'bzip2' 'zlib')
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
sha1sums=('1639723c6bdff873cdb6d747f8f8c9d9f066434d')
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
boost-1.56.0-add-missing-headers-to-shared_ptr_helper.patch)
sha1sums=('1639723c6bdff873cdb6d747f8f8c9d9f066434d'
'5d611ad72005d1fb939ea783603861d2cb29433a')
prepare() {
cd ${pkgbase}_${_boostver}
patch -p2 -i ../boost-1.56.0-add-missing-headers-to-shared_ptr_helper.patch
}
build() {
CFLAGS=`echo $CFLAGS | sed -e 's/armv6/armv6k/'` && CXXFLAGS="$CFLAGS"

View file

@ -0,0 +1,23 @@
From e70f330af74e902d4f1b1f4891a34d315cc09963 Mon Sep 17 00:00:00 2001
From: Gary Mirams <gary.mirams@gmail.com>
Date: Mon, 11 Aug 2014 14:41:49 +0100
Subject: [PATCH] Update the #includes in shared_ptr_helper.hpp to avoid
'singleton' is not a member of 'boost::serialization' errors on compilation
---
include/boost/serialization/shared_ptr_helper.hpp | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/boost/serialization/shared_ptr_helper.hpp b/include/boost/serialization/shared_ptr_helper.hpp
index 9dace87..78995d4 100644
--- a/include/boost/serialization/shared_ptr_helper.hpp
+++ b/include/boost/serialization/shared_ptr_helper.hpp
@@ -26,6 +26,8 @@
#include <boost/type_traits/is_polymorphic.hpp>
#include <boost/mpl/if.hpp>
+#include <boost/serialization/singleton.hpp>
+#include <boost/serialization/extended_type_info.hpp>
#include <boost/serialization/type_info_implementation.hpp>
#include <boost/serialization/throw_exception.hpp>
#include <boost/archive/archive_exception.hpp>