mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-aarch64 to 6.2.0-1
This commit is contained in:
parent
9beb02ff37
commit
5b197b6168
4 changed files with 605 additions and 359 deletions
|
@ -1,4 +1,4 @@
|
||||||
From 89d947a0151b40ba6855d9a9e64ebd466cd64064 Mon Sep 17 00:00:00 2001
|
From 648bf1e655cc1a82a32b1b556b2ecbdb03ab3a72 Mon Sep 17 00:00:00 2001
|
||||||
From: popcornmix <popcornmix@gmail.com>
|
From: popcornmix <popcornmix@gmail.com>
|
||||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||||
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
1 file changed, 56 insertions(+)
|
1 file changed, 56 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||||
index 4dc43929e370..75e8736e3a73 100644
|
index bfb58c91db04..29b7c4cb90f1 100644
|
||||||
--- a/drivers/net/usb/smsc95xx.c
|
--- a/drivers/net/usb/smsc95xx.c
|
||||||
+++ b/drivers/net/usb/smsc95xx.c
|
+++ b/drivers/net/usb/smsc95xx.c
|
||||||
@@ -54,6 +54,7 @@
|
@@ -54,6 +54,7 @@
|
||||||
|
@ -27,10 +27,10 @@ index 4dc43929e370..75e8736e3a73 100644
|
||||||
+module_param(macaddr, charp, 0);
|
+module_param(macaddr, charp, 0);
|
||||||
+MODULE_PARM_DESC(macaddr, "MAC address");
|
+MODULE_PARM_DESC(macaddr, "MAC address");
|
||||||
+
|
+
|
||||||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
static int __must_check smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||||
u32 *data, int in_pm)
|
u32 *data)
|
||||||
{
|
{
|
||||||
@@ -805,8 +810,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
@@ -761,8 +766,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||||
return phy_mii_ioctl(netdev->phydev, rq, cmd);
|
return phy_mii_ioctl(netdev->phydev, rq, cmd);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From b07c9b386a2ed138077bbde72237b97ffacedc31 Mon Sep 17 00:00:00 2001
|
From 211c3554b29218bfbf5b0de482a686b427a6f8c1 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
||||||
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||||
|
@ -9,7 +9,7 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||||
index b340c9e246c4..2fba5e42e287 100644
|
index c5db64f3e124..a3c36c7364b3 100644
|
||||||
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||||
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||||
@@ -751,7 +751,7 @@ wifi_host_wake_l: wifi-host-wake-l {
|
@@ -751,7 +751,7 @@ wifi_host_wake_l: wifi-host-wake-l {
|
||||||
|
|
|
@ -4,18 +4,18 @@
|
||||||
buildarch=8
|
buildarch=8
|
||||||
|
|
||||||
pkgbase=linux-aarch64
|
pkgbase=linux-aarch64
|
||||||
_srcname=linux-5.19
|
_srcname=linux-6.2
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="AArch64 multi-platform"
|
_desc="AArch64 multi-platform"
|
||||||
pkgver=5.19.8
|
pkgver=6.2.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('aarch64')
|
arch=('aarch64')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
source=("http://www.kernel.org/pub/linux/kernel/v6.x/${_srcname}.tar.xz"
|
||||||
"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
|
#"http://www.kernel.org/pub/linux/kernel/v6.x/patch-${pkgver}.xz"
|
||||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||||
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
|
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
|
||||||
'config'
|
'config'
|
||||||
|
@ -25,11 +25,10 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
||||||
'linux.preset'
|
'linux.preset'
|
||||||
'60-linux.hook'
|
'60-linux.hook'
|
||||||
'90-linux.hook')
|
'90-linux.hook')
|
||||||
md5sums=('f91bfe133d2cb1692f705947282e123a'
|
md5sums=('787862593d7bf354cf1a5c37e21fc147'
|
||||||
'702a69746536f24fd5ebde90eed26048'
|
'7b08a199a97e3e2288e5c03d8e8ded2d'
|
||||||
'e0514a3e8f7383c1304faeff0121dfb5'
|
'c9d4e392555b77034e24e9f87c5ff0b3'
|
||||||
'965c9f68072084cdbf1e083779d2ef0e'
|
'b340d56c70f074480d723ddabd96a515'
|
||||||
'417932cd6167ff0b47c6dc297e3eb3fb'
|
|
||||||
'7c97cf141750ad810235b1ad06eb9f75'
|
'7c97cf141750ad810235b1ad06eb9f75'
|
||||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||||
'584777ae88bce2c5659960151b64c7d8'
|
'584777ae88bce2c5659960151b64c7d8'
|
||||||
|
@ -46,7 +45,7 @@ prepare() {
|
||||||
echo "${pkgbase#linux}" > localversion.20-pkgname
|
echo "${pkgbase#linux}" > localversion.20-pkgname
|
||||||
|
|
||||||
# add upstream patch
|
# add upstream patch
|
||||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
#git apply --whitespace=nowarn ../patch-${pkgver}
|
||||||
|
|
||||||
# ALARM patches
|
# ALARM patches
|
||||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue