removed extra/gstreamer0.10-bad

This commit is contained in:
Kevin Mihelich 2017-01-23 14:40:09 +00:00
parent 226f64dee6
commit 5b4a891df1
7 changed files with 0 additions and 190 deletions

View file

@ -1,80 +0,0 @@
# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - disable soundtouch extension on v5, currently broken
pkgbase=gstreamer0.10-bad
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
pkgver=0.10.23
pkgrel=20
arch=('i686' 'x86_64')
license=('LGPL' 'GPL')
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'git' 'spandsp' 'celt')
url="http://gstreamer.freedesktop.org/"
options=(!emptydirs)
source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
fix-libmodplug-include.patch
drop-vpx-compat-defs.patch
disable-assrender-test.patch
disable-camerabin-test.patch
faad2-version-check.patch
wildmidi-0.4.patch)
sha256sums=('SKIP'
'd89d8f4307c7d5a143b9240467d260a1cb6bb1ab2e7ca57841ce0901f41c9cb7'
'eb97037b7b581d1ab994eadd144044c083975e5670a73ec827de126bf888f4b9'
'e66642affa6c0e69837d37615010e67e59ef3d672663303d46c1e2591e2ddfc6'
'01e780ddf1f8161a6115dded9dc5bf4bdd4d09a9eee00fa423b1330e90e76c68'
'741492ae7a9518603fc51d87ae331d882f075547ea7fdec19c60f399085f18cc'
'7a8698df3b53c34c627c00d3b025045818898cedc5ee7ffa13272d8758fcefd2')
prepare() {
cd gst-plugins-bad
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
patch -Np1 -i ../fix-libmodplug-include.patch
patch -Np1 -i ../drop-vpx-compat-defs.patch
patch -Np1 -i ../disable-assrender-test.patch
patch -Np1 -i ../disable-camerabin-test.patch
patch -Np1 -i ../faad2-version-check.patch
patch -Np1 -i ../wildmidi-0.4.patch
}
build() {
cd gst-plugins-bad
NOCONFIGURE=1 ./autogen.sh
[[ $CARCH == 'arm' ]] && CONFIG="--disable-soundtouch"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-static --enable-experimental --disable-gtk-doc \
--with-package-name="GStreamer Bad Plugins (Archlinux)" \
--with-package-origin="http://www.archlinux.org/" $CONFIG
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
sed -e 's/gst sys ext/gst/' -i Makefile
}
check() {
cd gst-plugins-bad
make check
}
package_gstreamer0.10-bad() {
pkgdesc="GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad)"
depends=('gstreamer0.10-base>=0.10.34')
cd gst-plugins-bad
make DESTDIR="${pkgdir}" install
}
package_gstreamer0.10-bad-plugins() {
pkgdesc="GStreamer Multimedia Framework Bad Plugins (gst-plugins-bad)"
depends=("gstreamer0.10-bad=${pkgver}" 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'libvdpau' 'soundtouch' 'libass' 'schroedinger' 'libvpx' 'gsm' 'rtmpdump' 'libgme' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'celt' 'spandsp')
groups=('gstreamer0.10-plugins')
cd gst-plugins-bad
make -C gst-libs DESTDIR="${pkgdir}" install
make -C ext DESTDIR="${pkgdir}" install
make -C sys DESTDIR="${pkgdir}" install
make -C gst-libs DESTDIR="${pkgdir}" uninstall
}

View file

@ -1,11 +0,0 @@
--- a/tests/check/elements/assrender.c
+++ b/tests/check/elements/assrender.c
@@ -289,8 +289,6 @@ assrender_suite (void)
tcase_set_timeout (tc_chain, 120);
suite_add_tcase (s, tc_chain);
- tcase_add_test (tc_chain, test_assrender_basic_xRGB);
- tcase_add_test (tc_chain, test_assrender_basic_I420);
return s;
}

View file

@ -1,10 +0,0 @@
--- gst-plugins-bad/tests/check/Makefile.am.orig 2013-12-10 22:01:50.504567189 +0000
+++ gst-plugins-bad/tests/check/Makefile.am 2013-12-10 22:02:17.081058500 +0000
@@ -181,7 +181,6 @@
elements/autovideoconvert \
elements/asfmux \
elements/baseaudiovisualizer \
- elements/camerabin \
elements/camerabin2 \
elements/dataurisrc \
elements/legacyresample \

View file

@ -1,26 +0,0 @@
--- gst-plugins-bad.orig/ext/vp8/gstvp8utils.h 2015-04-21 03:31:33.134952881 +0300
+++ gst-plugins-bad/ext/vp8/gstvp8utils.h 2015-04-21 03:32:45.553520671 +0300
@@ -25,23 +25,6 @@
G_BEGIN_DECLS
-/* Some compatibility defines for older libvpx versions */
-#ifndef VPX_IMG_FMT_I420
-#define VPX_IMG_FMT_I420 IMG_FMT_I420
-#endif
-
-#ifndef VPX_PLANE_Y
-#define VPX_PLANE_Y PLANE_Y
-#endif
-
-#ifndef VPX_PLANE_U
-#define VPX_PLANE_U PLANE_U
-#endif
-
-#ifndef VPX_PLANE_V
-#define VPX_PLANE_V PLANE_V
-#endif
-
const char * gst_vpx_error_name (vpx_codec_err_t status);
G_END_DECLS

View file

@ -1,35 +0,0 @@
From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
From: Wim Taymans <wtaymans@redhat.com>
Date: Wed, 13 May 2015 16:23:26 +0200
Subject: fix faad2 version check
On fedora 22, the output of cpp inserts extra debug comments, which
makes our regexp for the faad2 version check fail. This in turn causes
it to compile with the wrong arguments passed which then causes stack
corruption and crashes.
Fix this by only checking for the version (which should be by itself on
a single line). This is potentially less safe, it might be possible that
a similar string would appear in a later version in the header file.
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
diff --git a/configure.ac b/configure.ac
index f5ce28c..d295253 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
for minor in 10 9 8 7 6 5 0; do
if test x$faad2_minor_version = "x"; then
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
+ AC_EGREP_CPP([\"2\.$minor\"$], [
#include <$faad_hdr>
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
+ FAAD2_VERSION
], [
faad2_minor_version=$minor
])
--
cgit v0.10.2

View file

@ -1,12 +0,0 @@
diff -uprw gst-plugins-bad.orig/ext/modplug/gstmodplug.cc gst-plugins-bad/ext/modplug/gstmodplug.cc
--- gst-plugins-bad.orig/ext/modplug/gstmodplug.cc 2015-04-21 03:15:25.929456272 +0300
+++ gst-plugins-bad/ext/modplug/gstmodplug.cc 2015-04-21 03:18:54.624976723 +0300
@@ -50,7 +50,7 @@
#define WORDS_BIGENDIAN 0
#endif
-#include <stdafx.h>
+#include <libmodplug/stdafx.h>
#include <libmodplug/sndfile.h>
#include "gstmodplug.h"

View file

@ -1,16 +0,0 @@
Old versions used char* for the data, new versions use int8_t*. They're often
not the same and differ in signedness.
(backported from 04199db2aeea966c2c879b1764427c87433570f1)
--- a/ext/timidity/gstwildmidi.c
+++ b/ext/timidity/gstwildmidi.c
@@ -631,7 +631,7 @@
size = GST_BUFFER_SIZE (buffer);
GST_OBJECT_LOCK (wildmidi);
- bytes_read = WildMidi_GetOutput (wildmidi->song, (char *) data,
+ bytes_read = WildMidi_GetOutput (wildmidi->song, (gpointer *) data,
(unsigned long int) size);
GST_OBJECT_UNLOCK (wildmidi);