mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
aur updates
This commit is contained in:
parent
69ffb516fd
commit
5b56ddd3c8
9 changed files with 25 additions and 46 deletions
|
@ -34,8 +34,8 @@ SRC=linux/XMemUtils.cpp \
|
|||
SubtitleRenderer.cpp \
|
||||
Unicode.cpp \
|
||||
Srt.cpp \
|
||||
KeyConfig.cpp \
|
||||
omxplayer.cpp \
|
||||
KeyConfig.cpp \
|
||||
omxplayer.cpp
|
||||
|
||||
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
|
||||
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=18
|
||||
|
||||
pkgname=omxplayer-git
|
||||
pkgver=251.38f05ee
|
||||
pkgver=262.9b52cee
|
||||
pkgrel=1
|
||||
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
|
||||
arch=('arm' 'armv6h')
|
||||
|
@ -44,6 +44,6 @@ package() {
|
|||
}
|
||||
|
||||
md5sums=('SKIP'
|
||||
'305f8fedbc4638434475c4a83ee78578'
|
||||
'5c0e2eaa325baad852c762d3030eb52e'
|
||||
'b256bd3a81a974543a0afc62b62e5c28'
|
||||
'462e40e8da2e2b10cb32138e7885d285'
|
||||
'a8635442d02665944c04c18606453a04')
|
||||
|
|
|
@ -3,11 +3,18 @@
|
|||
[ -e /usr/bin/omxplayer.bin ] && OMXPLAYER="/usr/bin/omxplayer.bin" || exit 255
|
||||
|
||||
FNTOPT=
|
||||
#OMXFONT=${OMXFONT:-/usr/share/fonts/TTF/FreeSans.ttf}
|
||||
if [ -e /usr/share/fonts/TTF/FreeSans.ttf ]; then
|
||||
FNTOPT=$FNTOPT" --font /usr/share/fonts/TTF/FreeSans.ttf"
|
||||
fi
|
||||
|
||||
[ -n "$OMXFONT" -a -e "$OMXFONT" ] && FNTOPT="--font $OMXFONT"
|
||||
if [ -e /usr/share/fonts/TTF/FreeSansOblique.ttf ]; then
|
||||
FNTOPT=$FNTOPT" --italic-font /usr/share/fonts/TTF/FreeSansOblique.ttf"
|
||||
fi
|
||||
|
||||
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
|
||||
eval $(dbus-launch --sh-syntax)
|
||||
fi
|
||||
|
||||
[ $# = 0 ] && exec $OMXPLAYER --help || \
|
||||
[ "$1" = '-h' -o "$1" = '--help' ] && exec $OMXPLAYER --help || \
|
||||
clear ; exec $OMXPLAYER $FNTOPT "$@" >/dev/null 2>&1
|
||||
|
||||
clear ; exec $OMXPLAYER$FNTOPT "$@" #>/dev/null 2>&1
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From 698a95edb64941495b781451a1e323155fe87c5f Mon Sep 17 00:00:00 2001
|
||||
From: Nuno Araujo <nuno.araujo@russo79.com>
|
||||
Date: Wed, 16 Jan 2013 09:27:03 +0100
|
||||
Subject: [PATCH] Fix the build with automake 1.13
|
||||
|
||||
In Automake 1.13, the long-deprecated macro AM_CONFIG_HEADER (deprecated
|
||||
since 2002) has been removed in favour of AC_CONFIG_HEADERS.
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index fad886d..83176e4 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
AC_PREREQ(2.59)
|
||||
AC_INIT([xrdp], [0.6.0], [xrdp-devel@lists.sourceforge.net])
|
||||
-AM_CONFIG_HEADER(config_ac.h:config_ac-h.in)
|
||||
+AC_CONFIG_HEADERS(config_ac.h:config_ac-h.in)
|
||||
AM_INIT_AUTOMAKE([1.6 foreign])
|
||||
AC_PROG_CC
|
||||
AC_C_CONST
|
||||
--
|
||||
1.8.1.1
|
||||
|
|
@ -2,25 +2,22 @@
|
|||
# Maintainer: techryda <techryda at silentdome dot com>
|
||||
# Contributor: Mathias R. <pu154r@overlinux.org>
|
||||
pkgname=xrdp
|
||||
pkgver=0.6.0
|
||||
pkgrel=6
|
||||
pkgver=0.6.1
|
||||
pkgrel=1
|
||||
pkgdesc="An open source remote desktop protocol (RDP) server"
|
||||
url="http://xrdp.sourceforge.net/"
|
||||
arch=('arm' 'armv6h' 'armv7h')
|
||||
arch=('i686' 'x86_64' 'armv6h')
|
||||
license=('GPL')
|
||||
depends=('tigervnc')
|
||||
source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-v$pkgver.tar.gz"
|
||||
'xrdp.service'
|
||||
'xrdp-sesman.service'
|
||||
'0001-Fix-the-build-with-automake-1.13.patch')
|
||||
md5sums=('b2577256b5a34bd72849cd40375c92de'
|
||||
'xrdp-sesman.service')
|
||||
md5sums=('26099c6588943262023607c1b4e774d8'
|
||||
'0cb760b3e8a34f9bdf4daa871444d74c'
|
||||
'58eb44bdc7ca5bb436d6fd66826f9b0f'
|
||||
'dd097b937263565e34b6526560ac00a3')
|
||||
'58eb44bdc7ca5bb436d6fd66826f9b0f')
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-v${pkgver}"
|
||||
patch < ../0001-Fix-the-build-with-automake-1.13.patch
|
||||
# Fix path in xrdp.sh file
|
||||
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
|
||||
}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
# Maintainer: Aurélien Wailly <aurelien.wailly@gmail.com>
|
||||
|
||||
plugrel=1
|
||||
# Remove when bumped upstream
|
||||
|
||||
pkgname=protobuf-c
|
||||
pkgver=0.15
|
|
@ -1,6 +1,8 @@
|
|||
# Maintainer: Robert Knauer <robert@privatdemail.net>
|
||||
# Contributor : xav <xav at ethertricks dot net>
|
||||
|
||||
# Remove when bumped upstream
|
||||
|
||||
pkgname=umurmur
|
||||
pkgver=0.2.13
|
||||
pkgrel=1
|
Loading…
Reference in a new issue