extra/ntp to 4.2.8.p16-1

This commit is contained in:
Kevin Mihelich 2023-06-03 18:58:42 +00:00
parent 44950eb92a
commit 5b5abc02d1
2 changed files with 12 additions and 44 deletions

View file

@ -7,47 +7,43 @@
pkgname=ntp
_pkgname=ntp #-dev
_pkgver=4.2.8p15
_pkgver=4.2.8p16
pkgver=${_pkgver/p/.p}
pkgrel=3
pkgrel=1
pkgdesc='Network Time Protocol reference implementation'
url='http://www.ntp.org/'
url='https://www.ntp.org/'
license=('custom')
arch=('x86_64')
depends=('openssl' 'perl' 'libcap' 'libedit')
backup=('etc/ntp.conf')
source=("https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${_pkgname}-${_pkgver}.tar.gz"
'ntp-4.2.8_p15-glibc-2.34.patch'
'0001-disable-pthread-warmup-on-ARM.patch'
'ntp.conf'
'ntpd.service'
'ntpdate.service'
'ntp.sysusers')
sha1sums=('e34e5b6f48c3ed1bbcfb03080dec1b8f91e19381'
'1423b8ef72a3806ed74affc1973f66ed7cfa2afb'
'ec9bd3894b65edca8efdb34ce12b3eb144336294'
'ad1d6ee2e9aca64a84a7224c88bf6008ac6c69e1'
'0cccca872385e0142888ab48d273fec0669b30a8'
'059b382d1af0c55202e2d17f2ae065a2cbfec9ee'
'e8d1c895eabeb45b1a5f096fa5fc3c088eb3ee71')
sha256sums=('5225858bfd843b080fb9daa5b7370519130e5e49ac3eb0371e334bdc06c52dd7'
'a8d4480095bef3a5d01ac5233c3fc3758913a5c3c64ed9dbb5ea5c3f3f5bb8cd'
'abccefe0b3a65cd375d5071ce780be8d2d205439aa6d34bcd3c56de6e80ba821'
'1edd7e7916766b4aebb4d96a5da4b0a1086f43d3e0e4ffc90c2e4f92bd13ce7e'
'63b0f8c03905daecad3f901664db70a608519b6ca4f4e7b159ab2c971cffacf4'
'f839a3b6d8e64fcd9332274131b4d5aa0b2c272db072dc310af1735ef286746a')
options=('!emptydirs')
prepare() {
cd "${srcdir}/${_pkgname}-${_pkgver}"
patch -Np1 -i ../ntp-4.2.8_p15-glibc-2.34.patch
cd "${_pkgname}-${_pkgver}"
patch -p1 -i ../0001-disable-pthread-warmup-on-ARM.patch
}
build() {
cd "${srcdir}/${_pkgname}-${_pkgver}"
cd "${_pkgname}-${_pkgver}"
./configure --prefix=/usr --libexecdir=/usr/lib --enable-linuxcaps --enable-ntp-signd
make
}
package() {
cd "${srcdir}/${_pkgname}-${_pkgver}"
cd "${_pkgname}-${_pkgver}"
make DESTDIR="${pkgdir}" install

View file

@ -1,28 +0,0 @@
https://bugs.gentoo.org/806358
https://patchwork.openembedded.org/patch/180019/
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 31 Jul 2021 10:51:41 -0700
Subject: [PATCH] libntp: Do not use PTHREAD_STACK_MIN on glibc
In glibc 2.34+ PTHREAD_STACK_MIN is not a compile-time constant which
could mean different stack sizes at runtime on different architectures
and it also causes compile failure. Default glibc thread stack size
or 64Kb set by ntp should be good in glibc these days.
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
--- a/libntp/work_thread.c
+++ b/libntp/work_thread.c
@@ -41,7 +41,7 @@
#ifndef THREAD_MINSTACKSIZE
# define THREAD_MINSTACKSIZE (64U * 1024)
#endif
-#ifndef __sun
+#if !defined(__sun) && !defined(__GLIBC__)
#if defined(PTHREAD_STACK_MIN) && THREAD_MINSTACKSIZE < PTHREAD_STACK_MIN
# undef THREAD_MINSTACKSIZE
# define THREAD_MINSTACKSIZE PTHREAD_STACK_MIN
--
2.32.0