extra/snd: add patch

This commit is contained in:
Kevin Mihelich 2013-10-27 21:43:11 +00:00
parent 1efcd04800
commit 5b6dc2e921

View file

@ -0,0 +1,20 @@
diff -ur snd-14.1.orig/vct.h snd-14.1/vct.h
--- snd-14.1.orig/vct.h 2013-10-28 02:22:35.073798054 +0800
+++ snd-14.1/vct.h 2013-10-28 02:45:27.166364791 +0800
@@ -1,11 +1,11 @@
#ifndef VCT_H
#define VCT_H
-#if HAVE_SCHEME
- typedef struct s7_cell vct;
-#else
-typedef struct vct vct;
-#endif
+typedef struct {
+ mus_long_t length;
+ mus_float_t *data;
+ bool dont_free;
+} vct;
#ifdef __cplusplus
extern "C" {