extra/chromium to 109.0.5414.74-1

This commit is contained in:
Kevin Mihelich 2023-01-11 01:21:32 +00:00
parent bbdd586fd7
commit 5b814435a3
3 changed files with 5 additions and 166 deletions

View file

@ -15,10 +15,10 @@
highmem=1
pkgname=chromium
pkgver=108.0.5359.124
pkgver=109.0.5414.74
pkgrel=1
_launcher_ver=8
_gcc_patchset=2
_gcc_patchset=1
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
url="https://www.chromium.org/Home"
@ -37,8 +37,6 @@ options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
chromium-icu72.patch
v8-enhance-Date-parser-to-take-Unicode-SPACE.patch
REVERT-roll-src-third_party-ffmpeg-m102.patch
REVERT-roll-src-third_party-ffmpeg-m106.patch
@ -48,11 +46,9 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch)
sha256sums=('d48dfac2a61b14a5d7d2f460b09b70ef3ab88e27b82e3173938cb54eaa612a75'
sha256sums=('eded233c26ab631be325ad49cb306c338513b6a6528197d42653e66187548e5d'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'40ef8af65e78901bb8554eddbbb5ebc55c0b8e7927f6ca51b2a353d1c7c50652'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
'dabb5ab204b63be73d3c5c8b7c1fa74053105a285852ba3bbc4fb77646608572'
'1ca780a2ad5351f60671a828064392096c8da7b589086ee999f25c9e6e799a7b'
'b83406a881d66627757d9cbc05e345cbb2bd395a48b6d4c970e5e1cb3f6ed454'
'30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
'4c12d31d020799d31355faa7d1fe2a5a807f7458e7f0c374adf55edb37032152'
@ -73,7 +69,7 @@ declare -gA _system_libs=(
[fontconfig]=fontconfig
[freetype]=freetype2
[harfbuzz-ng]=harfbuzz
[icu]=icu
#[icu]=icu # https://crbug.com/1382032
[jsoncpp]=jsoncpp
[libaom]=aom
[libavif]=libavif # needs https://github.com/AOMediaCodec/libavif/commit/d22d4de94120
@ -137,8 +133,6 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
patch -Np1 -i ../re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
patch -Np1 -i ../chromium-icu72.patch
patch -Np1 -d v8 <../v8-enhance-Date-parser-to-take-Unicode-SPACE.patch
# Revert ffmpeg roll requiring new channel layout API support

View file

@ -1,114 +0,0 @@
From 2c4d3c61aa33f3169e7923ea3433c71e3df0952f Mon Sep 17 00:00:00 2001
From: Frank Tang <ftang@chromium.org>
Date: Mon, 7 Nov 2022 22:08:05 +0000
Subject: [PATCH 1/2] Prepare for ICU72 landing
The date format may output U+202F Narrow SPACE between time
and AM/PM. So switch to use UTF8 and not restrict to ASCII which
will break when the output is not only ASCII.
Bug: 1371208
Change-Id: I05f9daadfba5c45d618f15ae23340da373f2f36a
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4007076
Reviewed-by: Daniel Rubery <drubery@chromium.org>
Commit-Queue: Frank Tang <ftang@chromium.org>
Cr-Commit-Position: refs/heads/main@{#1068343}
(cherry picked from commit ce2ffed84b95e2b7c068d6f066d86cd034212425)
---
.../safe_browsing/content/browser/web_ui/safe_browsing_ui.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/components/safe_browsing/content/browser/web_ui/safe_browsing_ui.cc b/components/safe_browsing/content/browser/web_ui/safe_browsing_ui.cc
index 92597a9d3a4..e6e7514a082 100644
--- a/components/safe_browsing/content/browser/web_ui/safe_browsing_ui.cc
+++ b/components/safe_browsing/content/browser/web_ui/safe_browsing_ui.cc
@@ -457,7 +457,7 @@ namespace {
std::string UserReadableTimeFromMillisSinceEpoch(int64_t time_in_milliseconds) {
base::Time time =
base::Time::UnixEpoch() + base::Milliseconds(time_in_milliseconds);
- return base::UTF16ToASCII(base::TimeFormatShortDateAndTime(time));
+ return base::UTF16ToUTF8(base::TimeFormatShortDateAndTime(time));
}
void AddStoreInfo(const DatabaseManagerInfo::DatabaseInfo::StoreInfo store_info,
From 8ba9d96da703978655cddf07d58b0a15f0a43a10 Mon Sep 17 00:00:00 2001
From: Frank Tang <ftang@chromium.org>
Date: Tue, 8 Nov 2022 00:13:16 +0000
Subject: [PATCH 2/2] Prepare the landing of ICU72/Unicode 15
See
https://www.unicode.org/emoji/charts-15.0/emoji-released.html
https://www.unicode.org/charts/PDF/U1F680.pdf
https://www.unicode.org/charts/PDF/U1FA70.pdf
for the newly added emoji to
Transport and Map Symbols
Symbols and Pictographs Extended-A blocks.
Update the kIsCJKIdeographOrSymbolRanges to Unicode 15
Needed to avoid test breakage of
CharacterTest.HammerEmojiVsCJKIdeographOrSymbol
Bug: 1371208
Change-Id: Ic7b319ba18f3aded46b252d8b484e3b1bc43eff4
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4007098
Reviewed-by: Stephen Chenney <schenney@chromium.org>
Commit-Queue: Frank Tang <ftang@chromium.org>
Cr-Commit-Position: refs/heads/main@{#1068422}
(cherry picked from commit d93a774bf6fac8ddaaa1041ea6ad2dd8e5ff4539)
---
.../platform/text/character_property_data.h | 24 +++++++++----------
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/third_party/blink/renderer/platform/text/character_property_data.h b/third_party/blink/renderer/platform/text/character_property_data.h
index 9005c20a379..ee690563c28 100644
--- a/third_party/blink/renderer/platform/text/character_property_data.h
+++ b/third_party/blink/renderer/platform/text/character_property_data.h
@@ -107,7 +107,7 @@ static const UChar32 kIsCJKIdeographOrSymbolRanges[] = {
0x1F3FB, 0x1F3FF,
// Transport
- 0x1F6DD, 0x1F6DF,
+ 0x1F6DC, 0x1F6DF,
// Colored circles and squares for use with emoji.
0x1F7E0, 0x1F7EB,
@@ -118,25 +118,25 @@ static const UChar32 kIsCJKIdeographOrSymbolRanges[] = {
0x1F900, 0x1F90F,
// ZIPPER-MOUTH FACE...SIGN OF THE HORNS
0x1F910, 0x1F918, 0x1F919, 0x1F97F, 0x1F980, 0x1F9BF, 0x1F9C0, 0x1F9FF,
- // Clothing
- 0x1FA70, 0x1FA74,
- // Medical symbols
- 0x1FA78, 0x1FA7C,
+ // Clothing, heart and Medical symbols
+ 0x1FA70, 0x1FA7C,
// Toys and sport symbols
- 0x1FA80, 0x1FA86,
+ 0x1FA80, 0x1FA88,
// Miscellaneous objects
- 0x1FA90, 0x1FAAC,
// Animals and nature
- 0x1FAB0, 0x1FABA,
+ 0x1FA90, 0x1FABD,
+ // Animal
// Body parts
// People
- 0x1FAC0, 0x1FAC5,
+ 0x1FABF, 0x1FAC5,
+ // animal-mammal
+ 0x1FACE, 0x1FACF,
// Food and drink
- 0x1FAD0, 0x1FAD9,
+ 0x1FAD0, 0x1FADB,
// Face
- 0x1FAE0, 0x1FAE7,
+ 0x1FAE0, 0x1FAE8,
// Hand
- 0x1FAF0, 0x1FAF6,
+ 0x1FAF0, 0x1FAF8,
};
// https://html.spec.whatwg.org/C/#prod-potentialcustomelementname

View file

@ -1,41 +0,0 @@
From dda01a706453ded8c01c41775707cb5ef4e316f8 Mon Sep 17 00:00:00 2001
From: Andres Salomon <dilinger@queued.net>
Date: Tue, 25 Oct 2022 21:11:46 +0000
Subject: [PATCH] Re-fix TFLite build error on linux when using the system zlib
In commit ae0f9adb7e14c0d19ca695ef6ad40b321a8cb64c, I fixed some build
errors related to minizip patch inclusion in TFLite. However, after that
when TFLite Support was rolled to HEAD, a small part of that patch got
dropped. The result is the following build error with 107.0.5304.62:
../../third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc:22:10: fatal error: 'contrib/minizip/ioapi.h' file not found
^~~~~~~~~~~~~~~~~~~~~~~~~
1 error generated.
This commit re-adds the lost fix.
R=junzou@chromium.org
Change-Id: Ie96c3571894b5100a1e2a2771da29699eff0beb3
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3972087
Reviewed-by: Robert Ogden <robertogden@chromium.org>
Commit-Queue: Robert Ogden <robertogden@chromium.org>
Auto-Submit: Andres Salomon <dilinger@queued.net>
Cr-Commit-Position: refs/heads/main@{#1063478}
---
.../metadata/cc/utils/zip_readonly_mem_file.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
index 392b6b411fe..525ae4a2b45 100644
--- a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
+++ b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
@@ -19,7 +19,7 @@ limitations under the License.
#include <cstdio>
#include "absl/strings/string_view.h" // from @com_google_absl
-#include "contrib/minizip/ioapi.h"
+#include "third_party/zlib/contrib/minizip/ioapi.h"
namespace tflite {
namespace metadata {