mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-oak to 3.18.0-9
This commit is contained in:
parent
e2bc7d7823
commit
5bdc497466
15 changed files with 273 additions and 42 deletions
|
@ -1,7 +1,8 @@
|
|||
From 2ed826065abdfe471e0b7489c3fecc277848c471 Mon Sep 17 00:00:00 2001
|
||||
From a91a81413a014ef73cfa754be046216622496e7d Mon Sep 17 00:00:00 2001
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
Date: Tue, 10 May 2016 23:30:01 +0200
|
||||
Subject: [PATCH 1/8] kbuild: move -Wunused-const-variable to W=1 warning level
|
||||
Subject: [PATCH 01/13] kbuild: move -Wunused-const-variable to W=1 warning
|
||||
level
|
||||
|
||||
gcc-6 started warning by default about variables that are not
|
||||
used anywhere and that are marked 'const', generating many
|
||||
|
@ -63,5 +64,5 @@ index 48366bc8d5c8..abe5f47b1ab0 100644
|
|||
|
||||
warning-2 := -Waggregate-return
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 9e7ab58137c1d2a13fd5ea607968977bc54081e2 Mon Sep 17 00:00:00 2001
|
||||
From 7744e03fc5a0fb9db4c2aeea2892dff9c303a316 Mon Sep 17 00:00:00 2001
|
||||
From: Firo Yang <firogm@gmail.com>
|
||||
Date: Thu, 11 Jun 2015 09:41:10 +0800
|
||||
Subject: [PATCH 2/8] md: fix a build warning
|
||||
Subject: [PATCH 02/13] md: fix a build warning
|
||||
|
||||
Warning like this:
|
||||
|
||||
|
@ -33,5 +33,5 @@ index 9233c71138f1..43390353d62f 100644
|
|||
/* ignore bottom 8 bits of state, and allow SB_BITMAP_PRESENT to change */
|
||||
((state^info->state) & 0xfffffe00)
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
From 3f821de907c637437fe74f810aba5d28a17b9989 Mon Sep 17 00:00:00 2001
|
||||
From 27ed2218429159fe545b8be554a8187342eec105 Mon Sep 17 00:00:00 2001
|
||||
From: David Miller <davem@davemloft.net>
|
||||
Date: Tue, 7 Apr 2015 23:05:42 -0400
|
||||
Subject: [PATCH 3/8] netfilter: Fix switch statement warnings with recent gcc.
|
||||
Subject: [PATCH 03/13] netfilter: Fix switch statement warnings with recent
|
||||
gcc.
|
||||
|
||||
More recent GCC warns about two kinds of switch statement uses:
|
||||
|
||||
|
@ -124,5 +125,5 @@ index cc5603016242..18d520e0ca0a 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
From bd4a2deebae87cff9b9462cd08b3ec6af76ad384 Mon Sep 17 00:00:00 2001
|
||||
From 25968d93786f4622cad56e5de84fd93ce510457b Mon Sep 17 00:00:00 2001
|
||||
From: Chen Gang <gang.chen.5i5j@gmail.com>
|
||||
Date: Wed, 24 Dec 2014 23:04:54 +0800
|
||||
Subject: [PATCH 4/8] netfilter: nfnetlink_cthelper: Remove 'const' and '&' to
|
||||
avoid warnings
|
||||
Subject: [PATCH 04/13] netfilter: nfnetlink_cthelper: Remove 'const' and '&'
|
||||
to avoid warnings
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
@ -66,5 +66,5 @@ index 9e287cb56a04..a5599fc51a6f 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 412e403b486388f47a399bc791070726e1b6c743 Mon Sep 17 00:00:00 2001
|
||||
From ad3047724b25433636e6013a5b08752ed934e609 Mon Sep 17 00:00:00 2001
|
||||
From: "David S. Miller" <davem@davemloft.net>
|
||||
Date: Mon, 27 Apr 2015 13:20:34 -0400
|
||||
Subject: [PATCH 5/8] netfilter; Add some missing default cases to switch
|
||||
Subject: [PATCH 05/13] netfilter; Add some missing default cases to switch
|
||||
statements in nft_reject.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
|
@ -56,5 +56,5 @@ index 7b5f9d58680a..1fb065a77474 100644
|
|||
|
||||
return 0;
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 6d8ab10cd86d3936072b0099b5b879074840c0ac Mon Sep 17 00:00:00 2001
|
||||
From 4f73d3d82d7973d8f68f7aec4a6051248904289d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 29 Oct 2016 12:04:40 -0600
|
||||
Subject: [PATCH 6/8] usbtv: remove unused variable
|
||||
Subject: [PATCH 06/13] usbtv: remove unused variable
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -22,5 +22,5 @@ index a5eb726b2a0f..4f450c61ea74 100644
|
|||
|
||||
if (*nbuffers < 2)
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From b97d0ae34150c75903b645bf49636e67bdd44f46 Mon Sep 17 00:00:00 2001
|
||||
From 61f993ff5da7a98abcd780b239f903efc43684c4 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 26 May 2016 06:29:07 -0600
|
||||
Subject: [PATCH 7/8] add extra errata 843419 build flags
|
||||
Subject: [PATCH 07/13] add extra errata 843419 build flags
|
||||
|
||||
---
|
||||
arch/arm64/Makefile | 1 +
|
||||
|
@ -20,5 +20,5 @@ index b7da5c34aac1..5e27fa3850c8 100644
|
|||
|
||||
# Default value
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 2c8e7b746adc1a27a5c4232e005074ff8a5f78f1 Mon Sep 17 00:00:00 2001
|
||||
From 1e15329db4b750d9e1aefc01d5ecb24b70458ac6 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 5 Nov 2016 15:28:36 -0600
|
||||
Subject: [PATCH 8/8] Downgrade mmc1 speed
|
||||
Subject: [PATCH 08/13] Downgrade mmc1 speed
|
||||
|
||||
200MHz causes errors reading the card and filesystem corruption.
|
||||
|
||||
|
@ -28,5 +28,5 @@ index d64da67ef24d..b6e1835307e8 100644
|
|||
wp-gpios = <&pio 42 GPIO_ACTIVE_HIGH>;
|
||||
vmmc-supply = <&mt6397_vmch_reg>;
|
||||
--
|
||||
2.13.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -0,0 +1,47 @@
|
|||
From d3a38022ee4fb0c1e5ac66afc456de8c97fc15b2 Mon Sep 17 00:00:00 2001
|
||||
From: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
Date: Wed, 12 Jul 2017 19:25:47 -0700
|
||||
Subject: [PATCH 09/13] disable new gcc-7.1.1 warnings for now
|
||||
|
||||
I made the mistake of upgrading my desktop to the new Fedora 26 that
|
||||
comes with gcc-7.1.1.
|
||||
|
||||
There's nothing wrong per se that I've noticed, but I now have 1500
|
||||
lines of warnings, mostly from the new format-truncation warning
|
||||
triggering all over the tree.
|
||||
|
||||
We use 'snprintf()' and friends in a lot of places, and often know that
|
||||
the numbers are fairly small (ie a controller index or similar), but gcc
|
||||
doesn't know that, and sees an 'int', and thinks that it could be some
|
||||
huge number. And then complains when our buffers are not able to fit
|
||||
the name for the ten millionth controller.
|
||||
|
||||
These warnings aren't necessarily bad per se, and we probably want to
|
||||
look through them subsystem by subsystem, but at least during the merge
|
||||
window they just mean that I can't even see if somebody is introducing
|
||||
any *real* problems when I pull.
|
||||
|
||||
So warnings disabled for now.
|
||||
|
||||
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
---
|
||||
Makefile | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 0847d3f6c162..16005a20f4ef 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -614,6 +614,9 @@ all: vmlinux
|
||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||
|
||||
KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
|
||||
+KBUILD_CFLAGS += $(call cc-disable-warning, format-truncation)
|
||||
+KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
|
||||
+KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
|
||||
|
||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||
KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
|
||||
--
|
||||
2.13.3
|
||||
|
|
@ -0,0 +1,59 @@
|
|||
From 6f9d3832bf615e2fa5817057de8c5697c9f07018 Mon Sep 17 00:00:00 2001
|
||||
From: Christophe Jaillet <christophe.jaillet@wanadoo.fr>
|
||||
Date: Wed, 31 Aug 2016 13:50:59 +0200
|
||||
Subject: [PATCH 10/13] UPSTREAM: mwifiex: scan: Simplify code
|
||||
|
||||
This patch:
|
||||
- improves code layout
|
||||
- removes a useless memset(0) for some memory allocated with kzalloc
|
||||
- removes a useless if. We know that 'if (chan_band_tlv)' will succeed
|
||||
because it has been tested a few lines above
|
||||
|
||||
Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
|
||||
Signed-off-by: Kalle Valo <kvalo@codeaurora.org>
|
||||
(cherry picked from commit b711657616947e7b4c15f6825d259324216b23f2)
|
||||
|
||||
BUG=b:36466135
|
||||
TEST=check wifi still works on kevin
|
||||
|
||||
Change-Id: I9ab79bd2a02bb1ccb54f8d49eb56102ec21e36c8
|
||||
Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>
|
||||
Reviewed-on: https://chromium-review.googlesource.com/462178
|
||||
Commit-Ready: Brian Norris <briannorris@chromium.org>
|
||||
Tested-by: Brian Norris <briannorris@chromium.org>
|
||||
Reviewed-by: Brian Norris <briannorris@chromium.org>
|
||||
---
|
||||
drivers/net/wireless/mwifiex/scan.c | 14 +++++---------
|
||||
1 file changed, 5 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/mwifiex/scan.c b/drivers/net/wireless/mwifiex/scan.c
|
||||
index cabc97d491a2..a98148b0465b 100644
|
||||
--- a/drivers/net/wireless/mwifiex/scan.c
|
||||
+++ b/drivers/net/wireless/mwifiex/scan.c
|
||||
@@ -2158,18 +2158,14 @@ int mwifiex_ret_802_11_scan(struct mwifiex_private *priv,
|
||||
|
||||
if (chan_band_tlv && adapter->nd_info) {
|
||||
adapter->nd_info->matches[idx] =
|
||||
- kzalloc(sizeof(*pmatch) +
|
||||
- sizeof(u32), GFP_ATOMIC);
|
||||
+ kzalloc(sizeof(*pmatch) + sizeof(u32),
|
||||
+ GFP_ATOMIC);
|
||||
|
||||
pmatch = adapter->nd_info->matches[idx];
|
||||
|
||||
- if (!pmatch) {
|
||||
- memset(pmatch, 0, sizeof(*pmatch));
|
||||
- if (chan_band_tlv) {
|
||||
- pmatch->n_channels = 1;
|
||||
- pmatch->channels[0] =
|
||||
- chan_band->chan_number;
|
||||
- }
|
||||
+ if (pmatch) {
|
||||
+ pmatch->n_channels = 1;
|
||||
+ pmatch->channels[0] = chan_band->chan_number;
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.13.3
|
||||
|
|
@ -0,0 +1,40 @@
|
|||
From 83cd4eea92d5cbb1a52316a51dba51568e99b680 Mon Sep 17 00:00:00 2001
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
Date: Thu, 11 May 2017 08:46:44 -0300
|
||||
Subject: [PATCH 11/13] [media] ir-core: fix gcc-7 warning on bool arithmetic
|
||||
|
||||
gcc-7 suggests that an expression using a bitwise not and a bitmask
|
||||
on a 'bool' variable is better written using boolean logic:
|
||||
|
||||
drivers/media/rc/imon.c: In function 'imon_incoming_scancode':
|
||||
drivers/media/rc/imon.c:1725:22: error: '~' on a boolean expression [-Werror=bool-operation]
|
||||
ictx->pad_mouse = ~(ictx->pad_mouse) & 0x1;
|
||||
^
|
||||
drivers/media/rc/imon.c:1725:22: note: did you mean to use logical not?
|
||||
|
||||
I agree.
|
||||
|
||||
Fixes: 21677cfc562a ("V4L/DVB: ir-core: add imon driver")
|
||||
|
||||
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
||||
Signed-off-by: Mauro Carvalho Chehab <mchehab@s-opensource.com>
|
||||
---
|
||||
drivers/media/rc/imon.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/media/rc/imon.c b/drivers/media/rc/imon.c
|
||||
index 65f80b8b9f7a..eb9e7feb9b13 100644
|
||||
--- a/drivers/media/rc/imon.c
|
||||
+++ b/drivers/media/rc/imon.c
|
||||
@@ -1629,7 +1629,7 @@ static void imon_incoming_packet(struct imon_context *ictx,
|
||||
if (kc == KEY_KEYBOARD && !ictx->release_code) {
|
||||
ictx->last_keycode = kc;
|
||||
if (!nomouse) {
|
||||
- ictx->pad_mouse = ~(ictx->pad_mouse) & 0x1;
|
||||
+ ictx->pad_mouse = !ictx->pad_mouse;
|
||||
dev_dbg(dev, "toggling to %s mode\n",
|
||||
ictx->pad_mouse ? "mouse" : "keyboard");
|
||||
spin_unlock_irqrestore(&ictx->kc_lock, flags);
|
||||
--
|
||||
2.13.3
|
||||
|
|
@ -0,0 +1,42 @@
|
|||
From fad3c0ed1105d615614816b93c748b51bfbd1b59 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 20 Jul 2017 20:51:05 -0600
|
||||
Subject: [PATCH 12/13] sched: fix duplicate const error on gcc 7
|
||||
|
||||
Fixes f0e1f11d3d18.
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
kernel/sched/fair.c | 2 +-
|
||||
kernel/sched/sched.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
|
||||
index 358cc04b1096..16d5ddb38d41 100644
|
||||
--- a/kernel/sched/fair.c
|
||||
+++ b/kernel/sched/fair.c
|
||||
@@ -4626,7 +4626,7 @@ long group_norm_util(struct energy_env *eenv, struct sched_group *sg)
|
||||
}
|
||||
|
||||
static int find_new_capacity(struct energy_env *eenv,
|
||||
- const struct sched_group_energy const *sge)
|
||||
+ const struct sched_group_energy *sge)
|
||||
{
|
||||
int idx;
|
||||
unsigned long util = group_max_util(eenv);
|
||||
diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h
|
||||
index 544f0ac239bd..a2cb67fbcdaa 100644
|
||||
--- a/kernel/sched/sched.h
|
||||
+++ b/kernel/sched/sched.h
|
||||
@@ -820,7 +820,7 @@ struct sched_group {
|
||||
|
||||
unsigned int group_weight;
|
||||
struct sched_group_capacity *sgc;
|
||||
- const struct sched_group_energy const *sge;
|
||||
+ const struct sched_group_energy *sge;
|
||||
|
||||
/*
|
||||
* The CPUs this group covers.
|
||||
--
|
||||
2.13.3
|
||||
|
|
@ -0,0 +1,27 @@
|
|||
From 9a2cc0fdb2b38f0d5ee90cb6f0b9bb7504668715 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 20 Jul 2017 21:01:45 -0600
|
||||
Subject: [PATCH 13/13] staging: iio: light: isl29018: fix duplicate const
|
||||
error on gcc 7
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
drivers/staging/iio/light/isl29018.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/staging/iio/light/isl29018.c b/drivers/staging/iio/light/isl29018.c
|
||||
index c673e1bf694e..f4a2ef7e0415 100644
|
||||
--- a/drivers/staging/iio/light/isl29018.c
|
||||
+++ b/drivers/staging/iio/light/isl29018.c
|
||||
@@ -81,7 +81,7 @@
|
||||
#define CONT_MODE_IR 2
|
||||
#define CONT_MODE_PROX 3
|
||||
|
||||
-static const char const *isl29018_cont_modes[] = {
|
||||
+static const char *isl29018_cont_modes[] = {
|
||||
"once",
|
||||
"als",
|
||||
"ir",
|
||||
--
|
||||
2.13.3
|
||||
|
|
@ -7,8 +7,8 @@ pkgbase=linux-oak
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="Oak Chromebooks"
|
||||
pkgver=3.18.0
|
||||
pkgrel=8
|
||||
_commit=d57fda44257ae0e898a530d9537e65f3a74ef861
|
||||
pkgrel=9
|
||||
_commit=85c9629e12ba49c366ac44feca6ec2b7c0ab6581
|
||||
arch=('aarch64')
|
||||
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-3.18"
|
||||
license=('GPL2')
|
||||
|
@ -23,21 +23,31 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
|
|||
'0006-usbtv-remove-unused-variable.patch'
|
||||
'0007-add-extra-errata-843419-build-flags.patch'
|
||||
'0008-Downgrade-mmc1-speed.patch'
|
||||
'0009-disable-new-gcc-7.1.1-warnings-for-now.patch'
|
||||
'0010-UPSTREAM-mwifiex-scan-Simplify-code.patch'
|
||||
'0011-media-ir-core-fix-gcc-7-warning-on-bool-arithmetic.patch'
|
||||
'0012-sched-fix-duplicate-const-error-on-gcc-7.patch'
|
||||
'0013-staging-iio-light-isl29018-fix-duplicate-const-error.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk'
|
||||
'cmdline')
|
||||
md5sums=('2ddf0c97acb2f1a9b4a37c3428d21f23'
|
||||
'903af17c4197ed26845b6435caeeee5e'
|
||||
'1f557baf555c190b455234db053dd6c6'
|
||||
'd009d824fe0350cbba32de5d9f7b2006'
|
||||
'b2a7517e8f996e2e48318fcc210ef913'
|
||||
'fad90f4bb981ada9cd9db60c71e6466c'
|
||||
'cbfbaee600b4d53c08630bee6ce8ffcb'
|
||||
'2f87e4803fb113fd9fbc948b356d3c9d'
|
||||
'c522b9ddd7d58e17621c5e8e5c00eec3'
|
||||
'8acf55cbebd9c56d34186dfd27b6fe97'
|
||||
md5sums=('36ec59ebf3bc2a4d0d1fa00eaee6f0e5'
|
||||
'b0245f5b0ffd211ef356c3938bb9691d'
|
||||
'1ff1d92e5506ea3b150e286a1791cae3'
|
||||
'44325bb24aef330147e2fa2057a00a4a'
|
||||
'661c6a6513c4303a7c9736083205a9a4'
|
||||
'fa9119c1af1a445c59d64a44cf4262ce'
|
||||
'395c77cb0a834befdba3df49d4d82eed'
|
||||
'46c4454f5eddb64efecfb56073c6ef64'
|
||||
'dde4fe4cf04ef35d21e35e0d5b50d1a8'
|
||||
'f5a0fe61d4be9204a105f168fb892dfc'
|
||||
'18ccf5cda146f5141a5104caafe6df18'
|
||||
'3c24f23d6c47e9b13739dba603b2d9e0'
|
||||
'9a5ed78ec0a28e646538dc17ca744b61'
|
||||
'54c0375c456bc7ef03f5ad2a39915044'
|
||||
'569871139f6f746a2959a53e5f1abb48'
|
||||
'aef13cb59516e9313cb8947350f717d6'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8'
|
||||
|
@ -52,6 +62,11 @@ prepare() {
|
|||
git apply 0006-usbtv-remove-unused-variable.patch
|
||||
git apply 0007-add-extra-errata-843419-build-flags.patch
|
||||
git apply 0008-Downgrade-mmc1-speed.patch
|
||||
git apply 0009-disable-new-gcc-7.1.1-warnings-for-now.patch
|
||||
git apply 0010-UPSTREAM-mwifiex-scan-Simplify-code.patch
|
||||
git apply 0011-media-ir-core-fix-gcc-7-warning-on-bool-arithmetic.patch
|
||||
git apply 0012-sched-fix-duplicate-const-error-on-gcc-7.patch
|
||||
git apply 0013-staging-iio-light-isl29018-fix-duplicate-const-error.patch
|
||||
|
||||
cp config .config
|
||||
|
||||
|
@ -63,6 +78,7 @@ prepare() {
|
|||
|
||||
unset LDFLAGS
|
||||
cp include/linux/compiler-gcc5.h include/linux/compiler-gcc6.h
|
||||
cp include/linux/compiler-gcc5.h include/linux/compiler-gcc7.h
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm64 3.18.0-8 Kernel Configuration
|
||||
# Linux/arm64 3.18.0-9 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM64=y
|
||||
CONFIG_64BIT=y
|
||||
|
@ -1767,10 +1767,7 @@ CONFIG_LIBERTAS_SDIO=m
|
|||
# CONFIG_LIBERTAS_SPI is not set
|
||||
# CONFIG_LIBERTAS_DEBUG is not set
|
||||
CONFIG_LIBERTAS_MESH=y
|
||||
CONFIG_P54_COMMON=m
|
||||
CONFIG_P54_USB=m
|
||||
# CONFIG_P54_SPI is not set
|
||||
CONFIG_P54_LEDS=y
|
||||
# CONFIG_P54_COMMON is not set
|
||||
CONFIG_RT2X00=m
|
||||
CONFIG_RT2500USB=m
|
||||
CONFIG_RT73USB=m
|
||||
|
@ -3071,6 +3068,7 @@ CONFIG_DVB_AF9033=m
|
|||
#
|
||||
CONFIG_DRM=y
|
||||
CONFIG_DRM_MIPI_DSI=y
|
||||
# CONFIG_DRM_DP_AUX_CHARDEV is not set
|
||||
CONFIG_DRM_KMS_HELPER=y
|
||||
CONFIG_DRM_KMS_FB_HELPER=y
|
||||
CONFIG_DRM_FBDEV_EMULATION=y
|
||||
|
|
Loading…
Reference in a new issue