community/gdc to 5.3.0-1

This commit is contained in:
Kevin Mihelich 2015-12-24 16:09:32 +00:00
parent 7ce79b14d7
commit 5bfae636b7
2 changed files with 12 additions and 15 deletions

View file

@ -7,13 +7,8 @@
# - specifid build host
# - replaced bugurl with our GitHub issue page
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - TEMPORARY: specify current gdc head commit, adjusted system_zlib.diff
noautobuild=1
pkgname=('gdc' 'libgphobos-devel')
pkgver=5.2.0
pkgver=5.3.0
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/D-Programming-GDC/GDC"
@ -22,16 +17,18 @@ makedepends=('binutils>=2.23' 'git' 'gcc' 'make' 'perl' 'automake')
options=('!emptydirs' '!buildflags')
source=(
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
"gdc::git://github.com/D-Programming-GDC/GDC.git#commit=42c4f6c"
"gdc::git://github.com/D-Programming-GDC/GDC.git#tag=v2.066.1_gcc5"
"git+https://github.com/D-Programming-GDC/GDMD.git"
"folders.diff"
"system_zlib.diff"
)
sha256sums=('5f835b04b5f7dd4f4d2dc96190ec1621b8d89f2dc6f638f9f8bc1b1014ba8cad'
'SKIP'
'SKIP'
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
'79b618e5223bc145da360bee8cf3e71b86baa15c4686815e418ae8e3110df243')
sha256sums=(
'b84f5592e9218b73dbae612b5253035a7b34a9a1f7688d2e1bfaaf7267d5c4db'
'SKIP'
'SKIP'
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
'1bf81cde6a7bad096f76db2f20ad8ab2801cd0ab2dd2fa0219503073e8dae480'
)
groups=('dlang' 'dlang-gdc')
conflicts=('gdc1-bin' 'gdc1-hg' 'gdc-git')

View file

@ -1,7 +1,7 @@
diff --git a/gcc/d/d-spec.c b/gcc/d/d-spec.c
diff --git a/gcc/d/d-spec.cc b/gcc/d/d-spec.cc
index a43cb34..e4bb527 100644
--- a/gcc/d/d-spec.c
+++ b/gcc/d/d-spec.c
--- a/gcc/d/d-spec.cc
+++ b/gcc/d/d-spec.cc
@@ -96,7 +96,7 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
/* The number of arguments being added to what's in argv, other than
libraries. We use this to track the number of times we've inserted