mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/jupyterlab to 4.0.0-1
This commit is contained in:
parent
9e6ee53a35
commit
5c2d33efdb
2 changed files with 10 additions and 28 deletions
|
@ -5,25 +5,18 @@
|
|||
|
||||
pkgname=jupyterlab
|
||||
_pipname=jupyterlab
|
||||
pkgver=3.6.3
|
||||
pkgrel=7
|
||||
pkgver=4.0.0
|
||||
pkgrel=1
|
||||
pkgdesc='JupyterLab computational environment'
|
||||
arch=(any)
|
||||
url='https://github.com/jupyterlab/jupyterlab'
|
||||
license=(custom)
|
||||
makedepends=(python-build python-installer python-pre-commit)
|
||||
depends=(python-jupyterlab_server python-jupyter_packaging jupyter-notebook-shim jupyter-server-ydoc nodejs)
|
||||
makedepends=(python-build python-installer python-hatch-jupyter-builder)
|
||||
depends=(python-jupyterlab_server python-jupyter_packaging python-async-lru jupyter-server-ydoc nodejs)
|
||||
optdepends=('npm: to install extensions' 'jupyterlab-widgets: ipywidgets support')
|
||||
checkdepends=(python-pytest-tornasync python-pytest-jupyter npm)
|
||||
source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz
|
||||
no-nbclassic.patch)
|
||||
sha256sums=('373e9cfb8a72edd294be14f16662563a220cecf0fb26de7aab1af9a29b689b82'
|
||||
'c06dc4b2bc712e7fbffe9850a9c99f98ee4f5210ecd3a9572b7ed21496c8d59e')
|
||||
|
||||
prepare() {
|
||||
patch -d $pkgname-$pkgver -p1 < no-nbclassic.patch # Drop nbclassic dependency
|
||||
sed -e '/nbclassic/d' -e '/notebook<7/d' -e 's|ydoc\~\=.*|ydoc|g' -i $pkgname-$pkgver/setup.cfg
|
||||
}
|
||||
checkdepends=(python-pytest-tornasync python-pytest-jupyter npm python-jupyter-server-terminals)
|
||||
source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
|
||||
sha256sums=('ce656d04828b2e4ee0758e22c862cc99aedec66a10319d09f0fd5ea51be68dd8')
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
@ -33,7 +26,9 @@ build() {
|
|||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
pytest -v -k 'not test_build and not test_announcements'
|
||||
python -m venv --system-site-packages test-env
|
||||
test-env/bin/python -m installer dist/*.whl
|
||||
test-env/bin/python -m pytest -v
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/jupyterlab/labapp.py b/jupyterlab/labapp.py
|
||||
index 1eb56b22fe..5a401a0fdf 100644
|
||||
--- a/jupyterlab/labapp.py
|
||||
+++ b/jupyterlab/labapp.py
|
||||
@@ -19,7 +19,7 @@ from jupyterlab_server import (
|
||||
WorkspaceImportApp,
|
||||
WorkspaceListApp,
|
||||
)
|
||||
-from nbclassic.shim import NBClassicConfigShimMixin
|
||||
+from notebook_shim.shim import NotebookConfigShimMixin as NBClassicConfigShimMixin
|
||||
from traitlets import Bool, Instance, Type, Unicode, default
|
||||
|
||||
from ._version import __version__
|
Loading…
Reference in a new issue