mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
removed extra/imagemagick
This commit is contained in:
parent
70a871adae
commit
5c56db0434
2 changed files with 0 additions and 101 deletions
|
@ -1,90 +0,0 @@
|
|||
# $Id: PKGBUILD 153440 2012-03-14 01:50:29Z eric $
|
||||
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - use sunet.se mirror
|
||||
# - set quantum depth to 32 to fix FTBFS
|
||||
|
||||
pkgbase=imagemagick
|
||||
pkgname=('imagemagick' 'imagemagick-doc')
|
||||
pkgver=6.8.7.7
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.imagemagick.org/"
|
||||
license=('custom')
|
||||
makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript' \
|
||||
'openexr' 'libwmf' 'librsvg' 'libxml2' 'jasper' 'liblqr' 'libwebp')
|
||||
#source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc} \
|
||||
source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc} \
|
||||
perlmagick.rpath.patch)
|
||||
sha1sums=('d603d4139281501d325134a87975d9d66c6e107f'
|
||||
'SKIP'
|
||||
'e143cf9d530fabf3b58023899b5cc544ba93daec')
|
||||
|
||||
prepare() {
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
sed '/AC_PATH_XTRA/d' -i configure.ac
|
||||
autoreconf --force --install
|
||||
patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
./configure --prefix=/usr --sysconfdir=/etc --with-modules \
|
||||
--enable-hdri --with-wmf --with-openexr --with-xml --with-lcms2 --with-jp2 \
|
||||
--with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
|
||||
--with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
|
||||
--without-gvc --without-djvu --without-autotrace --without-webp \
|
||||
--without-fpx --without-dps --without-fftw --with-quantum-depth=32
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
#make check
|
||||
}
|
||||
|
||||
package_imagemagick() {
|
||||
pkgdesc="An image viewing/manipulation program"
|
||||
depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr')
|
||||
optdepends=('imagemagick-doc: for additional information'
|
||||
'ghostscript: for Ghostscript support'
|
||||
'openexr: for OpenEXR support'
|
||||
'libwmf: for WMF support'
|
||||
'librsvg: for SVG support'
|
||||
'libxml2: for XML support'
|
||||
'jasper: for JPEG-2000 support'
|
||||
'libpng: for PNG support'
|
||||
'libwebp: for WEBP support')
|
||||
backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/colors.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/delegates.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/log.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/magic.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/mime.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/policy.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
|
||||
options=('!docs' 'libtool' '!emptydirs')
|
||||
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
make -j1 DESTDIR="${pkgdir}" install
|
||||
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
|
||||
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
|
||||
|
||||
#Cleaning
|
||||
rm -f "${pkgdir}"/usr/lib/*.la
|
||||
}
|
||||
|
||||
package_imagemagick-doc() {
|
||||
pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
|
||||
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
make DESTDIR="${pkgdir}" install-data-html
|
||||
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
|
||||
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig 2013-02-21 03:26:56.785156600 -0500
|
||||
+++ Makefile.in 2013-02-21 03:39:03.102411457 -0500
|
||||
@@ -10469,6 +10469,8 @@
|
||||
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@$(PERLMAKEFILE): perl-sources $(MAGICKCORE_LIBS) $(MAGICKWAND_LIBS) $(PERLMAKEMAKER)
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @PERL@ Makefile.PL $(PERL_MAKE_OPTIONS)
|
||||
+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' Makefile
|
||||
+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' quantum/Makefile
|
||||
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@install-exec-perl: $(PERLMAKEFILE)
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ ( cd $(PERLMAGICK) && $(MAKE) CC='@CC@' && \
|
Loading…
Reference in a new issue