mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-odroid-c1 to 3.10.64-3
This commit is contained in:
parent
2acf545593
commit
5cd9ce0cb3
2 changed files with 50 additions and 3 deletions
|
@ -0,0 +1,43 @@
|
|||
From e7c973b76ee0059e1e5662c3c6ca60bd6cb69fbb Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 22 Jan 2015 22:24:22 -0700
|
||||
Subject: [PATCH] dirty status led active low hack
|
||||
|
||||
---
|
||||
drivers/gpio/gpiolib-of.c | 14 ++++++++++++--
|
||||
1 file changed, 12 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c
|
||||
index f86fe7c..3caf9fe 100644
|
||||
--- a/drivers/gpio/gpiolib-of.c
|
||||
+++ b/drivers/gpio/gpiolib-of.c
|
||||
@@ -66,14 +66,24 @@ static int of_gpiochip_find_and_xlate(struct gpio_chip *gc, void *data)
|
||||
#include <linux/amlogic/aml_gpio_consumer.h>
|
||||
int of_get_named_gpio_flags(struct device_node *np, const char *propname,
|
||||
int index __attribute__((unused)),
|
||||
- enum of_gpio_flags *flags __attribute__((unused)))
|
||||
+ enum of_gpio_flags *flags)
|
||||
{
|
||||
const char *str;
|
||||
+ int gpio;
|
||||
|
||||
if(of_property_read_string(np, "gpios", &str))
|
||||
return -EPROBE_DEFER;
|
||||
|
||||
- return amlogic_gpio_name_map_num(str);
|
||||
+ gpio = amlogic_gpio_name_map_num(str);
|
||||
+
|
||||
+ if (flags != NULL) {
|
||||
+ if (gpio == 13)
|
||||
+ *flags = 1;
|
||||
+ else
|
||||
+ *flags = 0;
|
||||
+ }
|
||||
+
|
||||
+ return gpio;
|
||||
}
|
||||
#else
|
||||
int of_get_named_gpio_flags(struct device_node *np, const char *propname,
|
||||
--
|
||||
2.2.2
|
||||
|
|
@ -9,7 +9,7 @@ _srcname=linux-${_commit}
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ODROID-C1"
|
||||
pkgver=3.10.64
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('armv7h')
|
||||
url="https://github.com/hardkernel/linux"
|
||||
license=('GPL2')
|
||||
|
@ -18,17 +18,21 @@ options=('!strip')
|
|||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||
"git+https://github.com/mdrjr/c1_bootini.git"
|
||||
'config'
|
||||
'amlogic.service')
|
||||
'amlogic.service'
|
||||
'0001-dirty-status-led-active-low-hack.patch')
|
||||
md5sums=('f2f37c9dbff08c340b55c36c3b42e4be'
|
||||
'SKIP'
|
||||
'2135e3a2e66b63cbb27b12fb9d89acdc'
|
||||
'b8956789318f49cec5b8bb0b41654a9b')
|
||||
'b8956789318f49cec5b8bb0b41654a9b'
|
||||
'11c4c2d1b6cf051fac1c6109c2bf8a16')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
git apply ../0001-dirty-status-led-active-low-hack.patch
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
||||
|
|
Loading…
Reference in a new issue