mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/gnome-builder to 3.22.1-1
This commit is contained in:
parent
9f0906a87b
commit
5ce09c4bf7
3 changed files with 49 additions and 27 deletions
28
extra/gnome-builder/0001-ARM-fix.patch
Normal file
28
extra/gnome-builder/0001-ARM-fix.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
From c950a2fe53e8f3269b2cb969fca2c37397732216 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 12 Oct 2016 06:40:31 -0600
|
||||
Subject: [PATCH] ARM fix
|
||||
|
||||
---
|
||||
libide/highlighting/ide-highlight-index.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/libide/highlighting/ide-highlight-index.c b/libide/highlighting/ide-highlight-index.c
|
||||
index 1e90686..711bd89 100644
|
||||
--- a/libide/highlighting/ide-highlight-index.c
|
||||
+++ b/libide/highlighting/ide-highlight-index.c
|
||||
@@ -31,6 +31,11 @@ G_DEFINE_BOXED_TYPE (IdeHighlightIndex, ide_highlight_index,
|
||||
|
||||
EGG_DEFINE_COUNTER (instances, "IdeHighlightIndex", "Instances", "Number of indexes")
|
||||
|
||||
+#ifndef PAGE_SIZE
|
||||
+#include <unistd.h>
|
||||
+#define PAGE_SIZE sysconf(_SC_PAGESIZE)
|
||||
+#endif
|
||||
+
|
||||
struct _IdeHighlightIndex
|
||||
{
|
||||
volatile gint ref_count;
|
||||
--
|
||||
2.10.0
|
||||
|
|
@ -5,28 +5,37 @@
|
|||
# - patch to fix build on ARM
|
||||
|
||||
pkgname=gnome-builder
|
||||
pkgver=3.20.4
|
||||
pkgrel=2
|
||||
pkgver=3.22.1
|
||||
pkgrel=1
|
||||
pkgdesc="An IDE for writing GNOME-based software"
|
||||
url="https://wiki.gnome.org/Apps/Builder"
|
||||
arch=(i686 x86_64)
|
||||
license=(GPL3)
|
||||
depends=(gtksourceview3 devhelp libgit2-glib gjs python-gobject clang desktop-file-utils
|
||||
ctags libpeas vte3 vala python-jedi)
|
||||
makedepends=(intltool llvm gobject-introspection gtk-doc)
|
||||
makedepends=(intltool llvm gobject-introspection gtk-doc yelp-tools autoconf-archive
|
||||
appstream-glib vala git mm-common)
|
||||
groups=(gnome-extra)
|
||||
source=(http://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz
|
||||
arm.patch)
|
||||
sha256sums=('b3e69495cd0fcfd3e3a7590f52aadaae7f45393eefd47ab5581a851cdd489041'
|
||||
'e56bb096be7b6fae0725efa5846e2376177e12b6b0495e04c21c13d771c38b34')
|
||||
_commit=74531b2d7a474f3f9edf5c215d7284fe0b022ec9 # tags/GNOME_BUILDER_3_22_1^0
|
||||
source=("git://git.gnome.org/gnome-builder#commit=$_commit"
|
||||
'0001-ARM-fix.patch')
|
||||
sha256sums=('SKIP'
|
||||
'a92b25439576fe44565d3d7517be5f22d386806916fbc4abd1b3b304ed7b7ca2')
|
||||
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/^GNOME_BUILDER_//;s/_/./g;s/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../arm.patch
|
||||
cd $pkgname
|
||||
git apply ../0001-ARM-fix.patch
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
|
||||
--libexecdir=/usr/lib --enable-gtk-doc
|
||||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
||||
|
@ -34,11 +43,11 @@ build() {
|
|||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
make -k check || :
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
cd $pkgname
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
diff -urN a/libide/ide-highlight-index.c b/libide/ide-highlight-index.c
|
||||
--- a/libide/ide-highlight-index.c 2015-04-08 00:43:25.000000000 -0600
|
||||
+++ b/libide/ide-highlight-index.c 2015-04-14 13:18:59.080511371 -0600
|
||||
@@ -28,6 +28,11 @@
|
||||
G_DEFINE_BOXED_TYPE (IdeHighlightIndex, ide_highlight_index,
|
||||
ide_highlight_index_ref, ide_highlight_index_unref)
|
||||
|
||||
+#ifndef PAGE_SIZE
|
||||
+#include <unistd.h>
|
||||
+#define PAGE_SIZE sysconf(_SC_PAGESIZE)
|
||||
+#endif
|
||||
+
|
||||
struct _IdeHighlightIndex
|
||||
{
|
||||
volatile gint ref_count;
|
Loading…
Reference in a new issue