mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/qbittorrent
This commit is contained in:
parent
0e080ead00
commit
5d15912dc5
3 changed files with 104 additions and 0 deletions
|
@ -0,0 +1,25 @@
|
||||||
|
From 403dd9d7b14ba83537a06d15339bd703a64e8987 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Mon, 20 Nov 2017 06:50:15 -0700
|
||||||
|
Subject: [PATCH] fix boost library path for ARM
|
||||||
|
|
||||||
|
---
|
||||||
|
configure | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 3179c1756..e72993d6e 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -4707,6 +4707,8 @@ fi
|
||||||
|
libsubdirs="lib64 lib lib64" ;; #(
|
||||||
|
libsubdirs="lib") :
|
||||||
|
;; #(
|
||||||
|
+ arm*) :
|
||||||
|
+ libsubdirs="lib" ;; #(
|
||||||
|
*) :
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
--
|
||||||
|
2.14.1
|
||||||
|
|
67
community/qbittorrent/PKGBUILD
Normal file
67
community/qbittorrent/PKGBUILD
Normal file
|
@ -0,0 +1,67 @@
|
||||||
|
# $Id$
|
||||||
|
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||||
|
# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
|
||||||
|
# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
|
||||||
|
# Contributor: Jkkyll Wu <adaptee at gmail [dot] com>
|
||||||
|
# Contributor: Thomas Dziedzic < gostrc at gmail >
|
||||||
|
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
|
||||||
|
# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch to fix boost library path for ARM
|
||||||
|
|
||||||
|
pkgbase=qbittorrent
|
||||||
|
pkgname=(qbittorrent qbittorrent-nox)
|
||||||
|
pkgver=4.0.0
|
||||||
|
pkgrel=1
|
||||||
|
arch=(x86_64)
|
||||||
|
url="https://www.qbittorrent.org"
|
||||||
|
license=(custom GPL)
|
||||||
|
makedepends=(libtorrent-rasterbar boost qt5-tools qt5-svg)
|
||||||
|
source=(https://downloads.sourceforge.net/sourceforge/qbittorrent/$pkgname-$pkgver.tar.xz{,.asc}
|
||||||
|
0001-fix-boost-library-path-for-ARM.patch)
|
||||||
|
sha256sums=('1d43e99585bb7e3e01f4002cbcc404db8baa25e6cc5e42269d1709444dd93156'
|
||||||
|
'SKIP'
|
||||||
|
'f040f1fec3a0f2fa62ffccc9a65fd9206ebdaa58ce082a0739b7d03e560bd5de')
|
||||||
|
validpgpkeys=('D8F3DA77AAC6741053599C136E4A2D025B7CC9A2')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd $pkgbase-$pkgver
|
||||||
|
patch -p1 -i ../0001-fix-boost-library-path-for-ARM.patch
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd $pkgbase-$pkgver
|
||||||
|
|
||||||
|
mkdir $pkgbase
|
||||||
|
pushd $pkgbase
|
||||||
|
../configure --prefix=/usr
|
||||||
|
make
|
||||||
|
|
||||||
|
# Build nox variant
|
||||||
|
popd
|
||||||
|
mkdir "$pkgbase-nox"
|
||||||
|
pushd "$pkgbase-nox"
|
||||||
|
../configure --prefix=/usr --disable-gui --enable-systemd
|
||||||
|
}
|
||||||
|
|
||||||
|
package_qbittorrent() {
|
||||||
|
pkgdesc="An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar."
|
||||||
|
depends=(libtorrent-rasterbar qt5-svg hicolor-icon-theme)
|
||||||
|
optdepends=('python: needed for torrent search tab')
|
||||||
|
|
||||||
|
cd $pkgbase-$pkgver/$pkgbase
|
||||||
|
|
||||||
|
make INSTALL_ROOT="$pkgdir" install
|
||||||
|
install -Dm644 "$srcdir"/$pkgbase-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
|
||||||
|
}
|
||||||
|
|
||||||
|
package_qbittorrent-nox() {
|
||||||
|
pkgdesc="An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar, w/o gui"
|
||||||
|
depends=(libtorrent-rasterbar qt5-base)
|
||||||
|
|
||||||
|
cd $pkgbase-$pkgver/$pkgbase-nox
|
||||||
|
|
||||||
|
make INSTALL_ROOT="$pkgdir" install
|
||||||
|
install -Dm644 "$srcdir"/$pkgbase-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
|
||||||
|
}
|
12
community/qbittorrent/qbittorrent@.service
Normal file
12
community/qbittorrent/qbittorrent@.service
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
[Unit]
|
||||||
|
Description=qbittorrent-nox Daemon
|
||||||
|
Documentation=https://github.com/qbittorrent/qBittorrent/wiki
|
||||||
|
After=network.target
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
User=%i
|
||||||
|
Type=forking
|
||||||
|
ExecStart=/usr/bin/qbittorrent-nox --daemon --webui-port=8080
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=multi-user.target
|
Loading…
Reference in a new issue