alarm/uboot-odroid-c1 to 2011.03-4

This commit is contained in:
Kevin Mihelich 2015-01-10 19:38:24 +00:00
parent 2f4318fc02
commit 5d2aa02c2a
6 changed files with 111 additions and 5861 deletions

File diff suppressed because it is too large Load diff

View file

@ -1,7 +1,7 @@
From 26b9caa2359554bca862fba7298cde0d393eaee1 Mon Sep 17 00:00:00 2001
From 199913f814f1c21d612514ee6455940096fdaf50 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 21 Dec 2014 18:04:05 -0700
Subject: [PATCH 2/3] remove cross-compiling
Subject: [PATCH 1/3] remove cross-compiling
---
arch/arm/config.mk | 2 +-
@ -22,15 +22,15 @@ index 0f9bffe..ecd547a 100755
ifeq ($(BOARD),omap2420h4)
diff --git a/arch/arm/cpu/aml_meson/config.mk b/arch/arm/cpu/aml_meson/config.mk
index cdf0bbc..07bd9a0 100755
index 151ef9a..c0b0b2e 100755
--- a/arch/arm/cpu/aml_meson/config.mk
+++ b/arch/arm/cpu/aml_meson/config.mk
@@ -1,4 +1,4 @@
-CROSS_COMPILE=arm-none-eabi-
+#CROSS_COMPILE=arm-none-eabi-
ARM_CPU=cortex-a9
PLATFORM_CPPFLAGS += $(call cc-option,-mcpu=cortex-a9 -ffixed-r8 -mno-long-calls -Wall -fPIC )
#USE_PRIVATE_LIBGCC=yes
PLATFORM_CPPFLAGS += $(call cc-option,-mcpu=cortex-a9 -ffixed-r8 -mno-long-calls -Wall -fPIC )
PF_CPPFLAGS_NO_UNALIGNED := $(call cc-option, -mno-unaligned-access,)
--
2.2.1

View file

@ -1,7 +1,7 @@
From 4dd3392b9a0642fdbbfb9c00cf094f46c32cb210 Mon Sep 17 00:00:00 2001
From 8464678df565088ae553a204be9b3ce3e16f5d57 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 22 Dec 2014 09:55:32 -0700
Subject: [PATCH 3/3] sd_fusing tweaks
Subject: [PATCH 2/3] sd_fusing tweaks
---
sd_fuse/sd_fusing.sh | 13 ++++++-------

View file

@ -0,0 +1,64 @@
From dce379fc81564dea21306935463fc42419a3e089 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 10 Jan 2015 11:51:52 -0700
Subject: [PATCH 3/3] environment fixes
---
include/configs/hardkernel/odroidc.h | 34 ++++++++++++++++------------------
1 file changed, 16 insertions(+), 18 deletions(-)
diff --git a/include/configs/hardkernel/odroidc.h b/include/configs/hardkernel/odroidc.h
index 2099f3b..2bc8b2c 100644
--- a/include/configs/hardkernel/odroidc.h
+++ b/include/configs/hardkernel/odroidc.h
@@ -119,21 +119,12 @@
#define CONFIG_EXTRA_ENV_SETTINGS \
"boardname=ODROIDC\0" \
- "bootargs=root=" MK_STR(CONFIG_DEFAULT_ROOT) " rw " \
- "console=" CONFIG_CONSOLE_PROTOCOL " no_console_suspend\0" \
- "bootcmd="\
- "cfgload;" \
- "setenv bootargs root=" MK_STR(CONFIG_DEFAULT_ROOT) " rw " \
- "console=" CONFIG_CONSOLE_PROTOCOL " no_console_suspend " \
- "vdaccfg=${vdac_config} " \
- "logo=osd1,loaded,${fb_addr},${outputmode},full " \
- "hdmimode=${hdmimode} " \
- "cvbsmode=${cvbsmode} " \
- "hdmitx=${cecconfig} " \
- "androidboot.serialno=${fbt_id#}; " \
- "movi read boot 0 0x12000000;" \
- "movi read dtb 0 0x12800000;" \
- "bootm 0x12000000 - 0x12800000\0" \
+ "optargs=\0" \
+ "mmcargs=setenv bootargs console=ttyS0,115200n8 no_console_suspend " \
+ "root=/dev/mmcblk0p1 rw rootwait " \
+ "vdaccfg=0xa000 logo=osd1,loaded,0x7900000,720p,full dmfc=3 cvbsmode=576cvbs " \
+ "hdmimode=${m} m_bpp=${m_bpp} vout=${vout_mode} ${disableuhs} hdmitx=cec1 " \
+ "${optargs}\0" \
"bootm_low=0x00000000\0" \
"bootm_size=0x80000000\0" \
"bootpath=u-boot.bin\0" \
@@ -163,9 +154,16 @@
"movi read logo 0 ${loadaddr_logo};" \
"bmp display ${loadaddr_logo}; bmp scale\0" \
"vdac_config=0x10\0" \
- "video_dev=tvout\0"
-
-#define CONFIG_BOOTCOMMAND "bootm"
+ "video_dev=tvout\0" \
+ "loadimage=ext4load mmc 0:1 0x21000000 /boot/uImage\0" \
+ "loadfdt=ext4load mmc 0:1 0x21800000 /boot/dtbs/meson8b_odroidc.dtb\0"
+
+#define CONFIG_BOOTCOMMAND \
+ "cfgload;" \
+ "run loadimage;" \
+ "run loadfdt;" \
+ "run mmcargs;" \
+ "bootm 0x21000000 - 0x21800000;"
#define CONFIG_AUTO_COMPLETE 1
#define CONFIG_ENV_SIZE (32 * 1024) // unit: bytes
--
2.2.1

View file

@ -5,7 +5,7 @@ buildarch=4
pkgname=uboot-odroid-c1
pkgver=2011.03
pkgrel=3
pkgrel=4
pkgdesc="U-Boot for ODROID-C1"
arch=('armv7h')
url="https://github.com/hardkernel/u-boot"
@ -13,24 +13,24 @@ license=('GPL')
install=$pkgname.install
makedepends=('git' 'bc')
backup=('boot/boot.ini')
_commit=388b4ae60f25e5e1a7a625b2253a66d05ab725d0
_commit=e7d4447d551ccba5d60be8b11697aa0ab49086c4
source=("https://github.com/hardkernel/u-boot/archive/${_commit}.tar.gz"
'boot.ini'
'0001-add-ext4-support.patch'
'0002-remove-cross-compiling.patch'
'0003-sd_fusing-tweaks.patch')
md5sums=('b8b66d02d1fab2a4745a7b769bff4b0c'
'5f0868d53453af2f95f36d5094fa406f'
'c8d1d5911a15ed995cf7fd57ef86b8fe'
'127c91d5af47a6dd78fdaf19a77a5263'
'645b00a999368d95c36d6cb5ef2f1076')
'0001-remove-cross-compiling.patch'
'0002-sd_fusing-tweaks.patch'
'0003-environment-fixes.patch')
md5sums=('0fc20cde97358ab04b22b946d563e970'
'a9e2adb320a058236b1317c7f873c07c'
'112dd04a3e5e383ad8bdcdfe81423a05'
'd395e29e94e23151cb921ceb16ec3b88'
'1057399b0a9b309c51c94b7cb84bd743')
prepare() {
cd u-boot-${_commit}
git apply ../0001-add-ext4-support.patch
git apply ../0002-remove-cross-compiling.patch
git apply ../0003-sd_fusing-tweaks.patch
git apply ../0001-remove-cross-compiling.patch
git apply ../0002-sd_fusing-tweaks.patch
git apply ../0003-environment-fixes.patch
}
build() {

View file

@ -4,22 +4,35 @@ ODROIDC-UBOOT-CONFIG
# Uncomment only a single Line! The line with setenv written.
# At least one mode must be selected.
# setenv m "vga" # VGA 640x480
# setenv m "480p" # 480p 720x480
# setenv m "576p" # 576p 720x576
# setenv m "800x480p60hz" # WVGA 800x480
# setenv m "svga" # Super VGA 800x600
# setenv m "xga" # XGA 1024x768
setenv m "720p" # 720p 1280x720
# setenv m "800p" # 800p(WXGA) 1280x800
# setenv m "sxga" # SXGA 1280x1024
# setenv m "1080p" # 1080P 1920x1080
# setenv m "1920x1200" # 1920x1200
# setenv m "vga" # 640x480
# setenv m "480p" # 720x480
# setenv m "576p" # 720x576
# setenv m "800x480p60hz" # 800x480
# setenv m "800x600p60hz" # 800x600
# setenv m "1024x600p60hz" # 1024x600
# setenv m "1024x768p60hz" # 1024x768
# setenv m "1360x768p60hz" # 1360x768
# setenv m "1366x768p60hz" # 1366x768
# setenv m "1440x900p60hz" # 1440x900
# setenv m "1680x1050p60hz" # 1680x1050
# setenv m "720p" # 720p 1280x720
# setenv m "800p" # 1280x800
# setenv m "sxga" # 1280x1024
setenv m "1080p" # 1080P 1920x1080
# setenv m "1920x1200" # 1920x1200
# HDMI DVI Mode Configuration
setenv vout_mode "hdmi"
# setenv vout_mode "dvi"
# HDMI BPP Mode
setenv m_bpp "32"
# setenv m_bpp "16"
setenv bootargs "console=ttyS0,115200n8 root=/dev/mmcblk0p1 rootwait rw no_console_suspend vdaccfg=0xa000 logo=osd1,loaded,0x7900000,720p,full dmfc=3 cvbsmode=576cvbs hdmimode=${m} m_bpp=${m_bpp} mac=${ethaddr}"
setenv bootcmd "ext4load mmc 0:1 0x21000000 /boot/uImage; ext4load mmc 0:1 0x21800000 /boot/dtbs/meson8b_odroidc.dtb; bootm 0x21000000 - 0x21800000"
run bootcmd
# UHS Card Configuration
# Uncomment the line below to __DISABLE__ UHS-1 MicroSD support
# This might break boot for some brand models of cards.
setenv disableuhs "disableuhs"
# Uncomment and set the line below to append additional bootargs
# setenv optargs ""