mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/gstreamer0.10-bad to 0.10.23-10
This commit is contained in:
parent
bb1d8f03c6
commit
5d5430bde8
2 changed files with 41 additions and 3 deletions
|
@ -7,7 +7,7 @@
|
|||
pkgbase=gstreamer0.10-bad
|
||||
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
|
||||
pkgver=0.10.23
|
||||
pkgrel=9
|
||||
pkgrel=10
|
||||
arch=('i686' 'x86_64')
|
||||
license=('LGPL' 'GPL')
|
||||
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'git' 'spandsp' 'celt')
|
||||
|
@ -17,10 +17,12 @@ source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=5756
|
|||
fix-libmodplug-include.patch
|
||||
drop-vpx-compat-defs.patch
|
||||
disable-assrender-test.patch
|
||||
disable-camerabin-test.patch)
|
||||
disable-camerabin-test.patch
|
||||
faad2-version-check.patch)
|
||||
sha256sums=('SKIP'
|
||||
'e66642affa6c0e69837d37615010e67e59ef3d672663303d46c1e2591e2ddfc6'
|
||||
'01e780ddf1f8161a6115dded9dc5bf4bdd4d09a9eee00fa423b1330e90e76c68')
|
||||
'01e780ddf1f8161a6115dded9dc5bf4bdd4d09a9eee00fa423b1330e90e76c68'
|
||||
'741492ae7a9518603fc51d87ae331d882f075547ea7fdec19c60f399085f18cc')
|
||||
|
||||
prepare() {
|
||||
cd gst-plugins-bad
|
||||
|
@ -29,6 +31,7 @@ prepare() {
|
|||
patch -Np1 -i ../drop-vpx-compat-defs.patch
|
||||
patch -Np1 -i ../disable-assrender-test.patch
|
||||
patch -Np1 -i ../disable-camerabin-test.patch
|
||||
patch -Np1 -i ../faad2-version-check.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
35
extra/gstreamer0.10-bad/faad2-version-check.patch
Normal file
35
extra/gstreamer0.10-bad/faad2-version-check.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Wed, 13 May 2015 16:23:26 +0200
|
||||
Subject: fix faad2 version check
|
||||
|
||||
On fedora 22, the output of cpp inserts extra debug comments, which
|
||||
makes our regexp for the faad2 version check fail. This in turn causes
|
||||
it to compile with the wrong arguments passed which then causes stack
|
||||
corruption and crashes.
|
||||
|
||||
Fix this by only checking for the version (which should be by itself on
|
||||
a single line). This is potentially less safe, it might be possible that
|
||||
a similar string would appear in a later version in the header file.
|
||||
|
||||
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f5ce28c..d295253 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
|
||||
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
|
||||
for minor in 10 9 8 7 6 5 0; do
|
||||
if test x$faad2_minor_version = "x"; then
|
||||
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
|
||||
+ AC_EGREP_CPP([\"2\.$minor\"$], [
|
||||
#include <$faad_hdr>
|
||||
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
|
||||
+ FAAD2_VERSION
|
||||
], [
|
||||
faad2_minor_version=$minor
|
||||
])
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
Loading…
Reference in a new issue