core/glibc to 2.18-8

This commit is contained in:
Kevin Mihelich 2013-10-25 01:54:52 +00:00
parent 7980178aa2
commit 5dbf30e73a
4 changed files with 105 additions and 31 deletions

View file

@ -4,6 +4,8 @@
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
# NOTE: valgrind requires rebuilt with each major glibc version
# NOTE: adjust version in install script when locale files are updated
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - Patch for ld-linux-armhf.so.3 transition and symlink ld-linux.so.3
# - Patch for hard-float ld.so.cache transition
@ -14,7 +16,7 @@ noautobuild=1
pkgname=glibc
pkgver=2.18
pkgrel=5
pkgrel=8
pkgdesc="GNU C Library"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/libc"
@ -25,14 +27,15 @@ makedepends=('gcc>=4.7')
backup=(etc/gai.conf
etc/locale.gen
etc/nscd.conf)
options=('!strip' '!distcc')
options=('!strip' 'staticlibs' '!distcc')
install=glibc.install
source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
glibc-2.18-make-4.patch
glibc-2.18-readdir_r-CVE-2013-4237.patch
glibc-2.18-malloc-corrupt-CVE-2013-4332.patch
glibc-2.18-strcoll-CVE-2012-4412+4424.patch
glibc-2.18-malloc-corrupt-CVE-2013-4332.patch
glibc-2.18-strcoll-CVE-2012-4412+4424.patch
glibc-2.18-strstr-hackfix.patch
glibc-2.18-ptr-mangle-CVE-2013-4788.patch
glibc-2.18-ptr-mangle-CVE-2013-4788.patch
local-soname-hack.diff
fix-hf-ld.so.cache.patch
nscd.service
@ -41,6 +44,7 @@ source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
locale-gen)
md5sums=('88fbbceafee809e82efd52efa1e3c58f'
'SKIP'
'e1883c2d1b01ff73650db5f5bb5a5a52'
'154da6bf5a5248f42a7bf5bf08e01a47'
'b79561ab9dce900e9bbeaf0d49927c2b'
'c7264b99d0f7e51922a4d3126182c40a'
@ -51,11 +55,14 @@ md5sums=('88fbbceafee809e82efd52efa1e3c58f'
'd5fab2cd3abea65aa5ae696ea4a47d6b'
'da662ca76e7c8d7efbc7986ab7acea2d'
'07ac979b6ab5eeb778d55f041529d623'
'476e9113489f93b348b21e144b6a8fcf')
'b5fd017036fb91199ee76f670da8c15b')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
# compatibility with make-4.0 (submitted upstream)
patch -p1 -i $srcdir/glibc-2.18-make-4.patch
# upstream commit 91ce4085
patch -p1 -i $srcdir/glibc-2.18-readdir_r-CVE-2013-4237.patch
@ -125,7 +132,7 @@ build() {
}
check() {
# bug to file - the linker commands need to be reordered
# the linker commands need to be reordered - fixed in 2.19
LDFLAGS=${LDFLAGS/--as-needed,/}
cd ${srcdir}/glibc-build
@ -157,6 +164,11 @@ package() {
sed -e '1,3d' -e 's|/| |g' -e 's|\\| |g' -e 's|^|#|g' \
${srcdir}/glibc-${pkgver}/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
# remove the static libraries that have a shared counterpart
cd $pkgdir/usr/lib
# note: keep libc, libdl, libm, libpthread for binutils testsuite
rm lib{anl,BrokenLocale,crypt,nsl,resolv,rt,util}.a
# ALARM: symlink ld-linux.so.3 for hard-float
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && ln -s /lib/ld-${pkgver}.so ${pkgdir}/usr/lib/ld-linux.so.3

View file

@ -0,0 +1,45 @@
From dc76f0c32dae689a08aa21a1d206d4cd62adb278 Mon Sep 17 00:00:00 2001
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Date: Thu, 10 Oct 2013 14:26:12 +0900
Subject: [PATCH] configure: allow building with GNU Make 4
Currently, configure errors telling make 4 is too old
since it does not match our regexp.
configure.in: allow GNU Make 4.*
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
---
configure | 2 +-
configure.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure b/configure
index 5e2f4d0..e139bf0 100755
--- a/configure
+++ b/configure
@@ -4761,7 +4761,7 @@ $as_echo_n "checking version of $MAKE... " >&6; }
ac_prog_version=`$MAKE --version 2>&1 | sed -n 's/^.*GNU Make[^0-9]*\([0-9][0-9.]*\).*$/\1/p'`
case $ac_prog_version in
'') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
- 3.79* | 3.[89]*)
+ 3.79* | 3.[89]* | 4.*)
ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
*) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
diff --git a/configure.in b/configure.in
index a7f9881..95c36b6 100644
--- a/configure.in
+++ b/configure.in
@@ -984,7 +984,7 @@ AC_CHECK_PROG_VER(CC, ${ac_tool_prefix}gcc ${ac_tool_prefix}cc, -v,
critic_missing="$critic_missing gcc")
AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
[GNU Make[^0-9]*\([0-9][0-9.]*\)],
- [3.79* | 3.[89]*], critic_missing="$critic_missing make")
+ [3.79* | 3.[89]* | 4.*], critic_missing="$critic_missing make")
AC_CHECK_PROG_VER(MSGFMT, gnumsgfmt gmsgfmt msgfmt, --version,
[GNU gettext.* \([0-9]*\.[0-9.]*\)],
--
1.8.4.1

View file

@ -3,7 +3,10 @@ filelist=(libc.info{,-1,-2,-3,-4,-5,-6,-7,-8,-9,-10,-11})
post_upgrade() {
ldconfig -r .
locale-gen
if [[ $(vercmp 2.18 $2) = 1 ]]; then
locale-gen
fi
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do

View file

@ -4,39 +4,53 @@ set -e
LOCALEGEN=/etc/locale.gen
LOCALES=/usr/share/i18n/locales
if [ -n "$POSIXLY_CORRECT" ]; then
unset POSIXLY_CORRECT
fi
unset POSIXLY_CORRECT
[ -f $LOCALEGEN -a -s $LOCALEGEN ] || exit 0;
[ -s "$LOCALEGEN" ] || exit 0
# Remove all old locale dir and locale-archive before generating new
# locale data.
rm -rf /usr/lib/locale/* || true
rm -rf /usr/lib/locale/*
umask 022
is_entry_ok() {
if [ -n "$locale" -a -n "$charset" ] ; then
true
else
echo "error: Bad entry '$locale $charset'"
false
fi
gen() {
local locale=$1
local charset=$2
local input=
if [ -z "$locale" ] || [ -z "$charset" ]; then
echo "error: Bad entry '$locale $charset'"
return
fi
printf ' %s.%s\n' "$(echo "$locale" | sed 's/\([^.\@]*\).*/\1/')" "$charset"
if [ -f "$LOCALES/$locale" ]; then
input=$locale
else
input=$(echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/')
fi
localedef -i "$input" -c -f "$charset" -A /usr/share/locale/locale.alias "$locale"
}
maxjobs=$(grep -c processor /proc/cpuinfo 2>/dev/null || echo 1)
echo "Generating locales..."
while read locale charset; do \
case $locale in \#*) continue;; "") continue;; esac; \
is_entry_ok || continue
echo -n " `echo $locale | sed 's/\([^.\@]*\).*/\1/'`"; \
echo -n ".$charset"; \
echo -n `echo $locale | sed 's/\([^\@]*\)\(\@.*\)*/\2/'`; \
echo -n '...'; \
if [ -f $LOCALES/$locale ]; then input=$locale; else \
input=`echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; fi; \
localedef -i $input -c -f $charset -A /usr/share/locale/locale.alias $locale; \
echo ' done'; \
case $locale in
\#*|'')
continue
;;
esac
gen "$locale" "$charset" &
# keep no more than $maxjobs jobs in flight
while [ $(jobs | wc -l) -ge $maxjobs ]; do
sleep 0.25
jobs >/dev/null
done
done < $LOCALEGEN
wait
echo "Generation complete."