diff --git a/extra/icedtea-web/PKGBUILD b/extra/icedtea-web/PKGBUILD
index 4fe16bfc7..1e081cb7d 100644
--- a/extra/icedtea-web/PKGBUILD
+++ b/extra/icedtea-web/PKGBUILD
@@ -7,27 +7,25 @@
 
 pkgbase=icedtea-web
 pkgname=('icedtea-web' 'icedtea-web-doc')
-pkgver=1.5.2
+pkgver=1.6
 pkgrel=1
 arch=('i686' 'x86_64')
 url='http://icedtea.classpath.org/wiki/IcedTea-Web'
 license=('GPL2')
-# TODO do we still need 'chromium' and '--with-chromium'? What does it do?
-# https://www.java.com/en/download/faq/chrome.xml
 makedepends=('java-environment-openjdk' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'junit'
              'epiphany')
 optdepends=('rhino: for using proxy auto config files')
 # Due to broken path names in the tarball that fails with LANG=C in our chroot
 noextract=${pkgbase}-${pkgver}.tar.gz
 source=(http://icedtea.classpath.org/download/source/${pkgbase}-${pkgver}.tar.gz)
-sha256sums=('b29e8ff2533cc6521a6509a002001f4c97c80a004460063156d003898da13bf3')
+sha256sums=('169386ad8d43c51b0c23ef128f9ba99040d23d9ceec24d7429514576778e117d')
 
 case $CARCH in
   armv6h)
     makedepends+=('firefox')
     ;;
   armv7h)
-    makedepends+=('firefox' 'chromium')
+    makedepends+=('firefox')
     ;;
 esac
 
@@ -43,9 +41,7 @@ build() {
       _arm_configure="--with-firefox=/usr/bin/firefox"
       ;;
     armv7h)
-      _arm_configure="\
-        --with-firefox=/usr/bin/firefox \
-        --with-chromium=/usr/bin/chromium"
+      _arm_configure="--with-firefox=/usr/bin/firefox"
       ;;
   esac