extra/openal: v8 fix

This commit is contained in:
Kevin Mihelich 2015-07-15 13:16:29 +00:00
parent c98571becf
commit 5e9b16a183
2 changed files with 23 additions and 3 deletions

View file

@ -5,6 +5,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - fix for unimplemented _FPU_EXTENDED
# - patch to use neon only on 32bit ARM
pkgname=openal
pkgver=1.16.0
@ -19,13 +20,19 @@ optdepends=('qt4: alsoft-config GUI Configurator'
'fluidsynth: MIDI rendering')
options=('!libtool')
source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2
no-fpuextended.patch)
no-fpuextended.patch
openal-soft-arm_neon-only-for-32bit.patch)
md5sums=('14db4b0d12f07252070b4fe5eb5911f6'
'de9569536f9f1c2b7b0e90d381c631de')
'de9569536f9f1c2b7b0e90d381c631de'
'5ca12576453226897c4d8821039a7f3e')
build() {
prepare() {
cd "${srcdir}/$pkgname-soft-$pkgver"
patch -p1 -i "${srcdir}"/no-fpuextended.patch
patch -p1 -i "${srcdir}"/openal-soft-arm_neon-only-for-32bit.patch
}
build() {
cd "${srcdir}/$pkgname-soft-$pkgver/build"
cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release ..
make

View file

@ -0,0 +1,13 @@
Index: openal-soft-1.16.0/CMakeLists.txt
===================================================================
--- openal-soft-1.16.0.orig/CMakeLists.txt
+++ openal-soft-1.16.0/CMakeLists.txt
@@ -679,7 +679,7 @@ ENDIF()
# Check for ARM Neon support
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H)
-IF(HAVE_ARM_NEON_H)
+IF(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
IF(ALSOFT_CPUEXT_NEON)
SET(HAVE_NEON 1)