community/argyllcms to 1.9.2-1

This commit is contained in:
Kevin Mihelich 2016-10-25 19:02:18 +00:00
parent 9a6721ac0d
commit 5e9d47d2fa
2 changed files with 3 additions and 26 deletions

View file

@ -7,7 +7,7 @@
pkgname=argyllcms
_pkgname=Argyll
pkgver=1.8.3
pkgver=1.9.2
_pkgver="V${pkgver}"
pkgrel=1
pkgdesc="An ICC compatible color management system with support for different colorimeter hardware"
@ -16,18 +16,15 @@ depends=('libtiff' 'libxss' 'libxinerama' 'libxxf86vm' 'libxrandr' 'openssl')
makedepends=('ftjam' 'zip' 'unzip')
# You need to fake an UserAgent or it doesn't download
DLAGENTS=('http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -A "Mozilla/4.0" -o %o %u')
source=(http://www.argyllcms.com/${_pkgname}_${_pkgver}_src.zip
argyllcms-1.8.0-gcc5.patch)
source=(http://www.argyllcms.com/${_pkgname}_${_pkgver}_src.zip)
url="http://www.argyllcms.com/"
license=("GPL" "AGPL")
install=${pkgname}.install
sha256sums=('60494176785f6c2e4e4daefb9452d83859880449040b2a843ed81de3bd0c558e'
'de9b8a90e249070d457291c29ae3c732f89c51bc6f6296cb6aa7e800ba31a0e5')
sha256sums=('4d61ae0b91686dea721d34df2e44eaf36c88da87086fd50ccc4e999a58e9ce90')
prepare() {
cd ${_pkgname}_${_pkgver}
sed -i 's:^TEST=="/lib/udev/usb-db", IMPORT{program}="usb-db %p":IMPORT{builtin}="hwdb --subsystem=usb":' usb/55-Argyll.rules
patch -Np1 -i "$srcdir"/argyllcms-1.8.0-gcc5.patch
sed -i 's/-j${NUMBER_OF_PROCESSORS:-2}/$MAKEFLAGS/' makeall.sh

View file

@ -1,20 +0,0 @@
Description: Fix FTBFS with GCC 5
Author: James Cowgill <james410@cowgill.org.uk>
Bug-Debian: https://bugs.debian.org/777779
Forwarded: no
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/icc/icc.h
+++ b/icc/icc.h
@@ -100,7 +100,11 @@
#define CF64PREC "LL" /* Constant precision specifier */
#ifndef ATTRIBUTE_NORETURN
+#ifdef _MSC_VER
# define ATTRIBUTE_NORETURN __declspec(noreturn)
+#else
+# define ATTRIBUTE_NORETURN __attribute__((noreturn))
+#endif
#endif
#else /* !__STDC_VERSION__ */