mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/xbmc-rbp, alarm/xbmc-rbp removed unused patch
This commit is contained in:
parent
5c56cb1b70
commit
5ea3554d7e
4 changed files with 6 additions and 65 deletions
|
@ -4,7 +4,7 @@
|
|||
buildarch=16
|
||||
|
||||
pkgname=xbmc-rbp-git
|
||||
pkgver=14.20140715
|
||||
pkgver=14.20140801
|
||||
pkgrel=1
|
||||
pkgdesc="A software media player and entertainment hub for digital media for the Raspberry Pi"
|
||||
arch=('armv6h')
|
||||
|
@ -22,12 +22,10 @@ provides=("xbmc")
|
|||
conflicts=("xbmc")
|
||||
install="xbmc.install"
|
||||
source=('xbmc.service'
|
||||
'polkit.rules'
|
||||
'fix_libnfs.patch')
|
||||
'polkit.rules')
|
||||
|
||||
md5sums=('55e6d3aab86e810c49a7f550be5b7f69'
|
||||
'02f7951824ee13103344f36009c0ef2a'
|
||||
'1086fdb02b838f0a5763e493bed59fc2')
|
||||
'02f7951824ee13103344f36009c0ef2a')
|
||||
|
||||
_gitname="xbmc"
|
||||
_gitroot="git://github.com/xbmc"
|
||||
|
@ -56,8 +54,6 @@ prepare() {
|
|||
|
||||
cd "${srcdir}/${_gitname}"
|
||||
|
||||
patch -Np1 -i "$srcdir/fix_libnfs.patch"
|
||||
|
||||
# fix lsb_release dependency
|
||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
diff --git a/xbmc/filesystem/NFSDirectory.cpp b/xbmc/filesystem/NFSDirectory.cpp
|
||||
index 85084a5..8efa7bf 100644
|
||||
--- a/xbmc/filesystem/NFSDirectory.cpp
|
||||
+++ b/xbmc/filesystem/NFSDirectory.cpp
|
||||
@@ -37,6 +37,7 @@
|
||||
using namespace XFILE;
|
||||
using namespace std;
|
||||
#include <limits.h>
|
||||
+#include <nfsc/libnfs-zdr.h>
|
||||
#include <nfsc/libnfs-raw-mount.h>
|
||||
#include <nfsc/libnfs-raw-nfs.h>
|
||||
|
||||
diff --git a/xbmc/filesystem/NFSFile.cpp b/xbmc/filesystem/NFSFile.cpp
|
||||
index 479f3fe..2aeea32 100644
|
||||
--- a/xbmc/filesystem/NFSFile.cpp
|
||||
+++ b/xbmc/filesystem/NFSFile.cpp
|
||||
@@ -32,6 +32,7 @@
|
||||
#include "network/DNSNameCache.h"
|
||||
#include "threads/SystemClock.h"
|
||||
|
||||
+#include <nfsc/libnfs-zdr.h>
|
||||
#include <nfsc/libnfs-raw-mount.h>
|
||||
|
||||
#ifdef TARGET_WINDOWS
|
||||
|
|
@ -8,7 +8,7 @@ buildarch=16
|
|||
pkgname=xbmc-rbp
|
||||
pkgver=13.1
|
||||
_codename=Gotham
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="A software media player and entertainment hub for digital media for the Raspberry Pi"
|
||||
arch=('armv6h')
|
||||
url="http://xbmc.org"
|
||||
|
@ -27,14 +27,12 @@ install="xbmc.install"
|
|||
source=("https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
|
||||
'xbmc.service'
|
||||
'polkit.rules'
|
||||
'panasonicCEC.patch'
|
||||
'fix_libnfs.patch')
|
||||
'panasonicCEC.patch')
|
||||
|
||||
sha256sums=('344b604eae2ddb47c032dd7964d01f27e6fcd7a8873c84c0841d5da75961a678'
|
||||
'189804742290946424a401163e351f5158bfd1b71e5b86b864589254b13f9571'
|
||||
'4ea78374a08e13a64dcf6a424b111b8bfc11de03ed5829744fc6d9b5fc1ec96e'
|
||||
'554140506063a85000d7072a961bb02514969e58b38a466aa120e9fb668a1863'
|
||||
'67dc3b48e47a90728f25bc0035be6d0a96685067c1779635f69288995ddaa161')
|
||||
'554140506063a85000d7072a961bb02514969e58b38a466aa120e9fb668a1863')
|
||||
|
||||
_prefix=/usr
|
||||
|
||||
|
@ -48,9 +46,6 @@ prepare() {
|
|||
# https://github.com/chbmuc/xbmc/commit/6e5822d4fe648abbd575cf77ced943a1461e9ae5
|
||||
# http://archlinuxarm.org/forum/viewtopic.php?f=31&t=6376&start=10
|
||||
patch -Np1 -i ${srcdir}/panasonicCEC.patch
|
||||
|
||||
# Fix missing headers includes
|
||||
patch -Np1 -i ${srcdir}/fix_libnfs.patch
|
||||
|
||||
# fix samba4 libsmbclient.h location
|
||||
sed -e 's/\(#include \)<libsmbclient\.h>/\1<samba-4.0\/libsmbclient\.h>/g' \
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
diff --git a/xbmc/filesystem/NFSDirectory.cpp b/xbmc/filesystem/NFSDirectory.cpp
|
||||
index 85084a5..8efa7bf 100644
|
||||
--- a/xbmc/filesystem/NFSDirectory.cpp
|
||||
+++ b/xbmc/filesystem/NFSDirectory.cpp
|
||||
@@ -37,6 +37,7 @@
|
||||
using namespace XFILE;
|
||||
using namespace std;
|
||||
#include <limits.h>
|
||||
+#include <nfsc/libnfs-zdr.h>
|
||||
#include <nfsc/libnfs-raw-mount.h>
|
||||
#include <nfsc/libnfs-raw-nfs.h>
|
||||
|
||||
diff --git a/xbmc/filesystem/NFSFile.cpp b/xbmc/filesystem/NFSFile.cpp
|
||||
index 479f3fe..2aeea32 100644
|
||||
--- a/xbmc/filesystem/NFSFile.cpp
|
||||
+++ b/xbmc/filesystem/NFSFile.cpp
|
||||
@@ -32,6 +32,7 @@
|
||||
#include "network/DNSNameCache.h"
|
||||
#include "threads/SystemClock.h"
|
||||
|
||||
+#include <nfsc/libnfs-zdr.h>
|
||||
#include <nfsc/libnfs-raw-mount.h>
|
||||
|
||||
#ifdef TARGET_WINDOWS
|
||||
|
Loading…
Reference in a new issue