mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/binutils to 2.30-5
This commit is contained in:
parent
619f9d9db8
commit
5eb816d7d5
3 changed files with 466 additions and 6 deletions
|
@ -0,0 +1,174 @@
|
|||
From c849ad001d6901825b29ddbe449e01a2e295598c Mon Sep 17 00:00:00 2001
|
||||
From: Renlin Li <renlin.li@arm.com>
|
||||
Date: Sat, 3 Feb 2018 13:18:17 +0000
|
||||
Subject: [PATCH] [PR22764][LD][AARCH64]Allow R_AARCH64_ABS16 and
|
||||
R_AARCH64_ABS32 against absolution symbol or undefine symbol in shared
|
||||
object.
|
||||
|
||||
backport from mainline
|
||||
|
||||
bfd/
|
||||
|
||||
2018-02-05 Renlin Li <renlin.li@arm.com>
|
||||
|
||||
PR ld/22764
|
||||
* elfnn-aarch64.c (elfNN_aarch64_check_relocs): Relax the
|
||||
R_AARCH64_ABS32 and R_AARCH64_ABS16 for absolute symbol. Apply the
|
||||
check for writeable section as well.
|
||||
|
||||
ld/
|
||||
|
||||
2018-02-05 Renlin Li <renlin.li@arm.com>
|
||||
|
||||
PR ld/22764
|
||||
* testsuite/ld-aarch64/emit-relocs-258.s: Define symbol as an address.
|
||||
* testsuite/ld-aarch64/emit-relocs-259.s: Likewise.
|
||||
* testsuite/ld-aarch64/aarch64-elf.exp: Run new test.
|
||||
* testsuite/ld-aarch64/pr22764.s: New.
|
||||
* testsuite/ld-aarch64/pr22764.d: New.
|
||||
---
|
||||
bfd/ChangeLog | 7 +++++++
|
||||
bfd/elfnn-aarch64.c | 15 ++++++++++++---
|
||||
ld/ChangeLog | 8 ++++++++
|
||||
ld/testsuite/ld-aarch64/aarch64-elf.exp | 1 +
|
||||
ld/testsuite/ld-aarch64/emit-relocs-258.s | 3 ++-
|
||||
ld/testsuite/ld-aarch64/emit-relocs-259.s | 3 ++-
|
||||
ld/testsuite/ld-aarch64/pr22764.d | 18 ++++++++++++++++++
|
||||
ld/testsuite/ld-aarch64/pr22764.s | 6 ++++++
|
||||
8 files changed, 56 insertions(+), 5 deletions(-)
|
||||
create mode 100644 ld/testsuite/ld-aarch64/pr22764.d
|
||||
create mode 100644 ld/testsuite/ld-aarch64/pr22764.s
|
||||
|
||||
diff --git a/bfd/ChangeLog b/bfd/ChangeLog
|
||||
index c310da6ed3..9b4cc6fc86 100644
|
||||
--- a/bfd/ChangeLog
|
||||
+++ b/bfd/ChangeLog
|
||||
@@ -1,3 +1,10 @@
|
||||
+2018-02-05 Renlin Li <renlin.li@arm.com>
|
||||
+
|
||||
+ PR ld/22764
|
||||
+ * elfnn-aarch64.c (elfNN_aarch64_check_relocs): Relax the
|
||||
+ R_AARCH64_ABS32 and R_AARCH64_ABS16 for absolute symbol. Apply the
|
||||
+ check for writeable section as well.
|
||||
+
|
||||
2018-01-27 Nick Clifton <nickc@redhat.com>
|
||||
|
||||
This is the 2.30 release:
|
||||
diff --git a/bfd/elfnn-aarch64.c b/bfd/elfnn-aarch64.c
|
||||
index d5711e0eb1..973188220b 100644
|
||||
--- a/bfd/elfnn-aarch64.c
|
||||
+++ b/bfd/elfnn-aarch64.c
|
||||
@@ -7074,10 +7074,19 @@ elfNN_aarch64_check_relocs (bfd *abfd, struct bfd_link_info *info,
|
||||
#if ARCH_SIZE == 64
|
||||
case BFD_RELOC_AARCH64_32:
|
||||
#endif
|
||||
- if (bfd_link_pic (info)
|
||||
- && (sec->flags & SEC_ALLOC) != 0
|
||||
- && (sec->flags & SEC_READONLY) != 0)
|
||||
+ if (bfd_link_pic (info) && (sec->flags & SEC_ALLOC) != 0)
|
||||
{
|
||||
+ if (h != NULL
|
||||
+ /* This is an absolute symbol. It represents a value instead
|
||||
+ of an address. */
|
||||
+ && ((h->root.type == bfd_link_hash_defined
|
||||
+ && bfd_is_abs_section (h->root.u.def.section))
|
||||
+ /* This is an undefined symbol. */
|
||||
+ || h->root.type == bfd_link_hash_undefined))
|
||||
+ break;
|
||||
+
|
||||
+ /* For local symbols, defined global symbols in a non-ABS section,
|
||||
+ it is assumed that the value is an address. */
|
||||
int howto_index = bfd_r_type - BFD_RELOC_AARCH64_RELOC_START;
|
||||
_bfd_error_handler
|
||||
/* xgettext:c-format */
|
||||
diff --git a/ld/ChangeLog b/ld/ChangeLog
|
||||
index 6337cd0cb6..379d8c0e49 100644
|
||||
--- a/ld/ChangeLog
|
||||
+++ b/ld/ChangeLog
|
||||
@@ -1,3 +1,11 @@
|
||||
+2018-02-05 Renlin Li <renlin.li@arm.com>
|
||||
+
|
||||
+ PR ld/22764
|
||||
+ * testsuite/ld-aarch64/emit-relocs-258.s: Define symbol as an address.
|
||||
+ * testsuite/ld-aarch64/emit-relocs-259.s: Likewise.
|
||||
+ * testsuite/ld-aarch64/pr22764.s: New.
|
||||
+ * testsuite/ld-aarch64/pr22764.d: New.
|
||||
+
|
||||
2018-01-27 Nick Clifton <nickc@redhat.com>
|
||||
|
||||
This is the 2.30 release:
|
||||
diff --git a/ld/testsuite/ld-aarch64/aarch64-elf.exp b/ld/testsuite/ld-aarch64/aarch64-elf.exp
|
||||
index f31089361b..d766f3736b 100644
|
||||
--- a/ld/testsuite/ld-aarch64/aarch64-elf.exp
|
||||
+++ b/ld/testsuite/ld-aarch64/aarch64-elf.exp
|
||||
@@ -275,6 +275,7 @@ run_dump_test "pr17415"
|
||||
run_dump_test_lp64 "tprel_g2_overflow"
|
||||
run_dump_test "tprel_add_lo12_overflow"
|
||||
run_dump_test "protected-data"
|
||||
+run_dump_test_lp64 "pr22764"
|
||||
|
||||
# ifunc tests
|
||||
run_dump_test "ifunc-1"
|
||||
diff --git a/ld/testsuite/ld-aarch64/emit-relocs-258.s b/ld/testsuite/ld-aarch64/emit-relocs-258.s
|
||||
index f724776243..87bb657c5d 100644
|
||||
--- a/ld/testsuite/ld-aarch64/emit-relocs-258.s
|
||||
+++ b/ld/testsuite/ld-aarch64/emit-relocs-258.s
|
||||
@@ -1,5 +1,6 @@
|
||||
+.global dummy
|
||||
.text
|
||||
-
|
||||
+dummy:
|
||||
ldr x0, .L1
|
||||
|
||||
.L1:
|
||||
diff --git a/ld/testsuite/ld-aarch64/emit-relocs-259.s b/ld/testsuite/ld-aarch64/emit-relocs-259.s
|
||||
index 7e1ba3ceb4..0977c9d869 100644
|
||||
--- a/ld/testsuite/ld-aarch64/emit-relocs-259.s
|
||||
+++ b/ld/testsuite/ld-aarch64/emit-relocs-259.s
|
||||
@@ -1,5 +1,6 @@
|
||||
+.global dummy
|
||||
.text
|
||||
-
|
||||
+dummy:
|
||||
ldr x0, .L1
|
||||
|
||||
.L1:
|
||||
diff --git a/ld/testsuite/ld-aarch64/pr22764.d b/ld/testsuite/ld-aarch64/pr22764.d
|
||||
new file mode 100644
|
||||
index 0000000000..997519f469
|
||||
--- /dev/null
|
||||
+++ b/ld/testsuite/ld-aarch64/pr22764.d
|
||||
@@ -0,0 +1,18 @@
|
||||
+#source: pr22764.s
|
||||
+#ld: -shared -T relocs.ld -defsym sym_abs1=0x1 -defsym sym_abs2=0x2 -defsym sym_abs3=0x3 -e0 --emit-relocs
|
||||
+#notarget: aarch64_be-*-*
|
||||
+#objdump: -dr
|
||||
+#...
|
||||
+
|
||||
+Disassembly of section \.text:
|
||||
+
|
||||
+0000000000010000 \<\.text\>:
|
||||
+ 10000: d503201f nop
|
||||
+ ...
|
||||
+ 10004: R_AARCH64_ABS64 sym_abs1
|
||||
+ 1000c: 00000002 \.word 0x00000002
|
||||
+ 1000c: R_AARCH64_ABS32 sym_abs2
|
||||
+ 10010: 0003 \.short 0x0003
|
||||
+ 10010: R_AARCH64_ABS16 sym_abs3
|
||||
+ 10012: 0000 \.short 0x0000
|
||||
+ 10014: d503201f nop
|
||||
diff --git a/ld/testsuite/ld-aarch64/pr22764.s b/ld/testsuite/ld-aarch64/pr22764.s
|
||||
new file mode 100644
|
||||
index 0000000000..25e36b4a12
|
||||
--- /dev/null
|
||||
+++ b/ld/testsuite/ld-aarch64/pr22764.s
|
||||
@@ -0,0 +1,6 @@
|
||||
+ .text
|
||||
+ nop
|
||||
+ .xword sym_abs1
|
||||
+ .word sym_abs2
|
||||
+ .short sym_abs3
|
||||
+ nop
|
||||
--
|
||||
2.17.0
|
||||
|
|
@ -0,0 +1,275 @@
|
|||
From 330b90b5ffbbc20c5de6ae6c7f60c40fab2e7a4f Mon Sep 17 00:00:00 2001
|
||||
From: Cary Coutant <ccoutant@gmail.com>
|
||||
Date: Fri, 23 Mar 2018 09:03:34 -0700
|
||||
Subject: [PATCH] Fix case where IR file provides symbol visibility but
|
||||
replacement file does not.
|
||||
|
||||
In PR 22868, two IR files provide conflicting visibility for a symbol.
|
||||
When a def with PROTECTED visibility is seen after a def with DEFAULT
|
||||
visibility, gold does not override the visibility. Later, if the
|
||||
replacement object define the symbol with DEFAULT visibility, the symbol
|
||||
remains DEFAULT. This was caused by a recent change to allow multiply-defined
|
||||
absolute symbols, combined with the fact that the plugin framework was using
|
||||
SHN_ABS as the section index for placeholder symbols. The solution is to
|
||||
use a real (but arbitrary) section index.
|
||||
|
||||
gold/
|
||||
PR gold/22868
|
||||
* plugin.cc (Sized_pluginobj::do_add_symbols): Use a real section
|
||||
index instead of SHN_ABS for defined symbols.
|
||||
* testsuite/Makefile.am (plugin_pr22868): New test case.
|
||||
* testsuite/Makefile.in: Regenerate
|
||||
* testsuite/plugin_pr22868.sh: New test script.
|
||||
* testsuite/plugin_pr22868_a.c: New source file.
|
||||
* testsuite/plugin_pr22868_b.c: New source file.
|
||||
---
|
||||
gold/plugin.cc | 3 ++-
|
||||
gold/testsuite/Makefile.am | 21 ++++++++++++++++++
|
||||
gold/testsuite/Makefile.in | 28 +++++++++++++++++++++---
|
||||
gold/testsuite/plugin_pr22868.sh | 45 +++++++++++++++++++++++++++++++++++++++
|
||||
gold/testsuite/plugin_pr22868_a.c | 28 ++++++++++++++++++++++++
|
||||
gold/testsuite/plugin_pr22868_b.c | 39 +++++++++++++++++++++++++++++++++
|
||||
6 files changed, 160 insertions(+), 4 deletions(-)
|
||||
create mode 100755 gold/testsuite/plugin_pr22868.sh
|
||||
create mode 100644 gold/testsuite/plugin_pr22868_a.c
|
||||
create mode 100644 gold/testsuite/plugin_pr22868_b.c
|
||||
|
||||
diff --git a/gold/plugin.cc b/gold/plugin.cc
|
||||
index 02fef25..a59f19d 100644
|
||||
--- a/gold/plugin.cc
|
||||
+++ b/gold/plugin.cc
|
||||
@@ -1144,7 +1144,8 @@ Sized_pluginobj<size, big_endian>::do_add_symbols(Symbol_table* symtab,
|
||||
{
|
||||
case LDPK_DEF:
|
||||
case LDPK_WEAKDEF:
|
||||
- shndx = elfcpp::SHN_ABS;
|
||||
+ // We use an arbitrary section number for a defined symbol.
|
||||
+ shndx = 1;
|
||||
break;
|
||||
case LDPK_COMMON:
|
||||
shndx = elfcpp::SHN_COMMON;
|
||||
diff --git a/gold/testsuite/Makefile.am b/gold/testsuite/Makefile.am
|
||||
index 16cae80..d086dad 100644
|
||||
--- a/gold/testsuite/Makefile.am
|
||||
+++ b/gold/testsuite/Makefile.am
|
||||
@@ -2433,6 +2433,27 @@ plugin_section_alignment.so: plugin_section_alignment.o gcctestdir/ld
|
||||
plugin_section_alignment.o: plugin_section_alignment.cc
|
||||
$(CXXCOMPILE) -O0 -c -fpic -o $@ $<
|
||||
|
||||
+check_SCRIPTS += plugin_pr22868.sh
|
||||
+check_DATA += plugin_pr22868.stdout
|
||||
+MOSTLYCLEANFILES += plugin_pr22868.stdout
|
||||
+plugin_pr22868.stdout: plugin_pr22868.so
|
||||
+ $(TEST_READELF) -W --dyn-syms $< >$@ 2>/dev/null
|
||||
+plugin_pr22868.so: plugin_pr22868_a.o.syms plugin_pr22868_b.o.syms plugin_pr22868_b.o plugin_test.so gcctestdir/ld
|
||||
+ $(LINK) -Bgcctestdir/ -shared -Wl,--plugin,"./plugin_test.so" plugin_pr22868_a.o.syms plugin_pr22868_b.o.syms
|
||||
+plugin_pr22868_a.o.syms: plugin_pr22868_a.o
|
||||
+ $(TEST_READELF) -sW $< >$@ 2>/dev/null
|
||||
+# Generate the .syms file from an alternate version of the original source
|
||||
+# file, with a "protected" visibility attribute. We'll link with a
|
||||
+# "replacement" object that does not have that attribute.
|
||||
+plugin_pr22868_b.o.syms: plugin_pr22868_b_ir.o
|
||||
+ $(TEST_READELF) -sW $< >$@ 2>/dev/null
|
||||
+plugin_pr22868_a.o: plugin_pr22868_a.c
|
||||
+ $(COMPILE) -c -fpic -o $@ $<
|
||||
+plugin_pr22868_b_ir.o: plugin_pr22868_b.c
|
||||
+ $(COMPILE) -c -DIR -fpic -o $@ $<
|
||||
+plugin_pr22868_b.o: plugin_pr22868_b.c
|
||||
+ $(COMPILE) -c -fpic -o $@ $<
|
||||
+
|
||||
endif PLUGINS
|
||||
|
||||
check_PROGRAMS += exclude_libs_test
|
||||
diff --git a/gold/testsuite/Makefile.in b/gold/testsuite/Makefile.in
|
||||
index bbf8dc1..22940ca 100644
|
||||
--- a/gold/testsuite/Makefile.in
|
||||
+++ b/gold/testsuite/Makefile.in
|
||||
@@ -591,16 +591,19 @@ check_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3) \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@am__append_52 = unused.c \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_final_layout \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_new_file \
|
||||
-@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_with_alignment
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_with_alignment \
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_pr22868.stdout
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@am__append_53 = plugin_final_layout.sh \
|
||||
-@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_with_alignment.sh
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_with_alignment.sh \
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_pr22868.sh
|
||||
|
||||
# Uses the plugin_final_layout.sh script above to avoid duplication
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@am__append_54 = plugin_final_layout.stdout \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_final_layout_readelf.stdout \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_new_file.stdout \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_new_file_readelf.stdout \
|
||||
-@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_with_alignment.stdout
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_layout_with_alignment.stdout \
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ plugin_pr22868.stdout
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@am__append_55 = exclude_libs_test \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@ local_labels_test \
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@ discard_locals_test
|
||||
@@ -5299,6 +5302,8 @@ plugin_final_layout.sh.log: plugin_final_layout.sh
|
||||
@p='plugin_final_layout.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
|
||||
plugin_layout_with_alignment.sh.log: plugin_layout_with_alignment.sh
|
||||
@p='plugin_layout_with_alignment.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
|
||||
+plugin_pr22868.sh.log: plugin_pr22868.sh
|
||||
+ @p='plugin_pr22868.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
|
||||
exclude_libs_test.sh.log: exclude_libs_test.sh
|
||||
@p='exclude_libs_test.sh'; $(am__check_pre) $(LOG_COMPILE) "$$tst" $(am__check_post)
|
||||
discard_locals_test.sh.log: discard_locals_test.sh
|
||||
@@ -7086,6 +7091,23 @@ uninstall-am:
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(CXXLINK) -Bgcctestdir/ -shared plugin_section_alignment.o
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_section_alignment.o: plugin_section_alignment.cc
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(CXXCOMPILE) -O0 -c -fpic -o $@ $<
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868.stdout: plugin_pr22868.so
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(TEST_READELF) -W --dyn-syms $< >$@ 2>/dev/null
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868.so: plugin_pr22868_a.o.syms plugin_pr22868_b.o.syms plugin_pr22868_b.o plugin_test.so gcctestdir/ld
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(LINK) -Bgcctestdir/ -shared -Wl,--plugin,"./plugin_test.so" plugin_pr22868_a.o.syms plugin_pr22868_b.o.syms
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868_a.o.syms: plugin_pr22868_a.o
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(TEST_READELF) -sW $< >$@ 2>/dev/null
|
||||
+# Generate the .syms file from an alternate version of the original source
|
||||
+# file, with a "protected" visibility attribute. We'll link with a
|
||||
+# "replacement" object that does not have that attribute.
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868_b.o.syms: plugin_pr22868_b_ir.o
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(TEST_READELF) -sW $< >$@ 2>/dev/null
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868_a.o: plugin_pr22868_a.c
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(COMPILE) -c -fpic -o $@ $<
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868_b_ir.o: plugin_pr22868_b.c
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(COMPILE) -c -DIR -fpic -o $@ $<
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@plugin_pr22868_b.o: plugin_pr22868_b.c
|
||||
+@GCC_TRUE@@NATIVE_LINKER_TRUE@@PLUGINS_TRUE@ $(COMPILE) -c -fpic -o $@ $<
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@exclude_libs_test.syms: exclude_libs_test
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@ $(TEST_READELF) -sW $< >$@ 2>/dev/null
|
||||
@GCC_TRUE@@NATIVE_LINKER_TRUE@libexclude_libs_test_1.a: exclude_libs_test_1.o
|
||||
diff --git a/gold/testsuite/plugin_pr22868.sh b/gold/testsuite/plugin_pr22868.sh
|
||||
new file mode 100755
|
||||
index 0000000..72f364b
|
||||
--- /dev/null
|
||||
+++ b/gold/testsuite/plugin_pr22868.sh
|
||||
@@ -0,0 +1,45 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
+# plugin_pr22868.sh -- a test case for the plugin API.
|
||||
+
|
||||
+# Copyright (C) 2018 Free Software Foundation, Inc.
|
||||
+# Written by Cary Coutant <ccoutant@google.com>.
|
||||
+
|
||||
+# This file is part of gold.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 3 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston,
|
||||
+# MA 02110-1301, USA.
|
||||
+
|
||||
+# This file goes with plugin_pr22868_a.c and plugin_pr22868_b.c,
|
||||
+# which check that if a symbol is declared PROTECTED in any IR file,
|
||||
+# it will remain PROTECTED in the output even if the replacement file(s)
|
||||
+# fail to declare it PROTECTED.
|
||||
+
|
||||
+check()
|
||||
+{
|
||||
+ if ! grep -q "$2" "$1"
|
||||
+ then
|
||||
+ echo "Did not find expected output in $1:"
|
||||
+ echo " $2"
|
||||
+ echo ""
|
||||
+ echo "Actual output below:"
|
||||
+ cat "$1"
|
||||
+ exit 1
|
||||
+ fi
|
||||
+}
|
||||
+
|
||||
+check plugin_pr22868.stdout "PROTECTED.*foo"
|
||||
+
|
||||
+exit 0
|
||||
diff --git a/gold/testsuite/plugin_pr22868_a.c b/gold/testsuite/plugin_pr22868_a.c
|
||||
new file mode 100644
|
||||
index 0000000..86a9843
|
||||
--- /dev/null
|
||||
+++ b/gold/testsuite/plugin_pr22868_a.c
|
||||
@@ -0,0 +1,28 @@
|
||||
+/* plugin_pr22868_a.c -- a test case for the plugin API with GC.
|
||||
+
|
||||
+ Copyright (C) 2018 Free Software Foundation, Inc.
|
||||
+ Written by Cary Coutant <ccoutant@gmail.com>.
|
||||
+
|
||||
+ This file is part of gold.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 3 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the Free Software
|
||||
+ Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston,
|
||||
+ MA 02110-1301, USA. */
|
||||
+
|
||||
+int foo(int i) __attribute__ (( weak ));
|
||||
+
|
||||
+int foo(int i)
|
||||
+{
|
||||
+ return i + 1;
|
||||
+}
|
||||
diff --git a/gold/testsuite/plugin_pr22868_b.c b/gold/testsuite/plugin_pr22868_b.c
|
||||
new file mode 100644
|
||||
index 0000000..92d2145
|
||||
--- /dev/null
|
||||
+++ b/gold/testsuite/plugin_pr22868_b.c
|
||||
@@ -0,0 +1,39 @@
|
||||
+/* plugin_pr22868_b_ir.c -- a test case for the plugin API with GC.
|
||||
+
|
||||
+ Copyright (C) 2018 Free Software Foundation, Inc.
|
||||
+ Written by Cary Coutant <ccoutant@gmail.com>.
|
||||
+
|
||||
+ This file is part of gold.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 3 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the Free Software
|
||||
+ Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston,
|
||||
+ MA 02110-1301, USA. */
|
||||
+
|
||||
+/* This file is compiled with -DIR to generate the .syms file,
|
||||
+ and without -DIR for use as the replacement object.
|
||||
+ The .syms file declares foo with protected visibility, but
|
||||
+ the replacement file does not. */
|
||||
+
|
||||
+#ifdef IR
|
||||
+#define PROTECTED __attribute__ (( visibility ("protected") ))
|
||||
+#else
|
||||
+#define PROTECTED
|
||||
+#endif
|
||||
+
|
||||
+int foo(int i) __attribute__ (( weak )) PROTECTED;
|
||||
+
|
||||
+int foo(int i)
|
||||
+{
|
||||
+ return i + 1;
|
||||
+}
|
||||
--
|
||||
2.9.3
|
||||
|
|
@ -5,15 +5,16 @@
|
|||
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Added a CONFIGFLAG for ARM, defining our build hosts
|
||||
# - --disable-sim, files provided by gdb
|
||||
# - Disabled make check, too processor/ram intensive, blows up
|
||||
# - Added a CONFIGFLAG for ARM, defining our build hosts
|
||||
# - --disable-sim, files provided by gdb
|
||||
# - Disabled make check, too processor/ram intensive, blows up
|
||||
# - upstream patch for AArch64
|
||||
|
||||
noautobuild=1
|
||||
|
||||
pkgname=binutils
|
||||
pkgver=2.30
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
pkgdesc='A set of programs to assemble and manipulate binary and object files'
|
||||
arch=(x86_64)
|
||||
url='http://www.gnu.org/software/binutils/'
|
||||
|
@ -25,13 +26,17 @@ options=(staticlibs !distcc !ccache)
|
|||
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
|
||||
0001-PR22741-objcopy-segfault-on-fuzzed-COFF-object.patch
|
||||
0002-PR22829-objcopy-strip-removes-PT_GNU_RELRO-from-lld-.patch
|
||||
0003-PR22836-r-s-doesnt-work-with-g3-using-GCC-7.patch)
|
||||
0003-PR22836-r-s-doesnt-work-with-g3-using-GCC-7.patch
|
||||
0004-PR22868-Fix-case-where-IR-file-provides-symbol-visibility.patch
|
||||
0001-PR22764-LD-AARCH64-Allow-R_AARCH64_ABS16-and-R_AARCH.patch)
|
||||
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
|
||||
md5sums=('ffc476dd46c96f932875d1b2e27e929f'
|
||||
'SKIP'
|
||||
'469164f3c93a0e92a697537b60c9806c'
|
||||
'0c679b37e90fb23de60a4d28329b956a'
|
||||
'53b5682e09c0a27e9994c3efdfe01d29')
|
||||
'53b5682e09c0a27e9994c3efdfe01d29'
|
||||
'0fac94f7fa54a95354454677d3e43994'
|
||||
'2b1d13379e401e8209e3d05016914d3b')
|
||||
|
||||
prepare() {
|
||||
mkdir -p binutils-build
|
||||
|
@ -50,6 +55,12 @@ prepare() {
|
|||
|
||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=22836
|
||||
patch -p1 -i "$srcdir/0003-PR22836-r-s-doesnt-work-with-g3-using-GCC-7.patch"
|
||||
|
||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=22868
|
||||
patch -p1 -i "$srcdir/0004-PR22868-Fix-case-where-IR-file-provides-symbol-visibility.patch"
|
||||
|
||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=22764
|
||||
patch -p1 -i "$srcdir/0001-PR22764-LD-AARCH64-Allow-R_AARCH64_ABS16-and-R_AARCH.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue