mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/irqbalance: v8 fix
This commit is contained in:
parent
261050926b
commit
5ec63879a4
3 changed files with 32 additions and 2 deletions
|
@ -4,6 +4,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - define WITH_NEON and ARM_FP_ABI
|
||||
# - AArch64 patch
|
||||
|
||||
pkgname=freerdp
|
||||
epoch=1
|
||||
|
|
|
@ -13,9 +13,16 @@ url="https://github.com/Irqbalance/irqbalance"
|
|||
license=('GPL')
|
||||
depends=('glib2' 'libcap-ng')
|
||||
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
|
||||
irqbalance.service)
|
||||
irqbalance.service
|
||||
irqbalance-fix-aarch64.patch)
|
||||
md5sums=('b15d975336080bcac4be0c1752d43cf3'
|
||||
'767061c257b26cc3e3c4a5e462166579')
|
||||
'767061c257b26cc3e3c4a5e462166579'
|
||||
'e3c0dce43ae1d68274c674ac3f91f250')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 -i ../irqbalance-fix-aarch64.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
|
22
extra/irqbalance/irqbalance-fix-aarch64.patch
Normal file
22
extra/irqbalance/irqbalance-fix-aarch64.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff --git a/procinterrupts.c b/procinterrupts.c
|
||||
index 63101d6..b70bfc2 100644
|
||||
--- a/procinterrupts.c
|
||||
+++ b/procinterrupts.c
|
||||
@@ -80,7 +80,7 @@ static int check_platform_device(char *name, struct irq_info *info)
|
||||
rc = 0;
|
||||
goto out;
|
||||
} else if (!strncmp(ent->d_name, "net", strlen("net"))) {
|
||||
- info->IRQ_TYPE_LEGACY;
|
||||
+ info->type = IRQ_TYPE_LEGACY;
|
||||
info->class = IRQ_ETH;
|
||||
rc = 0;
|
||||
goto out;
|
||||
@@ -94,7 +94,7 @@ static int check_platform_device(char *name, struct irq_info *info)
|
||||
|
||||
out:
|
||||
closedir(dirfd);
|
||||
- log(TO_ALL, LOG_DEBUG, "IRQ %s is of type %d and class %d\n", name, info->type, info->class)
|
||||
+ log(TO_ALL, LOG_DEBUG, "IRQ %s is of type %d and class %d\n", name, info->type, info->class);
|
||||
return rc;
|
||||
|
||||
}
|
Loading…
Reference in a new issue