core/gcc to 11.1.0-1

This commit is contained in:
Kevin Mihelich 2021-05-17 03:23:45 +00:00
parent 0db14f7c1b
commit 5eecee6675
3 changed files with 56 additions and 14 deletions

View file

@ -16,10 +16,10 @@
noautobuild=1 noautobuild=1
pkgname=(gcc gcc-libs gcc-fortran gcc-objc gcc-go gcc-d) pkgname=(gcc gcc-libs gcc-fortran gcc-objc gcc-go gcc-d)
pkgver=10.2.0 pkgver=11.1.0
_majorver=${pkgver%%.*} _majorver=${pkgver%%.*}
_islver=0.21 _islver=0.24
pkgrel=6 pkgrel=1
pkgdesc='The GNU Compiler Collection' pkgdesc='The GNU Compiler Collection'
arch=(x86_64) arch=(x86_64)
license=(GPL LGPL FDL custom) license=(GPL LGPL FDL custom)
@ -37,20 +37,24 @@ source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.
fs64270.patch fs64270.patch
ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch
ipa-fix-ICE-in-get_default_value.patch ipa-fix-ICE-in-get_default_value.patch
gcc-ada-repro.patch
gcc11-Wno-format-security.patch
0001-ARMv5-disable-LDRD-STRD.patch) 0001-ARMv5-disable-LDRD-STRD.patch)
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com 86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com 13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com> D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
sha256sums=('b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c' sha256sums=('4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf'
'SKIP' 'SKIP'
'777058852a3db9500954361e294881214f6ecd4b594c00da5eee974cd6a54960' '043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad'
'de48736f6e4153f03d0a5d38ceb6c6fdb7f054e8f47ddd6af0a3dbf14f27b931' 'de48736f6e4153f03d0a5d38ceb6c6fdb7f054e8f47ddd6af0a3dbf14f27b931'
'2513c6d9984dd0a2058557bf00f06d8d5181734e41dcfe07be7ed86f2959622a' '2513c6d9984dd0a2058557bf00f06d8d5181734e41dcfe07be7ed86f2959622a'
'c86372c207d174c0918d4aedf1cb79f7fc093649eb1ad8d9450dccc46849d308' 'c86372c207d174c0918d4aedf1cb79f7fc093649eb1ad8d9450dccc46849d308'
'1ef190ed4562c4db8c1196952616cd201cfdd788b65f302ac2cc4dabb4d72cee' '1ef190ed4562c4db8c1196952616cd201cfdd788b65f302ac2cc4dabb4d72cee'
'fcb11c9bcea320afd202b031b48f8750aeaedaa4b0c5dddcd2c0a16381e927e4' 'fcb11c9bcea320afd202b031b48f8750aeaedaa4b0c5dddcd2c0a16381e927e4'
'42865f2af3f48140580c4ae70b6ea03b5bdca0f29654773ef0d42ce00d60ea16' '42865f2af3f48140580c4ae70b6ea03b5bdca0f29654773ef0d42ce00d60ea16'
'1773f5137f08ac1f48f0f7297e324d5d868d55201c03068670ee4602babdef2f'
'504e4b5a08eb25b6c35f19fdbe0c743ae4e9015d0af4759e74150006c283585e'
'ac6663528a1cbea30ed9627ef41ef13f25b3cd49c31e22b45b04aa911e6f562f') 'ac6663528a1cbea30ed9627ef41ef13f25b3cd49c31e22b45b04aa911e6f562f')
prepare() { prepare() {
@ -75,15 +79,11 @@ prepare() {
# D hacks # D hacks
patch -p1 -i "$srcdir/gdc_phobos_path.patch" patch -p1 -i "$srcdir/gdc_phobos_path.patch"
# Turn off SSP for nostdlib|nodefaultlibs|ffreestanding # Reproducible gcc-ada
# https://bugs.archlinux.org/task/64270 patch -Np0 < "$srcdir/gcc-ada-repro.patch"
patch -p1 -i "$srcdir/fs64270.patch"
# Fix a crash in mpv when mesa 20.2 is compiled with LTO # configure.ac: When adding -Wno-format, also add -Wno-format-security
# https://gitlab.freedesktop.org/mesa/mesa/-/issues/3239 patch -Np0 < "$srcdir/gcc11-Wno-format-security.patch"
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96482
patch -Np1 -i ../ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch
patch -Np1 -i ../ipa-fix-ICE-in-get_default_value.patch
# ALARM: Specify build host types, triplet patch # ALARM: Specify build host types, triplet patch
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi --with-arch=armv5te --with-float=soft" [[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi --with-arch=armv5te --with-float=soft"

View file

@ -0,0 +1,15 @@
Avoid leaking current data on generated file for Ada.
Index: gcc/ada/gcc-interface/Makefile.in
===================================================================
--- gcc/ada/gcc-interface/Makefile.in (revision 268977)
+++ gcc/ada/gcc-interface/Makefile.in (working copy)
@@ -2407,6 +2407,7 @@ $(RTSDIR)/s-oscons.ads: ../stamp-gnatlib
$(OSCONS_CPP) ; \
$(OSCONS_EXTRACT) ; \
../bldtools/oscons/xoscons s-oscons)
+ touch -r $(fsrcpfx)ada/gsocket.h $@
gnatlib: ../stamp-gnatlib1-$(RTSDIR) ../stamp-gnatlib2-$(RTSDIR) $(RTSDIR)/s-oscons.ads
test -f $(RTSDIR)/s-oscons.ads || exit 1

View file

@ -0,0 +1,27 @@
2017-02-25 Jakub Jelinek <jakub@redhat.com>
* configure.ac: When adding -Wno-format, also add -Wno-format-security.
* configure: Regenerated.
--- gcc/configure.ac.jj 2017-02-13 12:20:53.000000000 +0100
+++ gcc/configure.ac 2017-02-25 12:42:32.859175403 +0100
@@ -480,7 +480,7 @@ AC_ARG_ENABLE(build-format-warnings,
AS_HELP_STRING([--disable-build-format-warnings],[don't use -Wformat while building GCC]),
[],[enable_build_format_warnings=yes])
AS_IF([test $enable_build_format_warnings = no],
- [wf_opt=-Wno-format],[wf_opt=])
+ [wf_opt="-Wno-format -Wno-format-security"],[wf_opt=])
ACX_PROG_CXX_WARNING_OPTS(
m4_quote(m4_do([-W -Wall -Wno-narrowing -Wwrite-strings ],
[-Wcast-qual -Wno-error=format-diag $wf_opt])),
--- gcc/configure.jj 2017-02-13 12:20:52.000000000 +0100
+++ gcc/configure 2017-02-25 12:42:50.041946391 +0100
@@ -6647,7 +6647,7 @@ else
fi
if test $enable_build_format_warnings = no; then :
- wf_opt=-Wno-format
+ wf_opt="-Wno-format -Wno-format-security"
else
wf_opt=
fi