extra/krita: fix

This commit is contained in:
Kevin Mihelich 2018-04-09 23:53:33 +00:00
parent 49da81ae7a
commit 5f3816bc75
2 changed files with 33 additions and 3 deletions

View file

@ -0,0 +1,26 @@
From 799b445e1cf2ca9810bb7b2a4fca73e897a8da4e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 9 Apr 2018 07:56:31 -0600
Subject: [PATCH] Fix ARM build
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efae71d..8db8c80 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -630,8 +630,8 @@ if (NOT ${CMAKE_SYSTEM_PROCESSOR} MATCHES "arm")
PURPOSE "Required by the Krita for vectorization")
macro_bool_to_01(Vc_FOUND HAVE_VC)
endif()
- configure_file(config-vc.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-vc.h )
endif()
+configure_file(config-vc.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-vc.h )
if(HAVE_VC)
message(STATUS "Vc found!")
--
2.16.2

View file

@ -3,6 +3,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove makedepend on vc
# - patch to fix building on ARM
pkgname=krita
pkgver=4.0.1
@ -17,13 +18,16 @@ optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio:
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins')
conflicts=(calligra-krita krita-l10n)
replaces=(calligra-krita krita-l10n)
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig})
sha256sums=('e187b91c97c80e0ae7c10085611ea19143ad4f4bb0013f223f604060f218010a'
'SKIP')
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig}
'0001-Fix-ARM-build.patch')
sha256sums=('da44e964cb2c0e409b18f3d50f92734d6e6e15e2ce494659b6dc52fed8d8218c'
'SKIP'
'14c43c57daf4fdff8f28abc844c1804a4bc9c898c4782daca7ab5cbd21ae48d2')
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
patch -p1 -d $pkgname-$pkgver -i ../0001-Fix-ARM-build.patch
}
build() {