extra/freecad to 0.21.1-6

This commit is contained in:
Kevin Mihelich 2023-11-20 13:59:12 +00:00
parent fba99aa73e
commit 5f72f541be
3 changed files with 25 additions and 4 deletions

View file

@ -1,7 +1,7 @@
pkgbase = freecad
pkgdesc = Feature based parametric 3D CAD modeler
pkgver = 0.21.1
pkgrel = 5
pkgrel = 6
url = https://freecadweb.org/
arch = x86_64
license = LGPL
@ -55,6 +55,8 @@ pkgbase = freecad
optdepends = graphviz: dependency graph support
optdepends = openscad: OpenSCAD support
source = git+https://github.com/freecad/freecad#commit=f6708547a9bb3f71a4aaade12109f511a72c207c
source = freecad-vtk9.3.patch
b2sums = SKIP
b2sums = 709e6321a45b050187a6c5447b4381a5e9958687a1a5f25d0418f63e85f52e040fdf37fb1aa1d2886e06edb1b5b4cce847cf4865d4e6396fdfb4839557657f53
pkgname = freecad

View file

@ -18,7 +18,7 @@ highmem=1
pkgname=freecad
pkgver=0.21.1
pkgrel=5
pkgrel=6
pkgdesc='Feature based parametric 3D CAD modeler'
arch=(x86_64)
url='https://freecadweb.org/'
@ -33,8 +33,14 @@ makedepends=(boost cgns cmake eigen git libharu liblas ninja openvdb openvr
qt5-webengine shiboken2 swig utf8cpp nlohmann-json)
optdepends=('graphviz: dependency graph support'
'openscad: OpenSCAD support')
source=("git+https://github.com/$pkgname/$pkgname#commit=f6708547a9bb3f71a4aaade12109f511a72c207c") # tag: 0.21.1
b2sums=('SKIP')
source=("git+https://github.com/$pkgname/$pkgname#commit=f6708547a9bb3f71a4aaade12109f511a72c207c"
freecad-vtk9.3.patch) # tag: 0.21.1
b2sums=('SKIP'
'709e6321a45b050187a6c5447b4381a5e9958687a1a5f25d0418f63e85f52e040fdf37fb1aa1d2886e06edb1b5b4cce847cf4865d4e6396fdfb4839557657f53')
prepare() {
patch -d freecad -Np1 -i "$srcdir"/freecad-vtk9.3.patch
}
build() {
cmake \

View file

@ -0,0 +1,13 @@
diff --git a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
index 7e3de0070a..2f81a799de 100644
--- a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+++ b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
@@ -1026,7 +1026,7 @@ void SMDS_UnstructuredGrid::BuildLinks()
GetLinks()->Allocate(this->GetNumberOfPoints());
GetLinks()->Register(this);
//FIXME: vtk9
- GetLinks()->BuildLinks(this);
+ GetLinks()->BuildLinks();
GetLinks()->Delete();
#else
this->Links = SMDS_CellLinks::New();