mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
remove community/opencolorio
This commit is contained in:
parent
20164b61cc
commit
5f7e99352d
3 changed files with 0 additions and 260 deletions
|
@ -1,30 +0,0 @@
|
|||
From 7e8ed9c0f426bf5aac758a59a31e0d3ebcaef6c2 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 1 Feb 2021 09:40:42 -0700
|
||||
Subject: [PATCH] remove duplicate ProcessorCache declaration
|
||||
|
||||
Fixes multiple declaration error on ARM:
|
||||
/usr/bin/ld: src/OpenColorIO/CMakeFiles/OpenColorIO.dir/Processor.cpp.o:(.rodata+0x0): multiple definition of `typeinfo name for OpenColorIO_v2_0::ProcessorCache<unsigned int, std::shared_ptr<OpenColorIO_v2_0::Processor> >'; src/OpenColorIO/CMakeFiles/OpenColorIO.dir/Config.cpp.o:(.rodata+0x1d4): first defined here
|
||||
/usr/bin/ld: src/OpenColorIO/CMakeFiles/OpenColorIO.dir/Processor.cpp.o:(.data.rel.ro+0x0): multiple definition of `typeinfo for OpenColorIO_v2_0::ProcessorCache<unsigned int, std::shared_ptr<OpenColorIO_v2_0::Processor> >'; src/OpenColorIO/CMakeFiles/OpenColorIO.dir/Config.cpp.o:(.data.rel.ro+0x0): first defined here
|
||||
---
|
||||
src/OpenColorIO/Config.cpp | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/src/OpenColorIO/Config.cpp b/src/OpenColorIO/Config.cpp
|
||||
index a207e439..07b2c9f2 100644
|
||||
--- a/src/OpenColorIO/Config.cpp
|
||||
+++ b/src/OpenColorIO/Config.cpp
|
||||
@@ -1140,10 +1140,6 @@ public:
|
||||
|
||||
|
||||
|
||||
-// Instantiate the cache with the right types.
|
||||
-template class ProcessorCache<std::size_t, ProcessorRcPtr>;
|
||||
-
|
||||
-
|
||||
///////////////////////////////////////////////////////////////////////////
|
||||
|
||||
ConfigRcPtr Config::Create()
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1,48 +0,0 @@
|
|||
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
|
||||
# Contributor: Dumitru Ursu <dima@ceata.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix 32-bit ARM FTBFS
|
||||
|
||||
pkgname=opencolorio
|
||||
pkgver=2.0.1
|
||||
pkgrel=3
|
||||
pkgdesc="A color management framework for visual effects and animation"
|
||||
arch=('x86_64')
|
||||
url="https://opencolorio.org"
|
||||
license=('BSD')
|
||||
depends=('freeglut' 'glew' 'lcms2' 'tinyxml' 'yaml-cpp' 'imath' 'pystring')
|
||||
makedepends=('cmake' 'python' 'pybind11' 'ninja')
|
||||
optdepends=('python: python bindings')
|
||||
source=($pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v$pkgver.tar.gz
|
||||
opencolorio-openexr3.patch
|
||||
0001-remove-duplicate-ProcessorCache-declaration.patch)
|
||||
sha512sums=('5787cc4cadb0a1832c925712ca0dfef6e843082b9461460e1798326c6fceaa97bee78e5298651e6a8a3662b348eab5ab9791e94c3efcac337da07229fb559338'
|
||||
'269a86e4020d272b64af631ba01f9b1e644bde119e9bfb1d5ec3fd62579d5d3f7ab31295fb6cffc51d7349c469e2ca6e12f69310317266eda602541e9fcff94f'
|
||||
'204c51ebf446e5fe83a9fa094b6037f1a5c0bb5240395176bed52f6b9f3082c3df13a4dc2589a924e1084ceea0692af9dd95a01d9461cd7d3bff511c66aba648')
|
||||
|
||||
prepare() {
|
||||
patch -d OpenColorIO-$pkgver -p1 < opencolorio-openexr3.patch
|
||||
cd OpenColorIO-$pkgver
|
||||
patch -p1 -i ../0001-remove-duplicate-ProcessorCache-declaration.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd OpenColorIO-$pkgver
|
||||
|
||||
cmake \
|
||||
-GNinja \
|
||||
-Bbuild \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib
|
||||
ninja -C build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd OpenColorIO-$pkgver
|
||||
|
||||
DESTDIR="$pkgdir" ninja -C build install
|
||||
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,182 +0,0 @@
|
|||
diff --git a/share/cmake/modules/FindExtPackages.cmake b/share/cmake/modules/FindExtPackages.cmake
|
||||
index c98e0af3..5f685935 100644
|
||||
--- a/share/cmake/modules/FindExtPackages.cmake
|
||||
+++ b/share/cmake/modules/FindExtPackages.cmake
|
||||
@@ -34,7 +34,7 @@ find_package(yaml-cpp 0.6.3 REQUIRED)
|
||||
|
||||
# Half (OpenEXR/IlmBase)
|
||||
# https://github.com/openexr/openexr
|
||||
-find_package(Half 2.4.0 REQUIRED)
|
||||
+find_package(Imath 3.0 REQUIRED)
|
||||
|
||||
# pystring
|
||||
# https://github.com/imageworks/pystring
|
||||
diff --git a/src/OpenColorIO/BitDepthUtils.h b/src/OpenColorIO/BitDepthUtils.h
|
||||
index a8b3cbd9..bb0163bf 100644
|
||||
--- a/src/OpenColorIO/BitDepthUtils.h
|
||||
+++ b/src/OpenColorIO/BitDepthUtils.h
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
#include <OpenColorIO/OpenColorIO.h>
|
||||
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
|
||||
|
||||
namespace OCIO_NAMESPACE
|
||||
diff --git a/src/OpenColorIO/CMakeLists.txt b/src/OpenColorIO/CMakeLists.txt
|
||||
index 2ce801e6..824f8a98 100755
|
||||
--- a/src/OpenColorIO/CMakeLists.txt
|
||||
+++ b/src/OpenColorIO/CMakeLists.txt
|
||||
@@ -207,7 +207,7 @@ target_link_libraries(OpenColorIO
|
||||
public_api
|
||||
PRIVATE
|
||||
expat::expat
|
||||
- IlmBase::Half
|
||||
+ Imath::Imath
|
||||
pystring::pystring
|
||||
sampleicc::sampleicc
|
||||
utils::strings
|
||||
diff --git a/src/OpenColorIO/MathUtils.h b/src/OpenColorIO/MathUtils.h
|
||||
index 309c6244..0873d490 100644
|
||||
--- a/src/OpenColorIO/MathUtils.h
|
||||
+++ b/src/OpenColorIO/MathUtils.h
|
||||
@@ -9,7 +9,7 @@
|
||||
|
||||
#include <OpenColorIO/OpenColorIO.h>
|
||||
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
|
||||
namespace OCIO_NAMESPACE
|
||||
{
|
||||
diff --git a/src/OpenColorIO/ops/range/RangeOp.cpp b/src/OpenColorIO/ops/range/RangeOp.cpp
|
||||
index 9ec863e2..444dac75 100644
|
||||
--- a/src/OpenColorIO/ops/range/RangeOp.cpp
|
||||
+++ b/src/OpenColorIO/ops/range/RangeOp.cpp
|
||||
@@ -7,7 +7,7 @@
|
||||
#include <OpenColorIO/OpenColorIO.h>
|
||||
|
||||
#include "GpuShaderUtils.h"
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
#include "HashUtils.h"
|
||||
#include "MathUtils.h"
|
||||
#include "ops/lut1d/Lut1DOpData.h"
|
||||
diff --git a/src/OpenColorIO/transforms/builtins/ACES.cpp b/src/OpenColorIO/transforms/builtins/ACES.cpp
|
||||
index 20968c0d..9ee2ac27 100644
|
||||
--- a/src/OpenColorIO/transforms/builtins/ACES.cpp
|
||||
+++ b/src/OpenColorIO/transforms/builtins/ACES.cpp
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
#include <OpenColorIO/OpenColorIO.h>
|
||||
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
#include "ops/fixedfunction/FixedFunctionOp.h"
|
||||
#include "ops/gradingrgbcurve/GradingRGBCurveOp.h"
|
||||
#include "ops/log/LogOp.h"
|
||||
diff --git a/src/OpenColorIO/transforms/builtins/OpHelpers.cpp b/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
|
||||
index 04b8fbd4..288ca566 100644
|
||||
--- a/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
|
||||
+++ b/src/OpenColorIO/transforms/builtins/OpHelpers.cpp
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
#include <OpenColorIO/OpenColorIO.h>
|
||||
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
#include "ops/lut1d/Lut1DOp.h"
|
||||
#include "transforms/builtins/OpHelpers.h"
|
||||
|
||||
diff --git a/src/apps/ocioconvert/CMakeLists.txt b/src/apps/ocioconvert/CMakeLists.txt
|
||||
index 68a5db17..6fea394a 100755
|
||||
--- a/src/apps/ocioconvert/CMakeLists.txt
|
||||
+++ b/src/apps/ocioconvert/CMakeLists.txt
|
||||
@@ -27,7 +27,7 @@ set_target_properties(ocioconvert PROPERTIES
|
||||
target_link_libraries(ocioconvert
|
||||
PRIVATE
|
||||
apputils
|
||||
- IlmBase::Half
|
||||
+ Imath::Imath
|
||||
${OCIO_GL_LIB}
|
||||
oiiohelpers
|
||||
OpenColorIO
|
||||
diff --git a/src/apps/ocioconvert/main.cpp b/src/apps/ocioconvert/main.cpp
|
||||
index b56d4999..7e8af7d0 100644
|
||||
--- a/src/apps/ocioconvert/main.cpp
|
||||
+++ b/src/apps/ocioconvert/main.cpp
|
||||
@@ -24,7 +24,7 @@ namespace OIIO = OIIO_NAMESPACE;
|
||||
#endif // OCIO_GPU_ENABLED
|
||||
|
||||
#include "oiiohelpers.h"
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
|
||||
|
||||
// Array of non OpenColorIO arguments.
|
||||
diff --git a/src/apps/ocioperf/CMakeLists.txt b/src/apps/ocioperf/CMakeLists.txt
|
||||
index 69e9ba4c..bcbe47be 100644
|
||||
--- a/src/apps/ocioperf/CMakeLists.txt
|
||||
+++ b/src/apps/ocioperf/CMakeLists.txt
|
||||
@@ -20,7 +20,7 @@ set_target_properties(ocioperf PROPERTIES
|
||||
target_link_libraries(ocioperf
|
||||
PRIVATE
|
||||
apputils
|
||||
- IlmBase::Half
|
||||
+ Imath::Imath
|
||||
oiiohelpers
|
||||
OpenColorIO
|
||||
OpenImageIO::OpenImageIO
|
||||
diff --git a/src/apps/ocioperf/main.cpp b/src/apps/ocioperf/main.cpp
|
||||
index 6427860d..f6e4a63c 100644
|
||||
--- a/src/apps/ocioperf/main.cpp
|
||||
+++ b/src/apps/ocioperf/main.cpp
|
||||
@@ -11,7 +11,7 @@ namespace OIIO = OIIO_NAMESPACE;
|
||||
#endif
|
||||
|
||||
#include "apputils/argparse.h"
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
#include "oiiohelpers.h"
|
||||
#include "utils/StringUtils.h"
|
||||
|
||||
diff --git a/src/libutils/oiiohelpers/CMakeLists.txt b/src/libutils/oiiohelpers/CMakeLists.txt
|
||||
index 6ef7c368..5f4a5113 100644
|
||||
--- a/src/libutils/oiiohelpers/CMakeLists.txt
|
||||
+++ b/src/libutils/oiiohelpers/CMakeLists.txt
|
||||
@@ -31,7 +31,7 @@ target_link_libraries(oiiohelpers
|
||||
|
||||
PRIVATE
|
||||
OpenColorIO
|
||||
- IlmBase::Half
|
||||
+ Imath::Imath
|
||||
utils::strings
|
||||
)
|
||||
|
||||
diff --git a/src/libutils/oiiohelpers/oiiohelpers.cpp b/src/libutils/oiiohelpers/oiiohelpers.cpp
|
||||
index be1a937d..e7db652c 100644
|
||||
--- a/src/libutils/oiiohelpers/oiiohelpers.cpp
|
||||
+++ b/src/libutils/oiiohelpers/oiiohelpers.cpp
|
||||
@@ -5,7 +5,7 @@
|
||||
#include <OpenColorIO/OpenColorIO.h>
|
||||
|
||||
|
||||
-#include "OpenEXR/half.h"
|
||||
+#include "Imath/half.h"
|
||||
#include "oiiohelpers.h"
|
||||
#include "utils/StringUtils.h"
|
||||
|
||||
diff --git a/tests/cpu/CMakeLists.txt b/tests/cpu/CMakeLists.txt
|
||||
index 67389962..8e8dd900 100755
|
||||
--- a/tests/cpu/CMakeLists.txt
|
||||
+++ b/tests/cpu/CMakeLists.txt
|
||||
@@ -18,7 +18,7 @@ function(add_ocio_test NAME SOURCES PRIVATE_INCLUDES)
|
||||
public_api
|
||||
PRIVATE
|
||||
expat::expat
|
||||
- IlmBase::Half
|
||||
+ Imath::Imath
|
||||
pystring::pystring
|
||||
sampleicc::sampleicc
|
||||
unittest_data
|
Loading…
Reference in a new issue