mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/sensors-applet to 3.0.0-3
This commit is contained in:
parent
ae2857c968
commit
5f989a7ed9
4 changed files with 82 additions and 8 deletions
|
@ -1,13 +1,12 @@
|
|||
pkgbase = sensors-applet
|
||||
pkgdesc = Applet for GNOME Panel to display readings from hardware sensors
|
||||
pkgver = 3.0.0
|
||||
pkgrel = 2
|
||||
pkgrel = 3
|
||||
epoch = 1
|
||||
url = https://sensors-applet.sourceforge.net/
|
||||
arch = x86_64
|
||||
license = GPL-2.0-or-later
|
||||
makedepends = git
|
||||
makedepends = gnome-common
|
||||
makedepends = intltool
|
||||
makedepends = yelp-tools
|
||||
depends = cairo
|
||||
|
@ -27,9 +26,11 @@ pkgbase = sensors-applet
|
|||
source = fix-crash-destroying-active-sensor.patch
|
||||
source = port-to-libgnome-panel.patch
|
||||
source = sensors-applet-3.0.0-udisks2-plugin.patch
|
||||
sha256sums = SKIP
|
||||
source = drop-gnome-common.patch
|
||||
sha256sums = 6ec258baf1bb697de8492ba231d23cd849d964ccfae801d52c9b199864c0fea9
|
||||
sha256sums = 9c4cc2accf326c44cb625f5db0b82a782351cdf8829f1a4067a30f287b6b7156
|
||||
sha256sums = cb0e35e0d6e6568f14836da7e5b78154bd4d9a4127f0f6dd476e4f7c9d62339d
|
||||
sha256sums = ca6489da2e82df77e5a3b4e71e99689954132d5110f1c7bffc2f0ee7c35d4b33
|
||||
sha256sums = 82f2ea8cae09976f1c82c000e1b135d1e3081dc47355d4aad7fe4166995599c0
|
||||
|
||||
pkgname = sensors-applet
|
||||
|
|
3
extra/sensors-applet/.nvchecker.toml
Normal file
3
extra/sensors-applet/.nvchecker.toml
Normal file
|
@ -0,0 +1,3 @@
|
|||
[sensors-applet]
|
||||
source = "git"
|
||||
git = "https://git.code.sf.net/p/sensors-applet/code"
|
|
@ -5,7 +5,7 @@
|
|||
|
||||
pkgname=sensors-applet
|
||||
pkgver=3.0.0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
epoch=1
|
||||
pkgdesc='Applet for GNOME Panel to display readings from hardware sensors'
|
||||
arch=('x86_64')
|
||||
|
@ -13,24 +13,27 @@ url='https://sensors-applet.sourceforge.net/'
|
|||
license=('GPL-2.0-or-later')
|
||||
depends=('cairo' 'dconf' 'gdk-pixbuf2' 'glib2' 'glibc' 'gnome-panel' 'gtk3' 'hicolor-icon-theme'
|
||||
'libx11' 'lm_sensors')
|
||||
makedepends=('git' 'gnome-common' 'intltool' 'yelp-tools')
|
||||
makedepends=('git' 'intltool' 'yelp-tools')
|
||||
optdepends=('hddtemp: get HDD temperatures'
|
||||
'udisks2: get HDD temperatures')
|
||||
_commit=07284262768e3a7066da09845370d78526be6bc1 # master
|
||||
source=("$pkgname::git+https://git.code.sf.net/p/sensors-applet/code#commit=$_commit"
|
||||
'fix-crash-destroying-active-sensor.patch'
|
||||
'port-to-libgnome-panel.patch'
|
||||
'sensors-applet-3.0.0-udisks2-plugin.patch')
|
||||
sha256sums=('SKIP'
|
||||
'sensors-applet-3.0.0-udisks2-plugin.patch'
|
||||
'drop-gnome-common.patch')
|
||||
sha256sums=('6ec258baf1bb697de8492ba231d23cd849d964ccfae801d52c9b199864c0fea9'
|
||||
'9c4cc2accf326c44cb625f5db0b82a782351cdf8829f1a4067a30f287b6b7156'
|
||||
'cb0e35e0d6e6568f14836da7e5b78154bd4d9a4127f0f6dd476e4f7c9d62339d'
|
||||
'ca6489da2e82df77e5a3b4e71e99689954132d5110f1c7bffc2f0ee7c35d4b33')
|
||||
'ca6489da2e82df77e5a3b4e71e99689954132d5110f1c7bffc2f0ee7c35d4b33'
|
||||
'82f2ea8cae09976f1c82c000e1b135d1e3081dc47355d4aad7fe4166995599c0')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -Np1 -i ../fix-crash-destroying-active-sensor.patch
|
||||
patch -Np1 -i ../port-to-libgnome-panel.patch
|
||||
patch -Np1 -i ../sensors-applet-3.0.0-udisks2-plugin.patch
|
||||
patch -Np1 -i ../drop-gnome-common.patch
|
||||
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
|
67
extra/sensors-applet/drop-gnome-common.patch
Normal file
67
extra/sensors-applet/drop-gnome-common.patch
Normal file
|
@ -0,0 +1,67 @@
|
|||
diff '--color=auto' -Naur sensors-applet.orig/autogen.sh sensors-applet/autogen.sh
|
||||
--- sensors-applet.orig/autogen.sh 2024-04-19 23:28:48.121005602 +0200
|
||||
+++ sensors-applet/autogen.sh 2024-04-19 23:32:38.141508669 +0200
|
||||
@@ -1,21 +1,38 @@
|
||||
#!/bin/sh
|
||||
# Run this to generate all the initial makefiles, etc.
|
||||
+test -n "$srcdir" || srcdir=$(dirname "$0")
|
||||
+test -n "$srcdir" || srcdir=.
|
||||
|
||||
-srcdir=`dirname $0`
|
||||
-test -z "$srcdir" && srcdir=.
|
||||
+olddir=$(pwd)
|
||||
|
||||
-PKG_NAME="sensors-applet"
|
||||
+cd $srcdir
|
||||
|
||||
-(test -f $srcdir/configure.ac) || {
|
||||
- echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
|
||||
- echo " top-level $PKG_NAME directory"
|
||||
- exit 1
|
||||
+(test -f configure.ac) || {
|
||||
+ echo "*** ERROR: Directory '$srcdir' does not look like the top-level project directory ***"
|
||||
+ exit 1
|
||||
}
|
||||
|
||||
-which gnome-autogen.sh || {
|
||||
- echo -n "ERROR: gnome-autogen.sh not found in path: "
|
||||
- echo "Please install gnome-common before running this script"
|
||||
- exit 1
|
||||
-}
|
||||
+# shellcheck disable=SC2016
|
||||
+PKG_NAME=$(autoconf --trace 'AC_INIT:$1' configure.ac)
|
||||
+
|
||||
+if [ "$#" = 0 -a "x$NOCONFIGURE" = "x" ]; then
|
||||
+ echo "*** WARNING: I am going to run 'configure' with no arguments." >&2
|
||||
+ echo "*** If you wish to pass any to it, please specify them on the" >&2
|
||||
+ echo "*** '$0' command line." >&2
|
||||
+ echo "" >&2
|
||||
+fi
|
||||
+
|
||||
+autoreconf --verbose --force --install || exit 1
|
||||
+
|
||||
+cd "$olddir"
|
||||
+if [ "$NOCONFIGURE" = "" ]; then
|
||||
+ $srcdir/configure "$@" || exit 1
|
||||
|
||||
-REQUIRED_AUTOMAKE_VERSION=1.7 USE_GNOME2_MACROS=1 . gnome-autogen.sh
|
||||
+ if [ "$1" = "--help" ]; then
|
||||
+ exit 0
|
||||
+ else
|
||||
+ echo "Now type 'make' to compile $PKG_NAME" || exit 1
|
||||
+ fi
|
||||
+else
|
||||
+ echo "Skipping configure process."
|
||||
+fi
|
||||
diff '--color=auto' -Naur sensors-applet.orig/configure.ac sensors-applet/configure.ac
|
||||
--- sensors-applet.orig/configure.ac 2024-04-19 23:28:48.214343415 +0200
|
||||
+++ sensors-applet/configure.ac 2024-04-19 23:30:24.755320189 +0200
|
||||
@@ -252,8 +252,6 @@
|
||||
AC_MSG_ERROR([xsltproc executable not found in your path - should be installed with libxslt])
|
||||
fi
|
||||
|
||||
-GNOME_COMPILE_WARNINGS(maximum)
|
||||
-
|
||||
YELP_HELP_INIT
|
||||
|
||||
# ==================== plugin stuff ================== #
|
Loading…
Reference in a new issue