core/libsecret to 0.20.4-1

This commit is contained in:
Kevin Mihelich 2020-10-13 13:38:41 +00:00
parent d2e9aed934
commit 6053895916
2 changed files with 24 additions and 5 deletions

View file

@ -1,10 +1,11 @@
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Maintainer: Jan de Groot <jgc@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove makedepend on valgrind
pkgname=libsecret
pkgver=0.20.3
pkgver=0.20.4
pkgrel=1
pkgdesc="Library for storing and retrieving passwords and other secrets"
url="https://wiki.gnome.org/Projects/Libsecret"
@ -15,9 +16,11 @@ checkdepends=(python-dbus dbus-glib python-gobject gjs)
makedepends=(docbook-xsl gobject-introspection vala git gtk-doc meson)
optdepends=('org.freedesktop.secrets: secret storage backend')
provides=(libsecret-1.so)
_commit=fb456a3853a080996f044496b11f3001af4a2659 # tags/0.20.3^0
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit")
sha256sums=('SKIP')
_commit=3fe635e64efd4b8dbc9ec3548b0bc8034c7665c4 # tags/0.20.4^0
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit"
fix-test.diff)
sha256sums=('SKIP'
'760e40ffcd3383149d62f803a900b3af1a838fb084a8403e45d0764696dd2ffe')
pkgver() {
cd $pkgname
@ -26,11 +29,15 @@ pkgver() {
prepare() {
cd $pkgname
# Fix compiliation of test-vala-unstable
# https://gitlab.gnome.org/GNOME/libsecret/-/issues/54
git apply -3 ../fix-test.diff
}
build() {
arch-meson $pkgname build
ninja -C build
meson compile -C build
}
check() {

View file

@ -0,0 +1,12 @@
diff --git i/libsecret/meson.build w/libsecret/meson.build
index 0c448b9..c0138d2 100644
--- i/libsecret/meson.build
+++ w/libsecret/meson.build
@@ -185,6 +185,7 @@ pkg.generate(description: 'GObject bindings for Secret Service API (Unstable)',
test_cflags = [
libsecret_cflags,
'-DSRCDIR="@0@"'.format(meson.source_root()),
+ '-DSECRET_WITH_UNSTABLE',
]
mock_service_lib = library('mock-service',