mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt5-webkit to 5.6.1-1
This commit is contained in:
parent
8941a229fe
commit
6068c5da48
2 changed files with 6 additions and 41 deletions
|
@ -8,9 +8,9 @@
|
|||
# - patch for AArch64 support in qtwebkit
|
||||
|
||||
pkgname=qt5-webkit
|
||||
_qtver=5.6.0
|
||||
_qtver=5.6.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=4
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -22,11 +22,11 @@ conflicts=('qt')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-opensource-src-${pkgver}"
|
||||
source=("http://download.qt.io/community_releases/${pkgver%.*}/${pkgver}/qtwebkit-opensource-src-${pkgver}.tar.xz"
|
||||
qt5-webkit-pthread.patch
|
||||
qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch
|
||||
0001-Add-ARM-64-support.patch)
|
||||
md5sums=('b68565d18db63ee4db998bb8e37608a5'
|
||||
'f65286024f65ca87837171272fc8975d')
|
||||
md5sums=('9ea7cb557375ba2fc7c62742c522d093'
|
||||
'd55ad1f1c90725834b44eada5db4e401'
|
||||
'47657bc1b3f51892d0cc88a271a8fa31')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -35,11 +35,8 @@ prepare() {
|
|||
mkdir -p bin
|
||||
ln -s /usr/bin/python2 bin/python
|
||||
|
||||
# Fix linking to pthread
|
||||
cd ${_pkgfqn}
|
||||
patch -p1 -i ../qt5-webkit-pthread.patch
|
||||
|
||||
# ARM fixes
|
||||
cd ${_pkgfqn}
|
||||
patch -p1 -i ../qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch
|
||||
patch -p1 -i ../0001-Add-ARM-64-support.patch
|
||||
}
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
From 5f359baacdf92fabcece83f0a2b30f74c7c02a3c Mon Sep 17 00:00:00 2001
|
||||
From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
|
||||
Date: Mon, 22 Feb 2016 10:57:32 +0100
|
||||
Subject: [PATCH] Fix linking with libpthread
|
||||
|
||||
WebKit use libpthread directly but is depending on other qt modules
|
||||
causing it to be linked against, which might break unless -lpthread
|
||||
is last. Instead just add it explicitly after the static libraries.
|
||||
|
||||
Change-Id: I2b95cff2c96373f8dce6f95052c4fccbe1982b33
|
||||
Reviewed-by: Simon Hausmann <simon.hausmann@theqtcompany.com>
|
||||
(cherry picked from commit 5dd4bb67cfce812fd7686e43616e2069f354a7df)
|
||||
Reviewed-by: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
|
||||
---
|
||||
Tools/qmake/mkspecs/features/default_post.prf | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Tools/qmake/mkspecs/features/default_post.prf b/Tools/qmake/mkspecs/features/default_post.prf
|
||||
index 67276b7..39bb3f7 100644
|
||||
--- a/Tools/qmake/mkspecs/features/default_post.prf
|
||||
+++ b/Tools/qmake/mkspecs/features/default_post.prf
|
||||
@@ -201,6 +201,7 @@ needToLink() {
|
||||
linkAgainstLibrary($$library, $$eval(WEBKIT.$${library_identifier}.root_source_dir))
|
||||
LIBS += $$eval(WEBKIT.$${library_identifier}.dependent_libs)
|
||||
}
|
||||
+ posix:!darwin: LIBS += -lpthread
|
||||
}
|
||||
|
||||
creating_module {
|
||||
--
|
||||
2.7.1
|
||||
|
Loading…
Reference in a new issue