added community/qtractor

This commit is contained in:
Kevin Mihelich 2014-01-03 02:40:56 +00:00
parent 9d01db007c
commit 60cf33c31b
3 changed files with 117 additions and 0 deletions

View file

@ -0,0 +1,64 @@
Description: Definte generic atomic function to prevent FTBFS on most
architectures.
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725611
Author: Alessio Treglia <alessio@debian.org>
---
src/qtractorAtomic.h | 40 ++++++++++++----------------------------
1 file changed, 12 insertions(+), 28 deletions(-)
--- qtractor.orig/src/qtractorAtomic.h
+++ qtractor/src/qtractorAtomic.h
@@ -35,33 +35,7 @@ extern "C" {
#if defined(__GNUC__)
-#if defined(powerpc) || defined(__ppc__)
-
-static inline int ATOMIC_CAS1 (
- volatile int *pAddr, int iOldValue, int iNewValue )
-{
- register int result;
- asm volatile (
- "# ATOMIC_CAS1 \n"
- " lwarx r0, 0, %1 \n"
- " cmpw r0, %2 \n"
- " bne- 1f \n"
- " sync \n"
- " stwcx. %3, 0, %1 \n"
- " bne- 1f \n"
- " li %0, 1 \n"
- " b 2f \n"
- "1: \n"
- " li %0, 0 \n"
- "2: \n"
- : "=r" (result)
- : "r" (pValue), "r" (iOldValue), "r" (iNewValue)
- : "r0"
- );
- return result;
-}
-
-#elif defined(__i386__) || defined(__x86_64__)
+#if defined(__i386__) || defined(__x86_64__)
static inline int ATOMIC_CAS1 (
volatile int *pValue, int iOldValue, int iNewValue )
@@ -79,7 +53,17 @@ static inline int ATOMIC_CAS1 (
}
#else
-# error "qtractorAtomic.h: unsupported target compiler processor (GNUC)."
+
+#if QT_VERSION < 0x040400
+
+static inline int ATOMIC_CAS1 (
+ volatile int *pAddr, int iOldValue, int iNewValue )
+{
+ return q_atomic_test_and_set_int(pAddr, iOldValue, iNewValue);
+}
+
+#endif
+
#endif
#elif defined(WIN32) || defined(__WIN32__) || defined(_WIN32)

View file

@ -0,0 +1,40 @@
# $Id$
# Maintainer: Ray Rashif <schiv@archlinux.org>
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building on ARM
pkgname=qtractor
pkgver=0.5.12
pkgrel=1
pkgdesc="Audio/MIDI multitrack sequencer"
arch=('i686' 'x86_64')
url="http://qtractor.sourceforge.net/"
license=('GPL')
depends=('qt4' 'suil' 'lilv' 'libmad' 'liblo'
'rubberband' 'shared-mime-info')
makedepends=('ladspa' 'dssi')
[ "$CARCH" = "i686" ] && optdepends=('dssi-vst: win32 VST support')
install=qtractor.install
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
'04-q_atomic_ftbfs.patch')
md5sums=('f26691f70c4cd4b89bc4369a579f291f'
'da44b00b6bcf808a1b840959361ba19f')
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i ../04-q_atomic_ftbfs.patch
./configure --prefix=/usr
make
}
package () {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:

View file

@ -0,0 +1,13 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-mime-database usr/share/mime &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}