mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/rust to 1.62.0-1
This commit is contained in:
parent
f5620ed39b
commit
61873e8dd8
3 changed files with 12 additions and 13 deletions
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||||
index be965971dbb6..f3fa15a8e2de 100644
|
index 6181a611ec31..ef2eccab8dc3 100644
|
||||||
--- a/src/bootstrap/dist.rs
|
--- a/src/bootstrap/dist.rs
|
||||||
+++ b/src/bootstrap/dist.rs
|
+++ b/src/bootstrap/dist.rs
|
||||||
@@ -976,7 +976,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
@@ -968,7 +968,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||||
let dirent = dirent.expect("read dir entry");
|
let dirent = dirent.expect("read dir entry");
|
||||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
||||||
4 files changed, 12 insertions(+), 3 deletions(-)
|
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||||
index 4182a5d07118..0556c95d5b5b 100644
|
index 530c1a06f8f4..bb6228bd4a7b 100644
|
||||||
--- a/compiler/rustc_session/src/config.rs
|
--- a/compiler/rustc_session/src/config.rs
|
||||||
+++ b/compiler/rustc_session/src/config.rs
|
+++ b/compiler/rustc_session/src/config.rs
|
||||||
@@ -1847,7 +1847,7 @@ pub fn parse_target_triple(
|
@@ -1830,7 +1830,7 @@ pub fn parse_target_triple(
|
||||||
early_error(error_format, &format!("target file {path:?} does not exist"))
|
early_error(error_format, &format!("target file {path:?} does not exist"))
|
||||||
})
|
})
|
||||||
}
|
}
|
||||||
|
@ -50,7 +50,7 @@ index 0998c618f31a..91c79c7e4ff0 100644
|
||||||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||||
f64:32:64-f80:32-n8:16:32-S128"
|
f64:32:64-f80:32-n8:16:32-S128"
|
||||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||||
index bd5b712c143c..a78d0c20aa5d 100644
|
index 832eeec3e8b2..d35c0b342869 100644
|
||||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||||
@@ -2424,6 +2424,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
@@ -2424,6 +2424,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||||
|
|
|
@ -16,14 +16,14 @@ highmem=1
|
||||||
pkgbase=rust
|
pkgbase=rust
|
||||||
pkgname=(rust rust-src)
|
pkgname=(rust rust-src)
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgver=1.61.0
|
pkgver=1.62.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||||
url=https://www.rust-lang.org/
|
url=https://www.rust-lang.org/
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
license=(MIT Apache)
|
license=(MIT Apache)
|
||||||
options=(!emptydirs !strip !lto)
|
options=(!emptydirs !strip !lto)
|
||||||
_llvm_ver=13.0.1
|
_llvm_ver=14.0.6
|
||||||
depends=(gcc-libs llvm-libs curl libssh2 gcc)
|
depends=(gcc-libs llvm-libs curl libssh2 gcc)
|
||||||
makedepends=(rust "llvm=$_llvm_ver" libffi perl python cmake
|
makedepends=(rust "llvm=$_llvm_ver" libffi perl python cmake
|
||||||
ninja lld)
|
ninja lld)
|
||||||
|
@ -36,17 +36,16 @@ source=(
|
||||||
0002-compiler-Change-LLVM-targets.patch
|
0002-compiler-Change-LLVM-targets.patch
|
||||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||||
)
|
)
|
||||||
sha256sums=('ad0b4351675aa9abdf4c7e066613bd274c4391c5506db152983426376101daed'
|
sha256sums=('7d0878809b64d206825acae3eb7f60afb2212d81e3de1adf4c11c6032b36c027'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'7b33955031f9a9c5d63077dedb0f99d77e4e7c996266952c1cec55626dca5dfc'
|
'88df303840ca8fbff944e15e61c141226fe79f5d2b8e89fb024264d77841a02e'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'c901a9bb036c29ca092f7dbc8b447efdd9aa1044a902a88f9d024cb22681dc19'
|
'c901a9bb036c29ca092f7dbc8b447efdd9aa1044a902a88f9d024cb22681dc19'
|
||||||
'60c6dfc100d292284af2187cfefc1d0d928139ca557d27bc6bef88edefccff70'
|
'839c342ea915ca55adaf1de5d18676ae8e7474265debde0f9e424c17abf2d51f'
|
||||||
'8dcb566da29a92ecf3eb6afe094d9c7766d08230d90fd666bfd022c018ae676a'
|
'ae69ccf45641064c950d8f8cabf74858e0c33f3ddc069930a994d7bf327c3215'
|
||||||
'26bf232d144b81a303ed91f6a331ddf004c5d9fefd41a11e36b61812a34459aa')
|
'26bf232d144b81a303ed91f6a331ddf004c5d9fefd41a11e36b61812a34459aa')
|
||||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||||
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
474E22316ABF4785A88C6E8EA2C794A986419D8A) # Tom Stellard <tstellar@redhat.com>
|
||||||
B6C8F98282B944E3B0D5C2530FC3042E345AD05D) # Hans Wennborg <hans@chromium.org>
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd rustc-$pkgver-src
|
cd rustc-$pkgver-src
|
||||||
|
|
Loading…
Reference in a new issue