extra/opencv to 3.2.0-1

This commit is contained in:
Kevin Mihelich 2017-02-03 14:30:21 +00:00
parent 3a74d3308e
commit 623476b818
2 changed files with 5 additions and 54 deletions

View file

@ -1,39 +0,0 @@
From 24dbb43c096691d0333cacf231e22f1369f8c826 Mon Sep 17 00:00:00 2001
From: Alexander Alekhin <alexander.alekhin@itseez.com>
Date: Tue, 22 Dec 2015 17:10:33 +0300
Subject: [PATCH] pkg-config: modules list contains only OpenCV modules (fixes
#5852)
---
cmake/OpenCVUtils.cmake | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/cmake/OpenCVUtils.cmake b/cmake/OpenCVUtils.cmake
index 3a23cd7..75412eb 100644
--- a/cmake/OpenCVUtils.cmake
+++ b/cmake/OpenCVUtils.cmake
@@ -806,7 +806,13 @@ macro(ocv_get_all_libs _modules _extra _3rdparty)
else()
set(deps "")
endif()
- list(INSERT ${_modules} 0 ${deps} ${m})
+ set(_rev_deps "${deps};${m}")
+ ocv_list_reverse(_rev_deps)
+ foreach (dep ${_rev_deps})
+ if(DEFINED OPENCV_MODULE_${dep}_LOCATION)
+ list(INSERT ${_modules} 0 ${dep})
+ endif()
+ endforeach()
foreach (dep ${deps} ${OPENCV_LINKER_LIBS})
if (NOT DEFINED OPENCV_MODULE_${dep}_LOCATION)
if (TARGET ${dep})
@@ -832,9 +838,6 @@ macro(ocv_get_all_libs _modules _extra _3rdparty)
endif()
endif()
- # split 3rdparty libs and modules
- list(REMOVE_ITEM ${_modules} ${${_3rdparty}} ${${_extra}} non_empty_list)
-
ocv_list_filterout(${_modules} "^[\$]<")
ocv_list_filterout(${_3rdparty} "^[\$]<")
ocv_list_filterout(${_extra} "^[\$]<")

View file

@ -8,8 +8,8 @@
pkgbase=opencv
pkgname=('opencv' 'opencv-samples')
pkgver=3.1.0
pkgrel=7
pkgver=3.2.0
pkgrel=1
pkgdesc="Open Source Computer Vision Library"
arch=('i686' 'x86_64')
license=('BSD')
@ -24,12 +24,9 @@ optdepends=('opencv-samples'
'python-numpy: Python 3 interface'
'python2-numpy: Python 2 interface')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/Itseez/opencv/archive/$pkgver.zip"
"opencv_contrib-$pkgver.tar.gz::https://github.com/Itseez/opencv_contrib/archive/$pkgver.tar.gz"
opencv-gcc6.patch::"https://github.com/mshabunin/opencv/commit/a0fdc91a.patch" '5852.patch')
md5sums=('6082ee2124d4066581a7386972bfd52a'
'a822839ad3ab79ff837c16785ea9dd10'
'4dacea7866d28014939a652f268cc7c1'
'5bd9cd736b171c15cedee3a32a0c47ff')
"opencv_contrib-$pkgver.tar.gz::https://github.com/Itseez/opencv_contrib/archive/$pkgver.tar.gz")
md5sums=('bfc6a261eb069b709bcfe7e363ef5899'
'd7d50c70c31df3b31310f548f31fd2a2')
_cmakeopts=('-D WITH_OPENCL=ON'
'-D WITH_OPENGL=ON'
@ -55,13 +52,6 @@ _cmakeopts=('-D WITH_OPENCL=ON'
'-D ENABLE_SSE2=OFF'
'-D ENABLE_SSE3=OFF')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i "$srcdir/5852.patch"
# Fix build with GCC 6
patch -p1 -i "$srcdir"/opencv-gcc6.patch
}
build() {
cd "$srcdir/$pkgname-$pkgver"