mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/flatpak to 1.15.2-1
This commit is contained in:
parent
675c10d024
commit
623ec24c6e
2 changed files with 46 additions and 18 deletions
|
@ -8,20 +8,45 @@
|
|||
|
||||
pkgbase=flatpak
|
||||
pkgname=(flatpak flatpak-docs)
|
||||
pkgver=1.15.1
|
||||
pkgver=1.15.2
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc="Linux application sandboxing and distribution framework (formerly xdg-app)"
|
||||
url="https://flatpak.org"
|
||||
arch=(x86_64)
|
||||
license=(LGPL)
|
||||
depends=(dbus glib2 curl polkit libxau ostree json-glib libseccomp libarchive
|
||||
python bubblewrap appstream xdg-dbus-proxy systemd fuse3 libmalcontent)
|
||||
makedepends=(gobject-introspection gtk-doc git docbook-xsl xmlto
|
||||
python-pyparsing meson socat)
|
||||
checkdepends=(valgrind socat)
|
||||
options=(debug)
|
||||
_commit=47ea3934c0e055605b8dff93edad2136141e48ec # tags/1.15.1^0
|
||||
depends=(
|
||||
appstream
|
||||
bubblewrap
|
||||
curl
|
||||
dbus
|
||||
fuse3
|
||||
glib2
|
||||
json-glib
|
||||
libarchive
|
||||
libmalcontent
|
||||
libseccomp
|
||||
libxau
|
||||
ostree
|
||||
polkit
|
||||
python
|
||||
systemd
|
||||
xdg-dbus-proxy
|
||||
)
|
||||
makedepends=(
|
||||
docbook-xsl
|
||||
git
|
||||
gobject-introspection
|
||||
gtk-doc
|
||||
meson
|
||||
python-pyparsing
|
||||
xmlto
|
||||
socat
|
||||
)
|
||||
checkdepends=(
|
||||
valgrind
|
||||
)
|
||||
_commit=a98bbbe2ce7e5f370064e56411722a662f385ac1 # tags/1.15.2^0
|
||||
source=(
|
||||
"git+https://github.com/flatpak/flatpak#commit=$_commit"
|
||||
git+https://gitlab.gnome.org/GNOME/libglnx.git
|
||||
|
@ -32,14 +57,14 @@ source=(
|
|||
fusermount3.diff
|
||||
flatpak-bindir.sh
|
||||
)
|
||||
sha256sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'3371dd250e61d9e1633630073fefda153cd4426f72f4afa0c3373ae2e8fea03a'
|
||||
'023c2bb5f355095e87357e625ef85119b5e15b3d0a4ad07ce858ed1a8f99a57a'
|
||||
'1824cb4eb1cc88702cb2b9f1c55b6dfdf20fca5eab83f6e8e532099281328745')
|
||||
b2sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'c094461a28dab284c1d32cf470f38118a6cbce27acce633b81945fb859daef9bdec1261490f344221b5cacf4437f53934cb51173f7ad2f1d2e05001139e75c54'
|
||||
'50746b629bdfc8de0a437c18883460e1ce31767bc723f1eaae564d05ce84f6a9255177fafb5d84eae8135c6dd1cd2422742bc680a2aa24081708d4a6e9b76dfc'
|
||||
'1c45caa65e2a1598f219977d5a81dcb8ea5d458880c43c40ba452b0c77cbbf41b36fa6911741f22c807d318e04e39e4fcc1455ed8d68faaba10162dae2570abc')
|
||||
|
||||
pkgver() {
|
||||
cd flatpak
|
||||
|
@ -89,7 +114,10 @@ _pick() {
|
|||
}
|
||||
|
||||
package_flatpak() {
|
||||
depends+=(xdg-desktop-portal libostree-1.so)
|
||||
depends+=(
|
||||
libostree-1.so
|
||||
xdg-desktop-portal
|
||||
)
|
||||
provides=(libflatpak.so)
|
||||
|
||||
meson install -C build --destdir "$pkgdir"
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
diff --git i/common/flatpak-dir.c w/common/flatpak-dir.c
|
||||
index 01362a2b..2b17c6f8 100644
|
||||
index a9b711ee..fbe1b089 100644
|
||||
--- i/common/flatpak-dir.c
|
||||
+++ w/common/flatpak-dir.c
|
||||
@@ -2109,7 +2109,7 @@ flatpak_dir_revokefs_fuse_unmount (OstreeRepo **repo,
|
||||
|
|
Loading…
Reference in a new issue