mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed alarm/cpufrequtils
This commit is contained in:
parent
e8b5e99028
commit
6256bc8e91
4 changed files with 0 additions and 150 deletions
|
@ -1,34 +0,0 @@
|
|||
From f1b6bccf08f53295b2f7f448f28bbd37533c14a2 Mon Sep 17 00:00:00 2001
|
||||
From: Zhang Le <r0bertz@gentoo.org>
|
||||
Date: Sun, 18 Jul 2010 02:05:28 +0800
|
||||
Subject: [PATCH 1/8] Only x86 has cpuid instruction
|
||||
|
||||
Signed-off-by: Zhang Le <r0bertz@gentoo.org>
|
||||
Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
|
||||
---
|
||||
utils/aperf.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/utils/aperf.c b/utils/aperf.c
|
||||
index 627fb17..1c64501 100644
|
||||
--- a/utils/aperf.c
|
||||
+++ b/utils/aperf.c
|
||||
@@ -68,11 +68,15 @@ struct avg_perf_cpu_info
|
||||
|
||||
static int cpu_has_effective_freq()
|
||||
{
|
||||
+#if defined(__i386__) || defined(__x86_64__)
|
||||
/* largest base level */
|
||||
if (cpuid_eax(0) < 6)
|
||||
return 0;
|
||||
|
||||
return cpuid_ecx(6) & 0x1;
|
||||
+#else
|
||||
+ return 0;
|
||||
+#endif
|
||||
}
|
||||
|
||||
/*
|
||||
--
|
||||
1.7.10
|
||||
|
|
@ -1,42 +0,0 @@
|
|||
# $Id: PKGBUILD 149475 2012-02-08 09:53:00Z pierre $
|
||||
# Maintainer: kevin <kevin@archlinux.org>
|
||||
# Contributor: phrakture <aaronmgriffin+gmail+com>
|
||||
# Contributor: SpepS <dreamspepser at yahoo dot it>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix x86-only parts
|
||||
|
||||
pkgname=cpufrequtils
|
||||
pkgver=008
|
||||
pkgrel=3
|
||||
pkgdesc="Userspace tools for the kernel cpufreq subsystem"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
|
||||
license=('GPL')
|
||||
depends=('sysfsutils')
|
||||
backup=('etc/conf.d/cpufreq')
|
||||
source=("https://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-${pkgver}.tar.xz"
|
||||
'cpufreq.rcd'
|
||||
'cpufreq.confd'
|
||||
'0001-Only-x86-has-cpuid-instruction.patch')
|
||||
options=('!libtool' '!makeflags')
|
||||
md5sums=('e0c9f333a9546f71d17fd5a0546db79e'
|
||||
'7f2b5085df44d2df3e7c2d0b9f6dab08'
|
||||
'baae1f2abffc6bef2bd32a8dd8263c09'
|
||||
'9ed71a50670aa99e12245cb3f5199142')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
patch -p1 -i "${srcdir}/0001-Only-x86-has-cpuid-instruction.patch"
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make INSTALL="/usr/bin/install -c" mandir=/usr/share/man DESTDIR="${pkgdir}" install
|
||||
|
||||
install -D -m755 ${srcdir}/cpufreq.rcd "${pkgdir}/etc/rc.d/cpufreq"
|
||||
install -D -m644 ${srcdir}/cpufreq.confd "${pkgdir}/etc/conf.d/cpufreq"
|
||||
}
|
|
@ -1,14 +0,0 @@
|
|||
#configuration for cpufreq control
|
||||
|
||||
# valid governors:
|
||||
# ondemand, performance, powersave,
|
||||
# conservative, userspace
|
||||
#governor="ondemand"
|
||||
|
||||
# limit frequency range (optional)
|
||||
# valid suffixes: Hz, kHz (default), MHz, GHz, THz
|
||||
#min_freq="2.25GHz"
|
||||
#max_freq="3GHz"
|
||||
|
||||
# use freq to set up the exact cpu frequency using it with userspace governor
|
||||
#freq=
|
|
@ -1,60 +0,0 @@
|
|||
#!/bin/bash
|
||||
|
||||
. /etc/rc.conf
|
||||
. /etc/rc.d/functions
|
||||
|
||||
# source application-specific settings
|
||||
[ -f /etc/conf.d/cpufreq ] && . /etc/conf.d/cpufreq
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
stat_busy "Setting cpufreq governing rules"
|
||||
|
||||
params=""
|
||||
if [ -n "$governor" ]; then
|
||||
mod="cpufreq_$governor"
|
||||
params="-g $governor"
|
||||
grep -qw "$governor" /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors || modprobe -q $mod
|
||||
if [ $? -eq 0 ]; then
|
||||
if [ "$min_freq" != "" ]; then
|
||||
params="$params -d $min_freq"
|
||||
fi
|
||||
if [ "$max_freq" != "" ]; then
|
||||
params="$params -u $max_freq"
|
||||
fi
|
||||
else
|
||||
stat_busy " Cannot load governor module '$governor'"
|
||||
stat_fail
|
||||
exit
|
||||
fi
|
||||
fi
|
||||
|
||||
if [ "$params" != "" ]; then
|
||||
CPUS=$(sed -ne 's/^processor.* \([0-9]\+\)$/\1/p' /proc/cpuinfo)
|
||||
stat_append ", cpu"
|
||||
for cpu in $CPUS; do
|
||||
stat_append " $cpu"
|
||||
cpufreq-set -c $cpu $params
|
||||
if [ "$freq" != "" ]; then
|
||||
cpufreq-set -c $cpu -f $freq
|
||||
fi
|
||||
done
|
||||
stat_done
|
||||
else
|
||||
stat_busy " Invalid configuration in /etc/conf.d/cpufreq"
|
||||
stat_fail
|
||||
fi
|
||||
;;
|
||||
stop)
|
||||
# nothing to do
|
||||
;;
|
||||
restart)
|
||||
$0 start
|
||||
;;
|
||||
set)
|
||||
# TODO: make callable... "cpufreq set 800MHz"
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 {start|stop|restart}"
|
||||
esac
|
||||
exit 0
|
Loading…
Reference in a new issue