mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/libsemigroups to 1.0.4-2
This commit is contained in:
parent
fa87241ff9
commit
6291da517a
2 changed files with 9 additions and 53 deletions
|
@ -4,34 +4,28 @@
|
||||||
# - strip -mavx from configure and Makefile
|
# - strip -mavx from configure and Makefile
|
||||||
|
|
||||||
pkgname=libsemigroups
|
pkgname=libsemigroups
|
||||||
pkgver=1.0.3
|
pkgver=1.0.4
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="C++ library for semigroups and monoids"
|
pkgdesc="C++ library for semigroups and monoids"
|
||||||
url="https://libsemigroups.github.io/libsemigroups/"
|
url="https://libsemigroups.github.io/libsemigroups/"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
license=(GPL3)
|
license=(GPL3)
|
||||||
depends=(gcc-libs)
|
depends=(gcc-libs)
|
||||||
makedepends=(fmt)
|
makedepends=(fmt)
|
||||||
source=(https://github.com/libsemigroups/libsemigroups/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
|
source=(https://github.com/libsemigroups/libsemigroups/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
|
||||||
system-fmt.patch)
|
sha256sums=('4956c868c41b3421da211f413b4b104b7882640ebb464314e8b12f7b6e10fcb0')
|
||||||
sha256sums=('6adc2e023ad1349f0a942355b88241198d23790e62216bfeb62c356d803119da'
|
|
||||||
'86c0ae8613df2959924d86c16874ee8d72288b10f87225c3909132b1d2a83fdf')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd $pkgname-$pkgver
|
|
||||||
patch -p1 -i ../system-fmt.patch
|
|
||||||
rm -r extern/fmt-*
|
|
||||||
sed -i 's/-mavx//g' configure.ac Makefile.am
|
|
||||||
autoreconf -fi
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
./configure --prefix=/usr
|
sed -i 's/-mavx//g' configure.ac Makefile.am
|
||||||
|
autoreconf -fi
|
||||||
|
./configure --prefix=/usr --with-external-fmt
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
make DESTDIR="$pkgdir" install
|
make DESTDIR="$pkgdir" install
|
||||||
|
|
||||||
|
sed -e 's|lsemigroups|lsemigroups-1.0|g' -i "$pkgdir"/usr/lib/pkgconfig/libsemigroups.pc # Fix lib name in pkgconfig
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,38 +0,0 @@
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index 761a772..0a8391b 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -108,17 +108,6 @@ pkginclude_HEADERS += extern/HPCombi/include/vect_generic.hpp
|
|
||||||
endif
|
|
||||||
|
|
||||||
fmtincludedir = $(includedir)/fmt
|
|
||||||
-fmtinclude_HEADERS = extern/fmt-5.3.0/include/fmt/chrono.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/color.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/core.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/format-inl.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/format.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/locale.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/ostream.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/posix.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/printf.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/ranges.h
|
|
||||||
-fmtinclude_HEADERS += extern/fmt-5.3.0/include/fmt/time.h
|
|
||||||
|
|
||||||
lib_LTLIBRARIES = libsemigroups.la
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index c40acdb..832d8a3 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -212,11 +212,5 @@ AS_IF([test "x$enable_hpcombi" = xyes],
|
|
||||||
AM_CONDITIONAL([HPCOMBI_CONSTEXPR_FUN_ARGS],
|
|
||||||
[test "x$hpcombi_constexpr_fun_args" = xyes])
|
|
||||||
|
|
||||||
-AC_CHECK_FILE([$srcdir/extern/fmt-5.3.0/README.rst],
|
|
||||||
- [],
|
|
||||||
- []
|
|
||||||
- [AC_MSG_ERROR([fmt-5.3.0 is not available, please download fmt-5.3.0 from https://fmt.dev/ and put the unpacked archive in the libsemigroups/extern directory])])
|
|
||||||
-dnl Output configured files
|
|
||||||
-
|
|
||||||
AC_CONFIG_FILES([Makefile libsemigroups.pc])
|
|
||||||
AC_OUTPUT
|
|
Loading…
Reference in a new issue