mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/percona-server to 8.0.33_25-3
This commit is contained in:
parent
4074e83692
commit
62dc966a0b
2 changed files with 48 additions and 1 deletions
|
@ -10,7 +10,7 @@ pkgver=8.0.33_25
|
|||
_boost_ver=1.77.0
|
||||
_pkgver=${pkgver/_/-}
|
||||
_myver=${pkgver/_rel*}
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
makedepends=('cmake' 'zlib' 'lz4' 'zstd' 'libaio' 'systemd-tools' 'pam' 'numactl' 'jemalloc' 'openssl'
|
||||
'rpcsvc-proto' 'doxygen' 'graphviz' 'libevent' 'protobuf' 'libfido2') # 'boost'
|
||||
|
@ -22,6 +22,7 @@ source=("https://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona
|
|||
'mysql-user.conf'
|
||||
'mysqlrouter-user.conf'
|
||||
'mysql-build-fix.patch'
|
||||
'protobuf-23.patch'
|
||||
'0001-fix-LF_PINS-padding-calculation.patch')
|
||||
sha256sums=('9871cac20c226bba7607f35c19ee23516a38c67573dd48618727c74eae22912e'
|
||||
'5347464af5b14ac54bb945dc68f1dd7c56f0dad7262816b956138fc53bcc0131'
|
||||
|
@ -29,6 +30,7 @@ sha256sums=('9871cac20c226bba7607f35c19ee23516a38c67573dd48618727c74eae22912e'
|
|||
'5d7710fe88ec6d298175a309c0b776142397b119c468830b2865980292ed5da6'
|
||||
'4ca7ffdcb2d1716d4f31e4c7dd314e5d76e64f13fdc67c5d81c53650b793f5e0'
|
||||
'ea17c754d5595bf053d733373b7c4ae6d608a9f85a990dbe5779b499dd398bef'
|
||||
'2d73c79f355eaf3c0bced0f0da6ad099323f4f489d5cddb609cf01af5a617305'
|
||||
'aa5e960625843b061f47c32b4a267fab1115667b8b7d1ce7ec952efe42eb77af')
|
||||
|
||||
prepare() {
|
||||
|
@ -37,6 +39,8 @@ prepare() {
|
|||
|
||||
patch -p1 -i ../mysql-build-fix.patch
|
||||
|
||||
patch -p1 -i ../protobuf-23.patch
|
||||
|
||||
sed -r -e s@/var/run/mysqlrouter@/run/mysqlrouter@ \
|
||||
-e s@lib64/mysql@lib/mysql@ \
|
||||
-i cmake/install_layout.cmake
|
||||
|
|
43
extra/percona-server/protobuf-23.patch
Normal file
43
extra/percona-server/protobuf-23.patch
Normal file
|
@ -0,0 +1,43 @@
|
|||
diff --git a/cmake/protobuf.cmake b/cmake/protobuf.cmake
|
||||
index 8c6db02097e..c529f2975d5 100644
|
||||
--- a/cmake/protobuf.cmake
|
||||
+++ b/cmake/protobuf.cmake
|
||||
@@ -121,7 +121,10 @@ MACRO(MYSQL_CHECK_PROTOBUF)
|
||||
IF(WITH_PROTOBUF STREQUAL "bundled")
|
||||
MYSQL_USE_BUNDLED_PROTOBUF()
|
||||
ELSE()
|
||||
+ FIND_PACKAGE(protobuf CONFIG)
|
||||
FIND_PACKAGE(Protobuf)
|
||||
+ set(PROTOBUF_LIBRARY protobuf::libprotobuf)
|
||||
+ set(PROTOBUF_LITE_LIBRARY protobuf::libprotobuf-lite)
|
||||
ENDIF()
|
||||
|
||||
IF(NOT PROTOBUF_FOUND)
|
||||
diff --git a/plugin/x/tests/driver/connector/connection_manager.cc b/plugin/x/tests/driver/connector/connection_manager.cc
|
||||
index bf411893641..02df9c245c7 100644
|
||||
--- a/plugin/x/tests/driver/connector/connection_manager.cc
|
||||
+++ b/plugin/x/tests/driver/connector/connection_manager.cc
|
||||
@@ -33,8 +33,6 @@
|
||||
|
||||
#include "plugin/x/tests/driver/processor/variable_names.h"
|
||||
|
||||
-google::protobuf::LogHandler *g_lh = nullptr;
|
||||
-
|
||||
Connection_manager::Connection_manager(const Connection_options &co,
|
||||
Variable_container *variables,
|
||||
const Console &console_with_flow_history,
|
||||
@@ -43,14 +41,6 @@ Connection_manager::Connection_manager(const Connection_options &co,
|
||||
m_variables(variables),
|
||||
m_console_with_flow_history(console_with_flow_history),
|
||||
m_console(console) {
|
||||
- g_lh = google::protobuf::SetLogHandler([](google::protobuf::LogLevel level,
|
||||
- const char *filename, int line,
|
||||
- const std::string &message) {
|
||||
- if (g_lh) g_lh(level, filename, line, message);
|
||||
- DBUG_LOG("debug",
|
||||
- "Protobuf error (level:" << level << ", filename:" << filename
|
||||
- << ":" << line << ", text:" << message);
|
||||
- });
|
||||
m_variables->make_special_variable(
|
||||
k_variable_option_user,
|
||||
new Variable_dynamic_string(m_default_connection_options.user));
|
Loading…
Reference in a new issue