mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/boost to 1.57.0-2
This commit is contained in:
parent
e1b5681d52
commit
632775bcef
3 changed files with 40 additions and 31 deletions
|
@ -0,0 +1,29 @@
|
|||
From 06ccdfee76fe487a141b95848d1c866890f15d88 Mon Sep 17 00:00:00 2001
|
||||
From: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
Date: Thu, 6 Nov 2014 09:19:26 +0200
|
||||
Subject: [PATCH] Add missing include to signals2/trackable.hpp
|
||||
|
||||
boost::weak_ptr started being used in commit a0bf2d1 (Disconnect slots
|
||||
associated with signals2::trackable immediately) but the matching header
|
||||
wasn't included.
|
||||
|
||||
https://svn.boost.org/trac/boost/ticket/10100#comment:7
|
||||
---
|
||||
include/boost/signals2/trackable.hpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/include/boost/signals2/trackable.hpp b/include/boost/signals2/trackable.hpp
|
||||
index dba001d..64e8489 100644
|
||||
--- a/include/boost/signals2/trackable.hpp
|
||||
+++ b/include/boost/signals2/trackable.hpp
|
||||
@@ -18,6 +18,7 @@
|
||||
|
||||
#include <boost/assert.hpp>
|
||||
#include <boost/shared_ptr.hpp>
|
||||
+#include <boost/weak_ptr.hpp>
|
||||
|
||||
namespace boost {
|
||||
namespace signals2 {
|
||||
--
|
||||
2.1.3
|
||||
|
|
@ -13,21 +13,23 @@
|
|||
|
||||
pkgbase=boost
|
||||
pkgname=('boost-libs' 'boost')
|
||||
pkgver=1.56.0
|
||||
pkgver=1.57.0
|
||||
_boostver=${pkgver//./_}
|
||||
pkgrel=3
|
||||
pkgrel=2
|
||||
url='http://www.boost.org/'
|
||||
arch=('i686' 'x86_64')
|
||||
license=('custom')
|
||||
makedepends=('icu>=53.1' 'python' 'python2' 'bzip2' 'zlib')
|
||||
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
|
||||
boost-1.56.0-add-missing-headers-to-shared_ptr_helper.patch)
|
||||
sha1sums=('1639723c6bdff873cdb6d747f8f8c9d9f066434d'
|
||||
'5d611ad72005d1fb939ea783603861d2cb29433a')
|
||||
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
|
||||
0001-Add-missing-include-to-signals2-trackable.hpp.patch)
|
||||
sha1sums=('e151557ae47afd1b43dc3fac46f8b04a8fe51c12'
|
||||
'35bc8ad7493a641ec708a691036fe5319aec70cd')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgbase}_${_boostver}
|
||||
patch -p2 -i ../boost-1.56.0-add-missing-headers-to-shared_ptr_helper.patch
|
||||
|
||||
# https://github.com/boostorg/signals2/pull/8
|
||||
patch -Np2 -i ../0001-Add-missing-include-to-signals2-trackable.hpp.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -84,7 +86,7 @@ package_boost() {
|
|||
cp -a "${_stagedir}"/{bin,include,share} "${pkgdir}"/usr
|
||||
|
||||
install -d "${pkgdir}"/usr/lib
|
||||
find "${_stagedir}"/lib -name \*.a -exec mv {} "${pkgdir}"/usr/lib \;
|
||||
cp -a "${_stagedir}"/lib/*.a "${pkgdir}"/usr/lib/
|
||||
|
||||
install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
|
||||
"${pkgdir}"/usr/share/licenses/boost/LICENSE_1_0.txt
|
||||
|
@ -98,6 +100,7 @@ package_boost-libs() {
|
|||
|
||||
install -dm755 "${pkgdir}"/usr
|
||||
cp -a "${_stagedir}"/lib "${pkgdir}"/usr
|
||||
rm "${pkgdir}"/usr/lib/*.a
|
||||
|
||||
install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
|
||||
"${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
From e70f330af74e902d4f1b1f4891a34d315cc09963 Mon Sep 17 00:00:00 2001
|
||||
From: Gary Mirams <gary.mirams@gmail.com>
|
||||
Date: Mon, 11 Aug 2014 14:41:49 +0100
|
||||
Subject: [PATCH] Update the #includes in shared_ptr_helper.hpp to avoid
|
||||
'singleton' is not a member of 'boost::serialization' errors on compilation
|
||||
|
||||
---
|
||||
include/boost/serialization/shared_ptr_helper.hpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/include/boost/serialization/shared_ptr_helper.hpp b/include/boost/serialization/shared_ptr_helper.hpp
|
||||
index 9dace87..78995d4 100644
|
||||
--- a/include/boost/serialization/shared_ptr_helper.hpp
|
||||
+++ b/include/boost/serialization/shared_ptr_helper.hpp
|
||||
@@ -26,6 +26,8 @@
|
||||
#include <boost/type_traits/is_polymorphic.hpp>
|
||||
#include <boost/mpl/if.hpp>
|
||||
|
||||
+#include <boost/serialization/singleton.hpp>
|
||||
+#include <boost/serialization/extended_type_info.hpp>
|
||||
#include <boost/serialization/type_info_implementation.hpp>
|
||||
#include <boost/serialization/throw_exception.hpp>
|
||||
#include <boost/archive/archive_exception.hpp>
|
Loading…
Reference in a new issue