mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
added extra/python2
This commit is contained in:
parent
758ad29388
commit
633453c0ea
5 changed files with 295 additions and 0 deletions
145
extra/python2/PKGBUILD
Normal file
145
extra/python2/PKGBUILD
Normal file
|
@ -0,0 +1,145 @@
|
|||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: Jason Chu <jason@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - configure with --without-lto
|
||||
|
||||
pkgname=python2
|
||||
pkgver=2.7.13
|
||||
pkgrel=4
|
||||
_pybasever=2.7
|
||||
pkgdesc="A high-level scripting language"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('PSF')
|
||||
url="http://www.python.org/"
|
||||
depends=('bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite' 'libffi')
|
||||
makedepends=('tk' 'bluez-libs')
|
||||
checkdepends=('gdb' 'file' 'xorg-server-xvfb')
|
||||
optdepends=('tk: for IDLE'
|
||||
'python2-setuptools'
|
||||
'python2-pip')
|
||||
conflicts=('python<3')
|
||||
source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc}
|
||||
bpo-29697-don-t-use-openssl-1.0-fallback-on-1.1.patch
|
||||
bpo-30714-alpn-changes-for-openssl-1.1.0f.patch
|
||||
descr_ref.patch fix-profile-task.patch)
|
||||
sha512sums=('f37c9a28ce129d01e63c84d7db627a06402854578f62d17927334ea21ede318e04bbf66e890e3f47c85333e6b19f6e5581fb3f3e27efd24be27017d1b6529c4b'
|
||||
'SKIP'
|
||||
'115c40c36f2f18474244c758472c6b670a576d8f0289d9add005af1ed23d368738eed09fe2123df38ed5111c37ce31d998ae3db2eeff29fc5ac3065f8ea25211'
|
||||
'b32c2a0f17b3d19720187b68606024886c6b8008b7c61feaf4fe7b26b4547fddc71a2f191f87557d5fe613d06a8bc79ce5f724681a3090559fc34a032ccbf61a'
|
||||
'2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d'
|
||||
'5d7b47bfa9f13cf5fb827546189d823033278f96866366fca5257aaf819c92ffb26e2116426c84ab78d9ae3178eebb591fa4b2f22cfc2725e3e3e795fdb5c2b6')
|
||||
validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF') # Benjamin Peterson
|
||||
|
||||
prepare() {
|
||||
cd Python-${pkgver}
|
||||
|
||||
# Temporary workaround for FS#22322
|
||||
# See http://bugs.python.org/issue10835 for upstream report
|
||||
sed -i "/progname =/s/python/python${_pybasever}/" Python/pythonrun.c
|
||||
|
||||
# Enable built-in SQLite module to load extensions (fix FS#22122)
|
||||
sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
|
||||
|
||||
# FS#23997
|
||||
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python2|" Lib/cgi.py
|
||||
|
||||
sed -i "s/python2.3/python2/g" Lib/distutils/tests/test_build_scripts.py \
|
||||
Lib/distutils/tests/test_install_scripts.py
|
||||
|
||||
# Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
|
||||
# rather than copies shipped in the tarball
|
||||
rm -r Modules/expat
|
||||
rm -r Modules/zlib
|
||||
rm -r Modules/_ctypes/{darwin,libffi}*
|
||||
|
||||
# clean up #!s
|
||||
find . -name '*.py' | \
|
||||
xargs sed -i "s|#[ ]*![ ]*/usr/bin/env python$|#!/usr/bin/env python2|"
|
||||
|
||||
# Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
|
||||
touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
|
||||
|
||||
# https://bugs.python.org/issue29697
|
||||
patch -Np1 -i ../bpo-29697-don-t-use-openssl-1.0-fallback-on-1.1.patch
|
||||
|
||||
# https://bugs.python.org/issue30714
|
||||
patch -Np1 -i ../bpo-30714-alpn-changes-for-openssl-1.1.0f.patch
|
||||
|
||||
# FS#48761
|
||||
# http://bugs.python.org/issue25750
|
||||
patch -Np1 -i ../descr_ref.patch
|
||||
|
||||
# Backport from Python 3.x
|
||||
patch -Np2 -i ../fix-profile-task.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/Python-${pkgver}"
|
||||
|
||||
export OPT="${CFLAGS}"
|
||||
./configure --prefix=/usr \
|
||||
--enable-shared \
|
||||
--with-threads \
|
||||
--enable-optimizations \
|
||||
--without-lto \
|
||||
--enable-ipv6 \
|
||||
--enable-unicode=ucs4 \
|
||||
--with-system-expat \
|
||||
--with-system-ffi \
|
||||
--with-dbmliborder=gdbm:ndbm \
|
||||
--without-ensurepip
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
# Since 2.7.13,
|
||||
# test_replace_overflow (present in test_bytes, test_str, test_string, test_unicode, test_userstring) segfault on i686
|
||||
# test_bigrepeat (present in test_tuple) segfault on i686
|
||||
|
||||
cd Python-${pkgver}
|
||||
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
|
||||
xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_bytes test_str test_string test_tuple test_unicode test_userstring
|
||||
}
|
||||
|
||||
package() {
|
||||
cd Python-${pkgver}
|
||||
|
||||
# Hack to avoid building again
|
||||
sed -i 's/^all:.*$/all: build_all/' Makefile
|
||||
|
||||
make DESTDIR="${pkgdir}" altinstall maninstall
|
||||
|
||||
rm "${pkgdir}"/usr/share/man/man1/python.1
|
||||
|
||||
ln -sf python${_pybasever} "${pkgdir}"/usr/bin/python2
|
||||
ln -sf python${_pybasever}-config "${pkgdir}"/usr/bin/python2-config
|
||||
ln -sf python${_pybasever}.1 "${pkgdir}"/usr/share/man/man1/python2.1
|
||||
|
||||
# FS#33954
|
||||
ln -sf python-${_pybasever}.pc "${pkgdir}"/usr/lib/pkgconfig/python2.pc
|
||||
|
||||
ln -sf ../../libpython${_pybasever}.so "${pkgdir}"/usr/lib/python${_pybasever}/config/libpython${_pybasever}.so
|
||||
|
||||
mv "${pkgdir}"/usr/bin/smtpd.py "${pkgdir}"/usr/lib/python${_pybasever}/
|
||||
|
||||
# some useful "stuff"
|
||||
install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
|
||||
install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
|
||||
install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
|
||||
|
||||
# fix conflicts with python
|
||||
mv "${pkgdir}"/usr/bin/idle{,2}
|
||||
mv "${pkgdir}"/usr/bin/pydoc{,2}
|
||||
mv "${pkgdir}"/usr/bin/2to3{,-2.7}
|
||||
|
||||
# clean-up reference to build directory
|
||||
sed -i "s#${srcdir}/Python-${pkgver}:##" "${pkgdir}"/usr/lib/python${_pybasever}/config/Makefile
|
||||
|
||||
# license
|
||||
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
||||
}
|
|
@ -0,0 +1,28 @@
|
|||
From f1a696efd6ca674579e25de29ec4053ff5a5ade1 Mon Sep 17 00:00:00 2001
|
||||
From: Donald Stufft <donald@stufft.io>
|
||||
Date: Thu, 2 Mar 2017 12:37:07 -0500
|
||||
Subject: [PATCH] bpo-29697: Don't use OpenSSL <1.0.2 fallback on 1.1+ (GH-399)
|
||||
|
||||
---
|
||||
Modules/_ssl.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/_ssl.c b/Modules/_ssl.c
|
||||
index a92710077cc..4fff16f6f49 100644
|
||||
--- a/Modules/_ssl.c
|
||||
+++ b/Modules/_ssl.c
|
||||
@@ -2166,12 +2166,12 @@ context_new(PyTypeObject *type, PyObject *args, PyObject *kwds)
|
||||
options |= SSL_OP_NO_SSLv3;
|
||||
SSL_CTX_set_options(self->ctx, options);
|
||||
|
||||
-#ifndef OPENSSL_NO_ECDH
|
||||
+#if !defined(OPENSSL_NO_ECDH) && !defined(OPENSSL_VERSION_1_1)
|
||||
/* Allow automatic ECDH curve selection (on OpenSSL 1.0.2+), or use
|
||||
prime256v1 by default. This is Apache mod_ssl's initialization
|
||||
policy, so we should be safe. OpenSSL 1.1 has it enabled by default.
|
||||
*/
|
||||
-#if defined(SSL_CTX_set_ecdh_auto) && !defined(OPENSSL_VERSION_1_1)
|
||||
+#if defined(SSL_CTX_set_ecdh_auto)
|
||||
SSL_CTX_set_ecdh_auto(self->ctx, 1);
|
||||
#else
|
||||
{
|
|
@ -0,0 +1,51 @@
|
|||
From 0e396a20c3137244b1774bd14a0cb03921ff326d Mon Sep 17 00:00:00 2001
|
||||
From: Christian Heimes <christian@python.org>
|
||||
Date: Tue, 20 Jun 2017 18:28:38 +0200
|
||||
Subject: [PATCH] bpo-30714: ALPN changes for OpenSSL 1.1.0f
|
||||
|
||||
OpenSSL 1.1.0 to 1.1.0e aborted the handshake when server and client
|
||||
could not agree on a protocol using ALPN. OpenSSL 1.1.0f changed that.
|
||||
The most recent version now behaves like OpenSSL 1.0.2 again. The ALPN
|
||||
callback can pretend to not been set.
|
||||
|
||||
See https://github.com/openssl/openssl/pull/3158 for more details
|
||||
|
||||
Signed-off-by: Christian Heimes <christian@python.org>
|
||||
---
|
||||
Doc/library/ssl.rst | 5 +++--
|
||||
Lib/test/test_ssl.py | 5 +++--
|
||||
Misc/NEWS | 3 +++
|
||||
3 files changed, 9 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Doc/library/ssl.rst b/Doc/library/ssl.rst
|
||||
index 729a239a1ba..b51b9c6e396 100644
|
||||
--- a/Doc/library/ssl.rst
|
||||
+++ b/Doc/library/ssl.rst
|
||||
@@ -1447,8 +1447,9 @@ to speed up repeated connections from the same clients.
|
||||
This method will raise :exc:`NotImplementedError` if :data:`HAS_ALPN` is
|
||||
False.
|
||||
|
||||
- OpenSSL 1.1.0+ will abort the handshake and raise :exc:`SSLError` when
|
||||
- both sides support ALPN but cannot agree on a protocol.
|
||||
+ OpenSSL 1.1.0 to 1.1.0e will abort the handshake and raise :exc:`SSLError`
|
||||
+ when both sides support ALPN but cannot agree on a protocol. 1.1.0f+
|
||||
+ behaves like 1.0.2.
|
||||
|
||||
.. versionadded:: 3.5
|
||||
|
||||
diff --git a/Lib/test/test_ssl.py b/Lib/test/test_ssl.py
|
||||
index fdaf1c52046..3215031206c 100644
|
||||
--- a/Lib/test/test_ssl.py
|
||||
+++ b/Lib/test/test_ssl.py
|
||||
@@ -3267,8 +3267,9 @@ def test_alpn_protocols(self):
|
||||
except ssl.SSLError as e:
|
||||
stats = e
|
||||
|
||||
- if expected is None and IS_OPENSSL_1_1:
|
||||
- # OpenSSL 1.1.0 raises handshake error
|
||||
+ if (expected is None and IS_OPENSSL_1_1
|
||||
+ and ssl.OPENSSL_VERSION_INFO < (1, 1, 0, 6)):
|
||||
+ # OpenSSL 1.1.0 to 1.1.0e raises handshake error
|
||||
self.assertIsInstance(stats, ssl.SSLError)
|
||||
else:
|
||||
msg = "failed trying %s (s) and %s (c).\n" \
|
58
extra/python2/descr_ref.patch
Normal file
58
extra/python2/descr_ref.patch
Normal file
|
@ -0,0 +1,58 @@
|
|||
When calling tp_descr_get(self, obj, type), make sure that we own a reference to "self"
|
||||
|
||||
diff -ru Python-2.7.9/Objects/typeobject.c Python-2.7.9-fixed//Objects/typeobject.c
|
||||
--- Python-2.7.9/Objects/typeobject.c 2014-12-10 16:59:57.000000000 +0100
|
||||
+++ Python-2.7.9-fixed//Objects/typeobject.c 2015-11-27 20:39:58.276156800 +0100
|
||||
@@ -2542,6 +2542,7 @@
|
||||
PyTypeObject *metatype = Py_TYPE(type);
|
||||
PyObject *meta_attribute, *attribute;
|
||||
descrgetfunc meta_get;
|
||||
+ PyObject* res;
|
||||
|
||||
if (!PyString_Check(name)) {
|
||||
PyErr_Format(PyExc_TypeError,
|
||||
@@ -2563,6 +2564,7 @@
|
||||
meta_attribute = _PyType_Lookup(metatype, name);
|
||||
|
||||
if (meta_attribute != NULL) {
|
||||
+ Py_INCREF(meta_attribute);
|
||||
meta_get = Py_TYPE(meta_attribute)->tp_descr_get;
|
||||
|
||||
if (meta_get != NULL && PyDescr_IsData(meta_attribute)) {
|
||||
@@ -2570,10 +2572,11 @@
|
||||
* writes. Assume the attribute is not overridden in
|
||||
* type's tp_dict (and bases): call the descriptor now.
|
||||
*/
|
||||
- return meta_get(meta_attribute, (PyObject *)type,
|
||||
+ res = meta_get(meta_attribute, (PyObject *)type,
|
||||
(PyObject *)metatype);
|
||||
+ Py_DECREF(meta_attribute);
|
||||
+ return res;
|
||||
}
|
||||
- Py_INCREF(meta_attribute);
|
||||
}
|
||||
|
||||
/* No data descriptor found on metatype. Look in tp_dict of this
|
||||
@@ -2581,6 +2584,7 @@
|
||||
attribute = _PyType_Lookup(type, name);
|
||||
if (attribute != NULL) {
|
||||
/* Implement descriptor functionality, if any */
|
||||
+ Py_INCREF(attribute);
|
||||
descrgetfunc local_get = Py_TYPE(attribute)->tp_descr_get;
|
||||
|
||||
Py_XDECREF(meta_attribute);
|
||||
@@ -2588,11 +2592,12 @@
|
||||
if (local_get != NULL) {
|
||||
/* NULL 2nd argument indicates the descriptor was
|
||||
* found on the target object itself (or a base) */
|
||||
- return local_get(attribute, (PyObject *)NULL,
|
||||
+ res = local_get(attribute, (PyObject *)NULL,
|
||||
(PyObject *)type);
|
||||
+ Py_DECREF(attribute);
|
||||
+ return res;
|
||||
}
|
||||
|
||||
- Py_INCREF(attribute);
|
||||
return attribute;
|
||||
}
|
||||
|
13
extra/python2/fix-profile-task.patch
Normal file
13
extra/python2/fix-profile-task.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/Python-2.7.13/Makefile.pre.in b/Python-2.7.13/Makefile.pre.in
|
||||
index e288964..22edc27 100644
|
||||
--- a/Python-2.7.13/Makefile.pre.in
|
||||
+++ b/Python-2.7.13/Makefile.pre.in
|
||||
@@ -456,7 +456,7 @@ build_all_generate_profile:
|
||||
|
||||
run_profile_task:
|
||||
: # FIXME: can't run for a cross build
|
||||
- $(LLVM_PROF_FILE) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
|
||||
+ $(LLVM_PROF_FILE) $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
|
||||
|
||||
build_all_merge_profile:
|
||||
$(LLVM_PROF_MERGER)
|
Loading…
Reference in a new issue