community/freerdp to 1.2.0_20160107-1

This commit is contained in:
Kevin Mihelich 2016-01-07 13:36:51 +00:00
parent cfac2bfa01
commit 633bf02b3d
2 changed files with 6 additions and 36 deletions

View file

@ -3,11 +3,11 @@
# Contributor: Stijn Segers <francesco dot borromini at gmail dot com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - define WITH_NEON and ARM_FP_ABI to fix retard developer assumptions
# - define WITH_NEON and ARM_FP_ABI
pkgname=freerdp
epoch=1
pkgver=1.2.0_beta1+android9
pkgver=1.2.0_20160107
_pkgver=${pkgver/_/-}
_pkgver=${_pkgver/+/-}
pkgrel=1
@ -21,13 +21,9 @@ depends=('openssl' 'libxcursor' 'libcups' 'alsa-lib' 'libxext' 'libxdamage'
makedepends=('krb5' 'cmake' 'damageproto' 'fixesproto' 'renderproto'
'xmlto' 'docbook-xsl' 'git')
conflicts=('freerdp-git')
#source=(FreeRDP-${_pkgver}::git://github.com/FreeRDP/FreeRDP.git#commit=ff6dbb049ce066f6fca5708f81fd33f97086bc0e
source=($pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/FreeRDP/archive/${pkgver/_/-}.tar.gz
https://github.com/FreeRDP/FreeRDP/commit/1b663ceffe51008af7ae9749e5b7999b2f7d6698.patch
stuck_winkey.patch)
md5sums=('a4a0a4f6e69c871aeab0600091ca6118'
'83da0f44c0e1a51707fad5ed06fd7b06'
'd29f028e61967f091f021d24005dbee2')
#source=($pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/FreeRDP/archive/${pkgver/_/-}.tar.gz)
source=(FreeRDP-${_pkgver}::git://github.com/FreeRDP/FreeRDP.git#commit=c3ce0c3b09bf10f388011e01bb4091e351af39e9)
md5sums=('SKIP')
prepare() {
cd $srcdir/FreeRDP-${_pkgver}
@ -49,6 +45,7 @@ build() {
-DWITH_CHANNELS=ON \
-DWITH_CLIENT_CHANNELS=ON \
-DWITH_SERVER_CHANNELS=ON \
-DWITH_WAYLAND=ON \
-DWITH_NEON=OFF \
-DARM_FP_ABI=${ABI} \
.

View file

@ -1,27 +0,0 @@
diff -rup ./client/X11.old/xf_event.c ./client/X11/xf_event.c
--- ./client/X11.old/xf_event.c 2014-06-12 15:51:57.000000000 +0200
+++ ./client/X11/xf_event.c 2014-10-22 16:53:53.440644196 +0200
@@ -556,6 +556,7 @@ static BOOL xf_event_FocusOut(xfContext*
if (event->xfocus.mode == NotifyWhileGrabbed)
XUngrabKeyboard(xfc->display, CurrentTime);
+ xf_keyboard_release_all_keypress(xfc);
xf_keyboard_clear(xfc);
if (app)
diff -rup ./client/X11.old/xf_keyboard.c ./client/X11/xf_keyboard.c
--- ./client/X11.old/xf_keyboard.c 2014-06-12 15:51:57.000000000 +0200
+++ ./client/X11/xf_keyboard.c 2014-10-22 16:57:58.403749478 +0200
@@ -169,6 +169,12 @@ void xf_keyboard_release_all_keypress(xf
if (xfc->KeyboardState[keycode] != NoSymbol)
{
rdp_scancode = freerdp_keyboard_get_rdp_scancode_from_x11_keycode(keycode);
+
+ // release tab before releasing the windows key.
+ // this stops the start menu from opening on unfocus event.
+ if (rdp_scancode == RDP_SCANCODE_LWIN)
+ freerdp_input_send_keyboard_event_ex(xfc->instance->input, FALSE, RDP_SCANCODE_TAB);
+
freerdp_input_send_keyboard_event_ex(xfc->instance->input, FALSE, rdp_scancode);
xfc->KeyboardState[keycode] = NoSymbol;
}