mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-gru to 4.4.79-1
This commit is contained in:
parent
74933c9116
commit
6376533844
6 changed files with 268 additions and 306 deletions
|
@ -1,4 +1,4 @@
|
|||
From f743d19646e09522664ef5ca48549d32f7f42bbf Mon Sep 17 00:00:00 2001
|
||||
From 69c6eaeae8786cb0ea9f4111274403fbc221eb15 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 15 Feb 2017 18:32:55 -0700
|
||||
Subject: [PATCH 1/4] Input: atmel_mxt_ts: Use KERN_DEBUG loglevel for status
|
||||
|
@ -10,10 +10,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers/input/touchscreen/atmel_mxt_ts.c
|
||||
index 6a13f44e4cd8..4ee0679c5516 100644
|
||||
index b89c2c8e2c05..2f8c1887a3d8 100644
|
||||
--- a/drivers/input/touchscreen/atmel_mxt_ts.c
|
||||
+++ b/drivers/input/touchscreen/atmel_mxt_ts.c
|
||||
@@ -1434,7 +1434,7 @@ static int mxt_proc_messages(struct mxt_data *data, u8 count, bool report)
|
||||
@@ -1435,7 +1435,7 @@ static int mxt_proc_messages(struct mxt_data *data, u8 count, bool report)
|
||||
const u8 *payload = &msg[1];
|
||||
u8 status = payload[0];
|
||||
data->config_csum = mxt_extract_T6_csum(&payload[1]);
|
||||
|
@ -23,5 +23,5 @@ index 6a13f44e4cd8..4ee0679c5516 100644
|
|||
if (status == 0x00)
|
||||
complete(&data->auto_cal_completion);
|
||||
--
|
||||
2.12.2
|
||||
2.14.1
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From ab0985215b2a3440bedff7b07a38c720a9ea1b47 Mon Sep 17 00:00:00 2001
|
||||
From 7f0c0725ee953b8ddbc45815354717153b8801ba Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 5 Apr 2017 22:55:05 -0600
|
||||
Subject: [PATCH 2/4] Revert "CHROMIUM: drm: rockchip: Add PSR residency debug
|
||||
|
@ -10,7 +10,7 @@ This reverts commit 9f416401b95d3f1dee2ffb12e0e27339fce3ce1b.
|
|||
1 file changed, 1 insertion(+), 20 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c b/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c
|
||||
index f2766cafd0b4..acd31ea3825d 100644
|
||||
index 9e953ee0d003..8d52abeb3f0b 100644
|
||||
--- a/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c
|
||||
+++ b/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c
|
||||
@@ -13,7 +13,6 @@
|
||||
|
@ -36,10 +36,10 @@ index f2766cafd0b4..acd31ea3825d 100644
|
|||
struct rockchip_dp_device *dp = to_dp(encoder);
|
||||
struct drm_crtc *crtc = dp->encoder.crtc;
|
||||
- s64 delta_ms;
|
||||
int vact_end;
|
||||
int ret;
|
||||
|
||||
@@ -103,7 +97,6 @@ static int analogix_dp_psr_set(struct drm_encoder *encoder, bool enabled)
|
||||
dev_dbg(dp->dev, "%s PSR...\n", enabled ? "enable" : "disable");
|
||||
@@ -100,7 +94,6 @@ static int analogix_dp_psr_set(struct drm_encoder *encoder, bool enabled)
|
||||
return ret;
|
||||
}
|
||||
rockchip_drm_set_win_enabled(crtc, false);
|
||||
|
@ -47,7 +47,7 @@ index f2766cafd0b4..acd31ea3825d 100644
|
|||
} else {
|
||||
rockchip_drm_set_win_enabled(crtc, true);
|
||||
ret = analogix_dp_disable_psr(dp->adp);
|
||||
@@ -111,9 +104,6 @@ static int analogix_dp_psr_set(struct drm_encoder *encoder, bool enabled)
|
||||
@@ -108,9 +101,6 @@ static int analogix_dp_psr_set(struct drm_encoder *encoder, bool enabled)
|
||||
dev_err(dp->dev, "failed to disable psr %d\n", ret);
|
||||
return ret;
|
||||
}
|
||||
|
@ -57,7 +57,7 @@ index f2766cafd0b4..acd31ea3825d 100644
|
|||
}
|
||||
return 0;
|
||||
}
|
||||
@@ -397,17 +387,9 @@ static int rockchip_dp_bind(struct device *dev, struct device *master,
|
||||
@@ -394,17 +384,9 @@ static int rockchip_dp_bind(struct device *dev, struct device *master,
|
||||
dp->plat_data.power_off = rockchip_dp_powerdown;
|
||||
dp->plat_data.get_modes = rockchip_dp_get_modes;
|
||||
|
||||
|
@ -76,7 +76,7 @@ index f2766cafd0b4..acd31ea3825d 100644
|
|||
|
||||
rockchip_drm_psr_register(&dp->encoder, analogix_dp_psr_set);
|
||||
|
||||
@@ -422,7 +404,6 @@ static void rockchip_dp_unbind(struct device *dev, struct device *master,
|
||||
@@ -419,7 +401,6 @@ static void rockchip_dp_unbind(struct device *dev, struct device *master,
|
||||
rockchip_drm_psr_unregister(&dp->encoder);
|
||||
|
||||
analogix_dp_unbind(dp->adp);
|
||||
|
@ -85,5 +85,5 @@ index f2766cafd0b4..acd31ea3825d 100644
|
|||
dp->adp = ERR_PTR(-ENODEV);
|
||||
}
|
||||
--
|
||||
2.12.2
|
||||
2.14.1
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From b926a0837eb5b744568fc2eca1d63a3692e1b25c Mon Sep 17 00:00:00 2001
|
||||
From 5b406d74d5217e3f29b802c57010ef506b09878b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 26 Feb 2017 19:14:10 -0700
|
||||
Subject: [PATCH 3/4] temporary hack to fix console output
|
||||
|
@ -8,10 +8,10 @@ Subject: [PATCH 3/4] temporary hack to fix console output
|
|||
1 file changed, 14 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c b/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c
|
||||
index acd31ea3825d..383129f82093 100644
|
||||
index 8d52abeb3f0b..19d0f9d8b4d0 100644
|
||||
--- a/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c
|
||||
+++ b/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c
|
||||
@@ -90,20 +90,6 @@ static int analogix_dp_psr_set(struct drm_encoder *encoder, bool enabled)
|
||||
@@ -87,20 +87,6 @@ static int analogix_dp_psr_set(struct drm_encoder *encoder, bool enabled)
|
||||
dev_err(dp->dev, "line flag interrupt did not arrive\n");
|
||||
return -ETIMEDOUT;
|
||||
}
|
||||
|
@ -33,5 +33,5 @@ index acd31ea3825d..383129f82093 100644
|
|||
return 0;
|
||||
}
|
||||
--
|
||||
2.12.2
|
||||
2.14.1
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From fb997ad6c00fcd16102805aa1cd98ede592dc577 Mon Sep 17 00:00:00 2001
|
||||
From bb6481e5f5d78cb83fc07e845766f8094bc51112 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Apr 2017 13:42:34 -0600
|
||||
Subject: [PATCH 4/4] skip HDCP setup
|
||||
|
@ -130,5 +130,5 @@ index e10ac220ef4b..c9d94e17b13c 100644
|
|||
|
||||
err_free_connector:
|
||||
--
|
||||
2.12.2
|
||||
2.14.1
|
||||
|
||||
|
|
|
@ -6,9 +6,9 @@ buildarch=8
|
|||
pkgbase=linux-gru
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Gru Chromebooks"
|
||||
pkgver=4.4.52
|
||||
pkgrel=4
|
||||
_commit=fb0e5f6ed779a218ace2839ef7a34a23830bd30b
|
||||
pkgver=4.4.79
|
||||
pkgrel=1
|
||||
_commit=3069b8b9061c70a0427f00fd36a0878e3c44a0d2
|
||||
arch=('aarch64')
|
||||
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-4.4"
|
||||
license=('GPL2')
|
||||
|
@ -23,13 +23,13 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
|
|||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk')
|
||||
md5sums=('6d8a8aa615b78f5794b4028d0ad2c0be'
|
||||
'84934e2f687a23f3f7160cdfe32bb211'
|
||||
'39f5a13ccc90bd47e890e0e01a1343ec'
|
||||
'f27e1cb28474d4882a9daec52d45becd'
|
||||
'a2e62054e7b21c9055470db6a8c17ae8'
|
||||
'ec598df9385f8c993e05238ec38e5b1f'
|
||||
'ded019b1c1e32c53b98e602f46ea1ba0'
|
||||
md5sums=('75ba3888c261269450eafa39001683ec'
|
||||
'61adb09d59c65c2df72135180ee39f8d'
|
||||
'6abb843c77b2fc684b1a4c6b21ac2b7e'
|
||||
'6c2221b2f8856a2d6a7a6de7eacab03a'
|
||||
'548731c6c4abc1e9679dabb3f53d2652'
|
||||
'9aa22cbed3e1b3a3adbcf65f80844a49'
|
||||
'25dea537b93937f77b92cde7adffcb55'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8')
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue