community/mysql-workbench to 6.3.7-2

This commit is contained in:
Kevin Mihelich 2016-07-29 15:35:51 +00:00
parent 95b13fca75
commit 637efcac56
2 changed files with 5 additions and 41 deletions

View file

@ -1,30 +0,0 @@
From 34ec0d65ede8392ba3e0f114d72672b3f517f964 Mon Sep 17 00:00:00 2001
From: Christian Hesse <mail@eworm.de>
Date: Tue, 10 May 2016 01:09:34 +0200
Subject: [PATCH 1/1] do not pass type to std::make_pair()
We not pass type template arguments to std::make_pair()
explicitly, and let the compiler deduce them on its own.
This fixes compiler error on GCC 6.1.1.
Signed-off-by: Christian Hesse <mail@eworm.de>
---
client/auth_utils.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/client/auth_utils.cc b/client/auth_utils.cc
index 21416bb..03fd71c 100644
--- a/client/auth_utils.cc
+++ b/client/auth_utils.cc
@@ -61,7 +61,7 @@ int parse_cnf_file(istream &sin, map<string, string > *options,
getline(sin, option_value);
trim(&option_value);
if (option_name.length() > 0)
- options->insert(make_pair<string, string >(option_name, option_value));
+ options->insert(make_pair(option_name, option_value));
}
return ALL_OK;
} catch(...)
--
2.8.2

View file

@ -10,10 +10,10 @@
pkgname=mysql-workbench
pkgver=6.3.7
pkgrel=1
_mysql_version=5.7.13
pkgrel=2
_mysql_version=5.7.14
_connector_version=1.1.7
_gdal_version=2.1.0
_gdal_version=2.1.1
_boost_version=1.59.0
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
arch=('i686' 'x86_64')
@ -32,26 +32,20 @@ source=("http://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-
"http://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-${_connector_version}.tar.gz"{,.asc}
"http://download.osgeo.org/gdal/${_gdal_version}/gdal-${_gdal_version}.tar.xz"
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
'0001-do-not-pass-type-to-std-make_pair.patch'
'0001-mysql-workbench-no-check-for-updates.patch'
'arch_linux_profile.xml')
sha256sums=('84941f6dc33674a245d53a21bc14c5f0c192e370940147ddc7c236a61c0193ec'
'SKIP'
'50bf1a1635a61235fc43fd4876df2f77163de109372679e29c1ff8dbc38a0b87'
'f7415bdac2ca8bbccd77d4f22d8a0bdd7280b065bd646a71a506b77c7a8bd169'
'SKIP'
'5b353fbcd26f607a2a0987ce78a4b811f8971813d46b0f4ae6fa07887e9fc763'
'SKIP'
'568b43441955b306364fcf97fb47d4c1512ac6f2f5f76b2ec39a890d2418ee03'
'87ce516ce757ad1edf1e21f007fbe232ed2e932af422e9893f40199711c41f92'
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
'9088cdcf82c1a925806d9162702e19c94fa21d89d422370df3f5700e204f5b32'
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
prepare() {
cd "${srcdir}/mysql-${_mysql_version}"
patch -Np1 < "${srcdir}"/0001-do-not-pass-type-to-std-make_pair.patch
cd "${srcdir}/mysql-workbench-community-${pkgver}-src/"
# Disable 'Help' -> 'Check for Updates'