extra/chromium to 44.0.2403.89-1

This commit is contained in:
Kevin Mihelich 2015-07-22 18:16:14 +00:00
parent 6fbf2d00f4
commit 63b6a38876
2 changed files with 3 additions and 134 deletions

View file

@ -21,7 +21,7 @@
buildarch=4
pkgname=chromium
pkgver=43.0.2357.134
pkgver=44.0.2403.89
pkgrel=1
_launcher_ver=2
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
@ -45,12 +45,11 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium.desktop
0001-NSS-reject-DH-groups-smaller-than-1024-bits.patch
0001-Use-the-correct-URL-for-ERR_SSL_WEAK_SERVER_EPHEMERA.patch
add-build-flag-to-disable-hotwording.patch
arm-webrtc-fix.patch
chromium-arm-r0.patch
v6-ffmpeg.patch
chromium-widevine.patch)
sha256sums=('d3a1bbe3e1445dfcf5ef4aff4b11a8f3770436c8b8954b7cc5fee5416f117659'
sha256sums=('badd9aa979487b55bbcce4f54ec16926c6fa7eb46ec2536866200a5e68853a98'
'7f91c81721092d707d7b94e6555a48bc7fd0bc0e1174df4649bdcd745930e52f'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'46daf921ed7eaab175f5a86b09357c69c33a10ffe1d4e7c24476af510c1b28d0'
@ -79,12 +78,6 @@ prepare() {
# https://code.google.com/p/chromium/issues/detail?id=490260
patch -Np1 -i ../0001-Use-the-correct-URL-for-ERR_SSL_WEAK_SERVER_EPHEMERA.patch
# Add build flag to disable 'Ok Google' hotwording feature
# The issue with this functionality is that it downloads a binary blob
# and that this behavior cannot be disabled if a user wishes to do so.
# https://code.google.com/p/chromium/issues/detail?id=491435
patch -Np1 -i ../add-build-flag-to-disable-hotwording.patch
# Enable support for the Widevine CDM plugin
# The actual libraries are not included, but can be copied over from Chrome:
# libwidevinecdmadapter.so
@ -184,7 +177,6 @@ fi
-Duse_system_zlib=0
-Dusb_ids_path=/usr/share/hwdata/usb.ids
-Duse_gconf=0
-Denable_hotwording=0
-Ddisable_fatal_linker_warnings=1
-Ddisable_glibc=1
-Ddisable_sse2=1
@ -224,10 +216,7 @@ package() {
install -Dm4755 out/Release/chrome_sandbox \
"$pkgdir/usr/lib/chromium/chrome-sandbox"
cp out/Release/{*.pak,*.bin,libffmpegsumo.so} \
"$pkgdir/usr/lib/chromium/"
strip $STRIP_SHARED "$pkgdir/usr/lib/chromium/libffmpegsumo.so"
cp out/Release/{*.pak,*.bin} "$pkgdir/usr/lib/chromium/"
cp -a out/Release/locales "$pkgdir/usr/lib/chromium/"

View file

@ -1,120 +0,0 @@
Index: build/common.gypi
diff --git a/build/common.gypi b/build/common.gypi
index b26d0e1aaf3baa8c0bea2aa21795051e0767bb39..bac0544541b1ffbd4c9a072e86425476f01fa3d9 100644
--- a/build/common.gypi
+++ b/build/common.gypi
@@ -391,6 +391,9 @@
# Web speech is enabled by default. Set to 0 to disable.
'enable_web_speech%': 1,
+ # 'Ok Google' hotwording is enabled by default. Set to 0 to disable.
+ 'enable_hotwording%': 1,
+
# Notifications are compiled in by default. Set to 0 to disable.
'notifications%' : 1,
@@ -1136,6 +1139,7 @@
'configuration_policy%': '<(configuration_policy)',
'safe_browsing%': '<(safe_browsing)',
'enable_web_speech%': '<(enable_web_speech)',
+ 'enable_hotwording%': '<(enable_hotwording)',
'notifications%': '<(notifications)',
'clang_use_chrome_plugins%': '<(clang_use_chrome_plugins)',
'mac_want_real_dsym%': '<(mac_want_real_dsym)',
Index: chrome/browser/BUILD.gn
diff --git a/chrome/browser/BUILD.gn b/chrome/browser/BUILD.gn
index 30127a3a2ee6836ffb108fd2859707b765d42cb8..867dc390d0b7f623423ed64bfbbe5f938fbc0659 100644
--- a/chrome/browser/BUILD.gn
+++ b/chrome/browser/BUILD.gn
@@ -19,6 +19,11 @@ if (is_desktop_linux) {
import("//build/config/linux/pkg_config.gni")
}
+declare_args() {
+ # 'Ok Google' hotwording is enabled.
+ enable_hotwording = true
+}
+
about_credits_file = "$target_gen_dir/about_credits.html"
additional_modules_list_file =
"$root_gen_dir/chrome/browser/internal/additional_modules_list.txt"
@@ -452,6 +457,10 @@ source_set("browser") {
}
}
+ if (enable_hotwording) {
+ defines += [ "ENABLE_HOTWORDING" ]
+ }
+
if (is_linux) {
deps += [
"//device/media_transfer_protocol",
Index: chrome/browser/search/hotword_service.cc
diff --git a/chrome/browser/search/hotword_service.cc b/chrome/browser/search/hotword_service.cc
index d222b150fbae877fe74598681e956e6e624890fa..5b08027ef4c198480f703a9420a55068e88aa435 100644
--- a/chrome/browser/search/hotword_service.cc
+++ b/chrome/browser/search/hotword_service.cc
@@ -639,7 +639,11 @@ bool HotwordService::IsServiceAvailable() {
if (group == hotword_internal::kHotwordFieldTrialDisabledGroupName)
return false;
+#if defined(ENABLE_HOTWORDING)
return DoesHotwordSupportLanguage(profile_);
+#else
+ return false;
+#endif
}
bool HotwordService::IsOptedIntoAudioLogging() {
Index: chrome/browser/search/hotword_service_unittest.cc
diff --git a/chrome/browser/search/hotword_service_unittest.cc b/chrome/browser/search/hotword_service_unittest.cc
index 588706c1c186e7f410230b12f649a6b8853da2fb..84444468e2f7634ad895d0752355303babf0c7d7 100644
--- a/chrome/browser/search/hotword_service_unittest.cc
+++ b/chrome/browser/search/hotword_service_unittest.cc
@@ -157,6 +157,7 @@ INSTANTIATE_TEST_CASE_P(HotwordServiceTests,
extension_misc::kHotwordSharedModuleId));
TEST_P(HotwordServiceTest, IsHotwordAllowedLocale) {
+#if defined(ENABLE_HOTWORDING)
TestingProfile::Builder profile_builder;
scoped_ptr<TestingProfile> profile = profile_builder.Build();
@@ -187,6 +188,7 @@ TEST_P(HotwordServiceTest, IsHotwordAllowedLocale) {
Profile* otr_profile = profile->GetOffTheRecordProfile();
SetApplicationLocale(otr_profile, "en");
EXPECT_FALSE(HotwordServiceFactory::IsHotwordAllowed(otr_profile));
+#endif // defined(ENABLE_HOTWORDING)
}
TEST_P(HotwordServiceTest, ShouldReinstallExtension) {
@@ -243,6 +245,7 @@ TEST_P(HotwordServiceTest, PreviousLanguageSetOnInstall) {
}
TEST_P(HotwordServiceTest, UninstallReinstallTriggeredCorrectly) {
+#if defined(ENABLE_HOTWORDING)
InitializeEmptyExtensionService();
service_->Init();
@@ -313,6 +316,7 @@ TEST_P(HotwordServiceTest, UninstallReinstallTriggeredCorrectly) {
EXPECT_TRUE(HotwordServiceFactory::IsHotwordAllowed(profile()));
EXPECT_FALSE(hotword_service->MaybeReinstallHotwordExtension());
EXPECT_EQ(1, hotword_service->uninstall_count()); // no change
+#endif // defined(ENABLE_HOTWORDING)
}
TEST_P(HotwordServiceTest, DisableAlwaysOnOnLanguageChange) {
Index: chrome/chrome_browser.gypi
diff --git a/chrome/chrome_browser.gypi b/chrome/chrome_browser.gypi
index 4070c8c38867d2394d3a2a60b1cd17361ccea1c3..b589e9a52e0ca183da7bee5a644c0de8f61a0d89 100644
--- a/chrome/chrome_browser.gypi
+++ b/chrome/chrome_browser.gypi
@@ -3573,6 +3573,9 @@
['enable_session_service==1', {
'sources': [ '<@(chrome_browser_session_service_sources)' ],
}],
+ ['enable_hotwording==1', {
+ 'defines': [ 'ENABLE_HOTWORDING' ],
+ }],
['OS!="android" and OS!="ios" and chromeos==0', {
'sources': [ '<@(chrome_browser_desktop_sources)' ],
}],