mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/vlc to 3.0.11.1-3
This commit is contained in:
parent
08d755932b
commit
63b6c9ba17
2 changed files with 2 additions and 31 deletions
|
@ -11,7 +11,7 @@ _vlcver=3.0.11.1
|
|||
# optional fixup version including hyphen
|
||||
_vlcfixupver=
|
||||
pkgver=${_vlcver}${_vlcfixupver//-/.r}
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
|
||||
url='https://www.videolan.org/vlc/'
|
||||
arch=('x86_64')
|
||||
|
@ -129,6 +129,7 @@ build() {
|
|||
export CFLAGS+=" -I/usr/include/samba-4.0"
|
||||
export CPPFLAGS+=" -I/usr/include/samba-4.0"
|
||||
export CXXFLAGS+=" -std=c++11"
|
||||
# upstream doesn't support lua 5.4 yet: https://trac.videolan.org/vlc/ticket/25036
|
||||
export LUAC=/usr/bin/luac5.2
|
||||
export LUA_LIBS="$(pkg-config --libs lua5.2)"
|
||||
export RCC=/usr/bin/rcc-qt5
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
commit 41caaa08cde60c4fec4bf2e5f9610e2a1b9e6a23
|
||||
Author: Vinson Lee <vlee@freedesktop.org>
|
||||
Date: Thu Feb 5 14:48:53 2015 -0800
|
||||
|
||||
lua: Define LUA_COMPAT_APIINTCASTS for Lua >= 5.3.0 compatibility.
|
||||
|
||||
In Lua 5.3.0, luaL_checkint was deprecated.
|
||||
|
||||
This patch fixes this build error with Lua 5.3.0.
|
||||
|
||||
lua/demux.c: In function ‘vlclua_demux_peek’:
|
||||
lua/demux.c:55:5: error: implicit declaration of function ‘luaL_checkint’ [-Werror=implicit-function-declaration]
|
||||
int n = luaL_checkint( L, 1 );
|
||||
^
|
||||
|
||||
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
|
||||
Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
|
||||
|
||||
diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
|
||||
index efd94f1..85c7fc1 100644
|
||||
--- a/modules/lua/vlc.h
|
||||
+++ b/modules/lua/vlc.h
|
||||
@@ -38,6 +38,7 @@
|
||||
#include <vlc_stream.h>
|
||||
#include <vlc_demux.h>
|
||||
|
||||
+#define LUA_COMPAT_APIINTCASTS
|
||||
#define LUA_COMPAT_MODULE
|
||||
#include <lua.h> /* Low level lua C API */
|
||||
#include <lauxlib.h> /* Higher level C API */
|
Loading…
Reference in a new issue